Jump to content
jono grant

Cakewalk randomly ignores High DPI scaling

Recommended Posts

I have my 4K monitor and system set to the recommended 150%  scaling so I can see properly.

Cakewalk randomly ignores it and I'm continually going in and having to set the scaling over and over again.  All my video drivers all up to date etc.

Does anyone else have this issue?

Have you heard of this @Noel Borthwick ?

Thank you!

Jono

Share this post


Link to post
Share on other sites

Hi Jono,
That's very odd. I haven't heard of anything like this, apart from maybe one guy who had to set some custom DPI settings or CbB would crash on startup (which should now be fixed anyway, at least in the latest Early Access release).
When you say "I'm continually going in and having to set the scaling over and over again", what is it that you're doing specifically? Are you going into Windows Settings to set it to 150% again, or something else? Also, what version of Windows are you using?
Thanks,
Ben

Share this post


Link to post
Share on other sites
On 5/28/2020 at 4:05 AM, Ben Staton said:

Hi Jono,
That's very odd. I haven't heard of anything like this, apart from maybe one guy who had to set some custom DPI settings or CbB would crash on startup (which should now be fixed anyway, at least in the latest Early Access release).
When you say "I'm continually going in and having to set the scaling over and over again", what is it that you're doing specifically? Are you going into Windows Settings to set it to 150% again, or something else? Also, what version of Windows are you using?
Thanks,
Ben

I'm on Windows 10.

Windows is always set to 150% but Cakewalk ignores that sometimes. So I go to the program .exe (Prog files, cakewalk, cakewalk core etc.) hit properties and under compatibility you can set the "high DPI scaling override" where you can choose to have the program either follow the systems DPI setting or the application's DPI scaling. (Or system advanced) - I change it here and it fixes it but eventually the setting gets unchecked and Cakewalk opens ignoring the DPI scaling. 

  • Thanks 1

Share this post


Link to post
Share on other sites

I'm struggling to think how CbB could change your high DPI scaling override setting. I know we aren't doing anything out of the ordinary. On start-up, CbB just tells Windows to handle scaling on its behalf. I wonder if Windows is trying to be 'clever' and is changing it because it thinks it knows better?!

A while back, I came across a plugin that was calling Windows DPI scaling functions, which it definitely shouldn't have been doing under any circumstances (it's the hosts job to worry about things like that). Maybe one of your plugins is misbehaving? That might explain it.

I did some Googling, and app compatibility settings (of which high DPI scaling is one) are stored in the registry here:
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

@jono grant If you're familiar with the registry, please would you send me a screenshot of the Cakewalk.exe entry in there? You might want to try deleting it to see if that makes any difference (at your own risk, of course). FWIW, I tried setting the high DPI scaling override and then deleted the corresponding registry entry with no ill effects.

 

Share this post


Link to post
Share on other sites
8 hours ago, Ben Staton said:

 

 If you're familiar with the registry, please would you send me a screenshot of the Cakewalk.exe entry in there? You might want to try deleting it to see if that makes any difference (at your own risk, of course). FWIW, I tried setting the high DPI scaling override and then deleted the corresponding registry entry with no ill effects.

 

Thanks. I've attached a screen shot, assuming this is what you meant?  PS. Not sure it would be a plugin, it only will (sometimes) go into "small mode" on the launch of the program, so there are no plugins involved at that stage. All I do know is that when I get the issue and I go check the DPI scale override for Cakewalk, it's always been automatically unchecked somehow.  I shouldn't even have to set it in the first place, it should follow the windows scaling like every other program. Weird...    

cakewalk screen shot.jpg

  • Thanks 1

Share this post


Link to post
Share on other sites

 

I don't see any people complaining about this as a Windows issue. I think Cakewalk is sometimes ignoring the DPI scaling override setting on program launch...

PS. I don't even need the setting, Cakewalk should just follow what is set in the display settings. If it's set to 150% , everything should be at that scale. So no matter what Cakewalk is randomly ignoring things that are DPI scale related.

 

J

Share this post


Link to post
Share on other sites
On 6/9/2020 at 7:43 AM, Anders Madsen said:

I do not have 4k, but some plugins have weird resolution on fonts.

I have the same with T-Racks 5 plugins when I enlarge them, sometimes it's graphics is crisp clear another time blurred. But I didn't think it's the same issue as the one being talked in this thread.

Share this post


Link to post
Share on other sites
18 hours ago, jono grant said:

 

I don't see any people complaining about this as a Windows issue. I think Cakewalk is sometimes ignoring the DPI scaling override setting on program launch...

PS. I don't even need the setting, Cakewalk should just follow what is set in the display settings. If it's set to 150% , everything should be at that scale. So no matter what Cakewalk is randomly ignoring things that are DPI scale related.

 

J

Hmm, this is a tricky one. Cakewalk literally does nothing at all to change or ignore the Windows scaling setting. It neither opts in nor out of it. Essentially, it just throws its hands in the air and says "Hey Windows, I know nothing about high DPI, so you take care of it!".

Do you by any chance have multiple monitors? If so, do they have different resolutions? Do you always run Cakewalk on the same monitor? Do you ever run Cakewalk on another display, whether it's temporarily plugging in a different monitor/TV, or by running it remotely (via Remote Desktop or similar)? Do you change the Windows scaling setting occasionally (nothing wrong with that, but it might be a factor)?

I'm also wondering why you're running Cakewalk with admin permissions all the time, which shouldn't be necessary. If Cakewalk is somehow affecting it (again, I fail to see how, but stranger things have happened), running it without admin permissions might prevent it from doing so.

If anyone else is running into this, please let us know. I'd like to get to the bottom of it.

Share this post


Link to post
Share on other sites

- I have a second monitor, which I rarely turn on. Is is not 4K but I don't change any settings if I use it. My main 4K monitor is connected by display port, the 2nd one is HDMI with adapter into display port.

- Occasionally I will use "splash streamer" which is an app that lets me view my monitor on a tablet, I use it when I'm recording alone and I'm several feet away from my desk. Again, I rarely use it. It runs wireless over my internet connection. I don't change any settings to use it and I don't think I've had the problem when using it ever.

- I set most of my apps to run as admin always. I find I get conflicts that only go away in admin mode. This is with various programs.  I can try turning admin off but there have been issues I have learned about, right here on this forum where I post an issue , perhaps about working with another program, say as a tool and folks have helped resolve my issue by having me make sure the programs involved are all set to admin. 

- the issue always happens at random times, say, after a reboot or I'll close cakewalk to do something else and reopen.

That's all the info I can think of right now.

Thanks

J

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...