Jump to content
Ben Taylor

No sound in external programs when running cakewalk?

Recommended Posts

So I've decided to give cakewalk a try and instantly I've run into a problem.

When cakewalk is loaded then no external programs will play any audio. As soon as I shut it down then I have audio again. 

Cakewalk itself still plays audio, just not external programs like youtube or spotify.

Thanks in advance for help :D

Edited by Ben Taylor

Share this post


Link to post
Share on other sites

Try this:

In Cakewalk menu. Edit --> Preferences --> Audio --> Playback and Recording

Tick on " Suspend Audio Engine when Cakewalk is not in focus" and "Always Open All Devices"

Hope it helps.

Share this post


Link to post
Share on other sites

Have you managed to fix this as I have the same problem?  It makes no difference if  "Suspend Audio Engine ..." is checked or unchecked, I cannot get sound in any other application or website unless I shut Cakewalk down.  My Driver Mode is set to ASIO and the Sampling Rate is 44100 which is the same as my audio interface (Focusrite  Saffire Pro 14).

Share this post


Link to post
Share on other sites

If the PC is using the audio same interface for Windows and CbB make sure both are set to the same sample rate.

 

Share this post


Link to post
Share on other sites
51 minutes ago, scook said:

If the PC is using the audio same interface for Windows and CbB make sure both are set to the same sample rate.

 

Thanks. Any idea how I check the Windows sample rate?

Share this post


Link to post
Share on other sites
1 hour ago, Mark Harknett said:

Thanks. Any idea how I check the Windows sample rate?

Like many other things, there are probably different entry points and different people prefer different methods. Not as an expert, but as a basic audio user, I usually use the taskbar speaker icon to run the Troubleshooter. Often when I am trouble shooting an issue with Windows audio, even if the troubleshooter detects no problem, simply running the troubleshooter seems to launch some check/reset audio services that might fix an issue.

After that, there are settings and/or properties options.  In audio device properties, I will then use the tab to set/test the sample rate and bit settings.

There are quicker ways to get there via Settings directly if you prefer, plus I am sure that others can tell you other methods.  This is just one method one person (me) uses.  Not trying to say anyone else should do it this way. I know there are people who will swear up and down that the trouble shooter is worthless. That's fine; multiple options works for me. Just offering this as some possible ideas.

image.png.bac93bfddc0830da3d6740d3c3efb098.png      image.png.d262aab4aa7672278c4f5f17d1a3e5c2.png

  image.png.00fb7edb420f52ee7770921225731e9e.png               image.png.d7d9184fc83e99b1be7ce037ff682ead.png

Edited by User 905133
(3) added more social distancing language to try to forestall another "thumbs down" reaction and being called childish; (2) method [missing word] added; (1) tool bar -> taskbar correction

Share this post


Link to post
Share on other sites

Thanks 905133.  The troubleshooter didn't pick anything up but I noticed that I had three audio devices, two of which I don't use, so I disabled these and looked at the one I do use.  This had a different sample rate to the one in Cakewalk so I made them the same and it all works ok.

  • Like 1

Share this post


Link to post
Share on other sites

I believe i have fixed this.
at least in my case it had nothing to do with sample rates or anything of the sort.
instead:
1)head to your audio settings in windows, and then properties (do this for both your audio playback, and recording, so that you can also use your mic).
image.png.d8cf9f557a10ae953d106365934f9d9d.png
2)go to advanced, and then disable the following:
image.png.850f7e3f27ee07e1bc2bef4110ef3bcb.png

3)restart cakewalk, and you're good to go.

hope this helped.

Share this post


Link to post
Share on other sites

I had the same problem, and reports of runtime error 217 at 0051CF9. I found that the inability to hear other sounds was due to selecting WASAPI Exclusive in Preferences>Audio>Playback and Recording. Selecting WASAPI Shared solved that problem, but I still get the runtime error on exiting Cakewalk.

PS: It seems the two problems were unrelated. I believe the runtime error was caused by the old SQ8L plugin. Removing it from the Synth Rack stopped the error.

Edited by MarkP
Added PS.

Share this post


Link to post
Share on other sites

same problem, did everything suggested, still notworking.

I am on windows 10, focusrite 2i2 asio mode

48k sampling on both windows and cakewalk.

 

thanks for any other suggestions

 

 

 

 

 

Share this post


Link to post
Share on other sites
On 7/21/2021 at 1:05 AM, ricky wong said:

same problem, did everything suggested, still notworking.

I am on windows 10, focusrite 2i2 asio mode

48k sampling on both windows and cakewalk.

 

thanks for any other suggestions

 

 

 

 

 

Not sure if it's of any help, but I've found that Windows randomly changes its sample rate.  I have the sample rate in Cakewalk set to 44100 - 24 bit and set my Windows sample rate to be the same.  On occasion, Windows changes to 96000 or 48000.  It's incredibly irritating and I can't find anything that explains why, but when I set it to the same as Cakewalk, all is ok.  The other thing to check (if you haven't already) is the Bit Rate.

Share this post


Link to post
Share on other sites

I also have had this issue, I make Desktop shorcuts to this because it happens frequently when A browser is also used the same time as CBB.
Also, make shortcuts to things like: Device Manager.
 

Cakewalk_Audio_Settings.jpg

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...