Jump to content
tdehan

The above Audio/MIDI device was disconnected from your system?

Recommended Posts

I had to flatten and rebuild my Windows 10 PC recently.  After re-installing Cakewalk I keep getting the following message when playing a MIDI file.   What does this mean, and how do I fix this so it stops coming up?    Thanks!

Capture.PNG.fbe26fd1434f0bdb971fe7c135adf90a.PNG

Share this post


Link to post
Share on other sites

I would really appreciate some assistance with this pop up that keeps happening since re-installing Cakewalk.  Regardless of whether I click YES or NO the window continually pops up.  It doesn't appear to affect anything however, i would really like to find out why this is happening and stop it as it is annoying as heckl

Thanks

Share this post


Link to post
Share on other sites

Hi tdehan,

This is usually associated with your drivers (and you may have to change driver mode).  What sound card and/or MIDI interface are you using?

Kind regards,

tecknot

Share this post


Link to post
Share on other sites

If you do not use it, disable the "High Definition Audio Device" in Windows Device Manager.

If not using any hardware synths or do not plan to send MIDI to hardware synths, make sure all MIDI output devices are deselected in preferences. This will let CbB automatically setup TTS-1 when opening MIDI files.

  • Like 1

Share this post


Link to post
Share on other sites

This issue has never happened before.  This only started after I recently and to flatten the computer and re-install Windows 10.  I've never had any issues prior with Cakewalk.  However, both Bandlab Cakewalk and Sonar 3 Cakewalk are throwing the same message.

I've never had to do anything special with Cakewalk settings prior so don't know why this is happening now.

Share this post


Link to post
Share on other sites
5 hours ago, tecknot said:

Hi tdehan,

This is usually associated with your drivers (and you may have to change driver mode).  What sound card and/or MIDI interface are you using?

Kind regards,

tecknot

Both High Definition Audio Device and NVIDIA High Definition Audio are listed.

Capture.PNG.2b8b2ffed21b9b8b675e669e19b81787.PNG

Share this post


Link to post
Share on other sites

Ok, hopefully I fixed the issue.  I updated the High Definition Audio Device to Realtek High Definition Audio and that appears to have fixed the issue.

Share this post


Link to post
Share on other sites

I am having this exact problem, although it has nothing to do with MIDI in my case. Just random pop-ups with identical wording. Usually I see it when I come back to my computer after a period of time and wiggle the mouse to reactivate the screen.

I will update this message with my findings.

Update: Pretty consistent. If I walk away from my computer and it goes into screen save mode, when I get back to it, this dialog is on the screen:

image.png.f88d1ad90c4d3234aea92873379d2416.png

It seems to be coming from Cakewalk, but Cakewalk shouldn't care two hoots about any other audio device other than the ASIO driver/device that I've told it to have exclusive use of.

So, why is Cakewalk telling me about this?

For what it's worth, choosing either YES or NO seems to have no difference. Cakewalk continues to work normally. So it is an annoyance rather than  big issue.

Edited by Colin Nicholls

Share this post


Link to post
Share on other sites

I may have resolved the issue. In the Device Manager, I have two (!) "High Definition Audio Device" entries, enabled, under "Sound, video and game controllers".

Now, I DO make use of the internal on-board audio with a pair of lightweight 'phones for YouTube and other computer audio, independent from my DAW/Echo3G configuration. It works very well, and I know that one of those HDADs represented that audio endpoint. The other one is a mystery. (I think it showed up when I last upgraded my NVIDIA drivers...)

Anyway. Having reviewed the Property Details for each node, and comparing the Device IDs with those of the nodes under "Audio inputs and outputs" (specifically "Headphones (High Definition Audio Device)", I could tell which one of these HDADs might be disabled safely (see yellow highlight on the disabled node).

image.png.22e8d52546d5532d643c9c1e7e2faf1f.png

So far, I haven't seen the "disconnect" dialog. But I guess it is early days.

Edited by Colin Nicholls

Share this post


Link to post
Share on other sites

I get it all the time, from different things, my monitor speakers, my webcam mic, etc, etc. Usually if the computer goes to sleep some of these will drop. It's harmless, but annoying. Just disable as people above commented. 

Share this post


Link to post
Share on other sites
  • Disable unused Audio Devices.
  • Disable Power-Management (should ideally be disable in a high-performance machine)

If you use a USB audio interface (and power-management isn't disabled), Windows can decide to turn off that USB port (to save power)... causing the audio interface to disconnect.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...