Jump to content
Sign in to follow this  
Sean

What can I do if increasing ASIO buffer size doesn't fix crackling and audio dropouts?

Recommended Posts

I have a Focusrite Scarlett 6i6 audio interface, a 3.3Ghz i5 quad-core CPU and 32GB RAM. I tried a new sampler and added a 65 channel piece to the new sampler, but now I can't play through the piece without crackling and audio dropouts. What can I do to fix the dropouts? I've set the buffer size to 1024, which is max. I'd rather not have to buy a new CPU, but would a CPU upgrade to an i7 processor help much?

Share this post


Link to post
Share on other sites

@Sean - FWIW I have a similar setup - 1st gen 6i6 + 3.4Ghz i5 3570.  I can quite comfortably work on projects with a buffer size of 64 - sometimes even 32 without crackles or dropouts.

@Anders Madsen is correct - first you should check you're running in high performance mode, so there's no reduction in CPU power.

However even then, 65 Channels through a single sampler may be a bit much for a single VST, especially if it's only running on one core.

Things to try:

  • Try splitting up your sampler into 4 instances, so each instance is only dealing with 16/17 channels. This will allow each instance to run on its own CPU core.
  • You've got 32GB of RAM, so if possible try to get the sampler to load more samples into RAM rather than relying on disk streaming - this will increase project load time, but should reduce CPU load during use.
  • In Preferences->Audio->Configuration File Check you've NOT got the ThreadSchedulingModel set to 3 - it should be set to 1 or 2.

[Edit] - Out of interest, what sampler are you using?  Kontakt for instance can be configured to use multiple cores, which would negate the need to split your tracks up:

image.png.1b5f3b689feec78ba36dbb7f68457dfc.png
 

  • Like 2

Share this post


Link to post
Share on other sites

Try Latency Monitor   On my system it shows a serious execution time problem in NVIDIA Windows Kernel Mode Driver. Latency Monitor states unequivocally that my system is not suitable for handling realtime audio. Written in red. I updated my NVIDIA driver (a few days old) but it doesn't help.  Will backup my boot drive and rollback a few Windows updates and see if that helps.

 

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, msmcleod said:
  • Try splitting up your sampler into 4 instances, so each instance is only dealing with 16/17 channels. This will allow each instance to run on its own CPU core.
  • You've got 32GB of RAM, so if possible try to get the sampler to load more samples into RAM rather than relying on disk streaming - this will increase project load time, but should reduce CPU load during use.

How does splitting up the project work, exactly? I couldn't find out how to do that in the documentation. What about increasing RAM usage? (right now, the project is at 24GB RAM usage, but all the samples are stored on an SSD). Everything else seems to be taken care of (though in Vienna Synchron Player, I couldn't find any multi-core settings anywhere in options)

What I did do though, that seems to work, was updating Vienna Synchron Player to the latest version. This time, only times I heard crackles this time was if I launched another program when Cakewalk was playing the piece.

Edited by Sean
  • Like 1

Share this post


Link to post
Share on other sites
9 minutes ago, Sean said:

How does splitting up the project work, exactly? I couldn't find out how to do that in the documentation. What about increasing RAM usage? (right now, the project is at 24GB RAM usage, but all the samples are stored on an SSD). Everything else seems to be taken care of (though in Vienna Synchron Player, I couldn't find any multi-core settings anywhere in options)

What I did do though, that seems to work, was updating Vienna Synchron Player to the latest version. This time, only times I heard crackles this time was if I launched another program when Cakewalk was playing the piece.

What I meant was say you've got one instance of VSP, with all your tracks feeding into it. 

You could have 4 instances of VSP and have 16 of your tracks feeding the 1st instance, the next 16 tracks go to the second and so on...

So in practical terms this means copying your current VSP instance in the synth rack 3 times (so you've got 4) - then ensuring each instance only has 16 (or 17) parts.

However it sounds like the latest player is probably doing the core load balancing for you, so there's no need to go down this route.

Share this post


Link to post
Share on other sites

I've been having some recent issues with crackling when playing VSTi's and have adjusted buffer size to no avail. My thread scheduling model is set to 1 - would setting it to 2 help? I have a quad core i5 2,500k at 3.3GHz & 8gb RAM

 

What does the thread scheduling model do?

Cheers

Share this post


Link to post
Share on other sites
2 hours ago, JoeGBradford said:

I've been having some recent issues with crackling when playing VSTi's and have adjusted buffer size to no avail. My thread scheduling model is set to 1 - would setting it to 2 help? I have a quad core i5 2,500k at 3.3GHz & 8gb RAM

 

What does the thread scheduling model do?

Cheers

Setting it to 2 might well help - it certainly did for me after the last big Windows update.

Just don't set it to 3 - that mode is still experimental and is causing problems for many users.

  • Thanks 1

Share this post


Link to post
Share on other sites
7 hours ago, msmcleod said:

Setting it to 2 might well help - it certainly did for me after the last big Windows update.

Just don't set it to 3 - that mode is still experimental and is causing problems for many users.

Thanks I'll give it a try! I assume I go in by clicking the Edit Config File button?

Share this post


Link to post
Share on other sites
4 minutes ago, JoeGBradford said:

Thanks I'll give it a try! I assume I go in by clicking the Edit Config File button?

Yes.

  • Thanks 1

Share this post


Link to post
Share on other sites

Don't want to speak too soon but setting it to 2 seems to have helped in Sampletank based instruments. Will try Union tomorrow which was the other VSTi I was having issues with 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

With the highest level of respect stated for a DAW I've used, in one form or another, since 1990, it is time for Cakewalk to get technical and deep and figure out its audio engine.  We can always find the other side of these things, but it seems the fact is that we are so often problematic.  Something is not right, I believe.

As stated before, my Nuendo, ProTools and Sequoia have NONE of these issues -- and I mean over years and years of use for projects.

Bandlab/Cake, if you can, it is time to drive a new day in software reliability and integration with Windows.  We all love this framework, but it is not reliable enough to be top-shelf production programming on the average.

We can site many instances of success and lack of issues, yet we must all be very honest in asking ourselves, would we have the scenario put forth, "Would I use this to make my living, or even (as I) to bring artists in and produce their work?"

I'm sure we will get a chorus of "Yes!", but I, one who loves this interface for workflow, would NEVER do such, YET.  

Cake, get after this.  Really.

Edited by Jon White
  • Confused 1

Share this post


Link to post
Share on other sites
Posted (edited)

@Jon White

I just don't have problems with the audio engine itself. Cakewalk works the same for me regarding reliability and dropouts as other daws. Just my experience. It is true that i can out drive my computer so i try to keep with the times, even if computer upgrades for me are slower than I'd like.

For lots of purposes I'm able to live around 3 to 5 ms of latency with no dropouts.

Not for heavy synths though. The computer can't do the work in time.

Regarding cutting voices, one of the tools for staying real time with synths is reducing voices and this is described in this video.

 

Edited by Gswitz
  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...