Jump to content
Evael

BUG: None = Omni? + Any MonitoringFX?

Recommended Posts

Posted (edited)

Hi,

I just installed Cakewalk 2020.01 build 28 ×64 bit.

 

BUG: Choosing None in the Instrument input channel actually gives me Omni input.

 

MISSING FEATURE: MonitoringFX to be able to load headphone correction plugins such as Sonarworks, without having to "load it last in the Mater FX chain and having to remember to turn in off during export".

 

omni-none.jpg

Edited by Evael

Share this post


Link to post
Share on other sites
11 minutes ago, Evael said:

BUG №2: Choosing None in the Instrument input channel actually gives me Omni input.

Not a bug. Maybe this thread will help explain

 

  • Like 1

Share this post


Link to post
Share on other sites

Ah, I see now!

Many thanks, scook! Really helpful. 

I also saw an option to Record MIDI track data even when the MIDI track has not been rec-armed. I think it is 'off' (not ticked) by default but it is there on the ame setting page as the 'Always Echo current MIDI Track'.

Now... if you can advise me on how to implement a workaround to make a proper routing for my Sonarworks headphone correction plugin to function as a MonitoringFX, that would be fantastic! I tried in Studio One, but their workaround is so cluttered (via some kind of Pipeline plugin on the Master bus, routed to itself... some voodoo magic for such a simple task in Reaper).

Share this post


Link to post
Share on other sites

I do not use Sonarworks but if I did, I would create a bus between the master bus and the hardware outputs. Add the plug-in to this bus and always use the master bus for export.

 

Share this post


Link to post
Share on other sites

I tried disabling 'Always Echo current MIDI Track' but the problem is when I manually click on the monitoring icon next to rec-arm icon on the track, it keeps reverting it to All imputs - Omni, whils it still says None.

Definitely a bug!

 

  • Like 1

Share this post


Link to post
Share on other sites
9 minutes ago, scook said:

I do not use Sonarworks but if I did, I would create a bus between the master bus and the hardware outputs. Add the plug-in to this bus and always use the master bus for export.

 

Yeah, tried that, but this way would have to manually every time rout every new track, bus that that "Monitoring" bus track that finally goes to the Master. 

Reaper is definitely more convenient in this. Hope one day we see this feature in Cakewalk. Many people nowadays mix/listen on their headphones, so should be a standard at some point to have such a feature.

Share this post


Link to post
Share on other sites
Posted (edited)
48 minutes ago, Evael said:

Now... if you can advise me on how to implement a workaround to make a proper routing for my Sonarworks headphone correction plugin to function as a MonitoringFX, that would be fantastic! I tried in Studio One, but their workaround is so cluttered (via some kind of Pipeline plugin on the Master bus, routed to itself... some voodoo magic for such a simple task in Reaper).

Pipeline is absolutely not necessary. scook's advice is similar to what I do in Studio One a described below, and you can do the same sort of thing in Cakewalk.

1. Create a bus, and assign it to the same hardware output as your Main bus (in Studio One, this is done in Song Setup). Insert Sonarworks in this bus (we'll call it Sub1).

2. Select all your tracks and change the output of one track to Sub1 instead of Main. Like Cakewalk's Quick Group, this causes all the tracks to terminate in the Sub 1 bus.

3. When you're ready to export,  select all your tracks, and change the output in one track to Main instead of Sub 1. Export from the Main out.

A benefit of having a separate bus is you can match levels more easily when Sonarworks is active. BTW I also use a similar technique to get around Studio One's lack of a Dim Solo function - create a dedicated Dim Solo bus that goes to the same hardware output as the main bus. I can switch the track I want to Dim Solo to the Dim Solo bus, and reduce the Main bus to whatever level is appropriate. This can actually be better in some situations than having a fixed volume change for a global Dim Solo function, and you can do it in Cakewalk as well.

 

Edited by Craig Anderton
Give more detail about using the Dim Solo bus

Share this post


Link to post
Share on other sites

Actually @Craig Anderton in CbB I route the master bus to a "final bus" which routes to the hardware output.

Sonarworks would go in the final bus FX rack.

It does not affect exports because exports are made using the master bus. There is no need to change routings for export.

New tracks are always automatically added to the master bus because it is still the default bus.

 

Of course, this routing assumes the headphones use the same main ports as the master bus. If the headphones can monitor different hardware ports, instead of a "final bus" a send on the master can do the same job.

 

  • Like 1

Share this post


Link to post
Share on other sites
10 minutes ago, Evael said:

Yeah, tried that, but this way would have to manually every time rout every new track, bus that that "Monitoring" bus track that finally goes to the Master. 

See my response, both Cakewalk and Studio One have Quick Grouping so that routing one track to a bus routes them all. But there's another advantage to the "dual bus" approach. Some people like to mix through mastering effects, like a limiter or maximizer, to get a sense of what the song will sound like when mastered. However, I don't want to actually export through effects, I want to export  with nothing in the master bus because I treat mastering as a separate process compared to mixing. By using two buses, you can have your Cakewalk and eat it too - export a clean version for mastering, but also include effects and Sonarworks while monitoring.

And BTW, isn't Sonarworks effing cool? I got the version where I could also calibrate my monitors. I was impressed that the sound through headphones and speakers was pretty much the same.

The one caveat I have is that headphones of even the same make and model can vary quite a bit.  This is why the Sonarworks profiles are indicated as "averages." If you do this for a living, it may be worth biting the bullet, sending your headphones to Sonarworks, and paying them to run a profile. Since I can profile the speakers, I just use the headphones that sound the most like the sound coming out of the speakers. 

Share this post


Link to post
Share on other sites
34 minutes ago, Evael said:

I tried disabling 'Always Echo current MIDI Track' but the problem is when I manually click on the monitoring icon next to rec-arm icon on the track, it keeps reverting it to All imputs - Omni, whils it still says None.

Definitely a bug!

 

Not a bug, I explain why later in the the thread linked above (note: monitoring icon = input echo)

 

Share this post


Link to post
Share on other sites
3 minutes ago, scook said:

Actually @Craig Anderton in CbB I route the master bus to a "final bus" which routes to the hardware output.

Sonarworks would go in the final bus FX rack.

It does not affect exports because exports are made using the master bus,

New tracks are always automatically added to the master bus.

That's a better way to do things in CbB, I didn't realize Exports were always made from the Master bus when you selected Entire Mix. I've always exported using Hardware Outputs as the Source Category, that seemed safest to me. Good to know there's an alternative.

In Studio One, you can't route the Main bus to another bus, so that technique wouldn't work in SO. You always export from the hardware outputs.

Share this post


Link to post
Share on other sites
31 minutes ago, Evael said:

Yeah, tried that, but this way would have to manually every time rout every new track, bus that that "Monitoring" bus track that finally goes to the Master. 

Reaper is definitely more convenient in this. Hope one day we see this feature in Cakewalk. Many people nowadays mix/listen on their headphones, so should be a standard at some point to have such a feature.

You actually need to do it once if you use track templates. A track template in CbB includes all its routing. Just drag it from the browser and you are done. 

Share this post


Link to post
Share on other sites
10 minutes ago, Craig Anderton said:

I didn't realize Exports were always made from the Master bus when you selected Entire Mix

The default "Entire Mix" is essentially "What you hear" - IOW all tracks and buses that point to the mains.

As you know, the Export dialog also permits exports from the master bus or any track or bus.

Share this post


Link to post
Share on other sites
4 minutes ago, JoseC said:

You actually need to do it once if you use track templates. A track template in CbB includes all its routing. Just drag it from the browser and you are done. 

Or build it into the project templates

All my project templates have a bus after the default (aka master) bus.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, scook said:

I route the master bus to a "final bus" which routes to the hardware output.

Sonarworks would go in the final bus FX rack.

It does not affect exports because exports are made using the master bus. There is no need to change routings for export.

New tracks are always automatically added to the master bus because it is still the default bus.

Of course, this routing assumes the headphones use the same main ports as the master bus. If the headphones can monitor different hardware ports, instead of a "final bus" a send on the master can do the same job.

 

Will definitely try out this method! Thanks for the suggestion. Maybe I could not find a way to rout the Master to another bus in the previous attempts.

And yes, the Echo button does not respect the None selection for the inputs and that is a bug. I want when I say 'None input', no signal to come in the track, no matter how much a press the buttons.

Else, if Echo button should take priority for the sake of it, the 'None' label in the panel should change accordingly. Then it won't look and behave like it's a bug.

Track templates are a pain in the but. Sometimes I will forget and will thing a track is routed appropriately, but it would not be, so I will have to double check... no time for that.

Edited by Evael

Share this post


Link to post
Share on other sites
11 minutes ago, Evael said:

I want when I say 'None input', no signal to come in the track, no matter how much a press the buttons.

This is not how the program works.

By design, turning on input echo requires an input other than None on instrument and MIDI tracks. To that end, tracks set to None change to Omni when input echo is enabled.

This is why I turn off Always Echo Current MIDI tracks and assume manual control of both the input drop down and input echo.

 

Feel free to file a feature request.

  • Like 1

Share this post


Link to post
Share on other sites

I have the latest Bandlab of cakewalk 2020 version and I also just added Melodyne Studio 4.......Since  I added Melodyne, I have had so many issues with Cakewalk freezing up. I have called/emailed both Melodyne and Bandlab. but as you say both blame the other. or 'try in a new project'. I cannot do this every time I find a new issue.  I have songs to record and running into these issues every time is frustrating. I guess with Bandlab you get what you pay for but as  a Long time customer all the way from 12 tones days, its disappointing.  I did offer to Beta site these programs for both companies but have not been taken up on my offer.

 

I have started to keep a list of the issues with Both programs. I will publish here when I update it.

 

Does anyone else have a lot of issues with Cakewalk freezing up??

Share this post


Link to post
Share on other sites

I have Melodyne 4 Editor, and no stability issues currently. Last time I had a problem with freezing, it turned out to be an interoperability issue between certain VST3s and NVidia drivers;  fixed by a driver update.

Cakewalk Dev have a very good and close relationship with Melodyne, having been an early adopter of ARA, so there should be no finger-pointing. If it's reproducible by either of them, they will get it fixed, but more likely you have some system-specific issue.

Ideally, you will be able to provide detailed steps on how to repro the issue in the simplest possible project, started from the ' Basic' template. If it's only reproducible in a  specific project, strip it down as much as possible without losing the reproducibility, and send them a copy of that project. Sometimes the process of stripping it down will identify the problem.

Share this post


Link to post
Share on other sites

Hi Thanks for a quick reply, here are two bugs that you could try.

 

 

1) open Melodyne in Bandlab. by double clicking the clip that has already been 'melodyned' notice that when the window opens you can not 'see' the  -, open window, and close window icons in the right hand top corner, now if you click on undock and then click on the expand window that has now appeared in the right hand corner you will be able to 'see' the - open, close etc. in the right hand top corner.

2) go to preferences in Melodyne, see that one of the short cuts is F1, however if you press F1 while you are in Melodyne it tries to open the Cakewalk help documentation as if you are still in Cakewalk and pressed F1, There are several other keys that are common between Melodyne and Cakewalk that do not work in Melodyne because they are opening things inside of Cakewalk, even though you are in the Melodyne window. for example pressing 'M' in Melodyne opens the marker window in Cakewalk.

 

These two issues above are just some of the ones I have documented and can re-produce, in fact the first one is in Bandlabs Namm presentation if you look carefully.

and these two are not bad I can deal with them, The worst ones are where I have to close the project down and restart Cakewalk because it is either not responding or Melodyne will not open when I double click on it until I close down and restart.

 

As I say I have started to keep a log of the issues, but with Corona virus, response is slow in coming, I think maybe they are not working during this time.

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

The first "bug" is just the way the Docker works. Melodyne opens docked by default. If you want to close it, close the Docker tab.

Edited by JoseC

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...