Jump to content
George Abercrombie

CbB no longer recognizes MIDI

Recommended Posts

I don't know what I did, but my MIDI controller is no longer recognized in CbB. I opened standalone apps like Addictive Drums and Battery and the controller worked. So, it seems to be isolated to Cakewalk. My Saffire is checked under MIDI Devices settings. Is there a setting somewhere that I inadvertently switched off?

Edited by George Abercrombie

Share this post


Link to post
Share on other sites

First I would suggest a reboot of the computer.  Sometimes that is the easiest fix.

  • Like 1

Share this post


Link to post
Share on other sites

shutdown CbB

rename %appdata%\Cakewalk\Cakewalk Core\TTSSEQ.INI

restart CbB
 

 

  • Thanks 1

Share this post


Link to post
Share on other sites

What ever you wish. If TTSSEQ.INI is not found when CbB starts up, the program creates a new one with default settings. The purpose for renaming the ini files is to compare the old with the new. This is especially important if the old file has some custom settings.

 

  • Thanks 1

Share this post


Link to post
Share on other sites

There is no need to search for it. The file must be there if your are using CbB. Type %appdata%\Cakewalk\Cakewalk Core\ into the Window Explorer path.
 

 

Share this post


Link to post
Share on other sites

Is there a way to roll back to 2019.12 to rule out the possibility that the update caused it? I haven't had to roll back since SPLAT, so I don't know if CbB still allows it.

Share this post


Link to post
Share on other sites

Check your MIDI preferences in CbB. You may need to set them again.

  • Thanks 1

Share this post


Link to post
Share on other sites

Great. Please edit the OP and add [Solved] to the subject line of the thread.

 

  • Like 1

Share this post


Link to post
Share on other sites

IIRC, it used to be that SONAR/Cakewalk recognized when new midi devices were connected; however, last night the usb keyboard I have been using for about 6 months wasn't immediately recognized.  Not sure if it was because I plugged it in to a different usb port or what. Eventually, it was listed in  Preferences > MIDI Devices (unchecked) and showed up in the MIDI Input Track Control Widget--after I had enabled it in Preferences.

Re-loading the project did not automatically assign the keyboard as the midi device for the tracks where it had previously been assigned.

Just offering my experiences in case it helps point to debugging strategies.  I have no idea why hot plugging midi devices no longer registers (or if that feature was removed sometime and I never noticed it) and no idea which thing I did made it visible again.

NEW DETAILS: I just remembered, prior to this I had attempted (again) to update Win 10 (Features Update). As usual, it took several hours to attempt, and about 30-45 minutes to undo the failed attempt.  I had disconnected almost all my usb devices (not PC keyboard and mouse) and my sound card to see if the update would work this time.  (It didn't.) So, the soundcard preferences had to be redone as well--before I had only 8 ASIO channels in use and with friendly names.  Upon reinstalling the card, all 32 ASIO channels were selected and the friendly names were gone.

In my experience when Win 10 reverts itself from a failed Features Update, it is never 100% back to what it was. The sudden appearance of on-going BSODs was one one the symptoms that clued me in to the changes from the failed update/so-called reversion process.

Edited by User 905133
to add new details that might be relevant
  • Like 1

Share this post


Link to post
Share on other sites

@MisterGreen - look at your Control Surfaces set up...  is your MIDI device listed as one of the MIDI inputs?

This has caught me out many times (including earlier on today!)

Share this post


Link to post
Share on other sites
2 hours ago, msmcleod said:

@MisterGreen - look at your Control Surfaces set up...  is your MIDI device listed as one of the MIDI inputs?

This has caught me out many times (including earlier on today!)

There is an ongoing issue that I have, because the midi devices and their USB ports got modified, GRRRRR to the friend that accidentally did that to my desktop computer.

Anyways, any existing project now contineus to 'see' the midi controller, however absolutely no midi activity is recognized/detected by CbB.  The workaround I have been performing is to:

1) In the open project, remove that midi controller in Preferences - Midi Devices, and click Apply, then Save project. then close the project

2) Re-open the project, add the midi controller back in Preferences - Midi Devices, click Apply, then Save the project again.

I kind of lumped several steps above, into each numbered steps, just because I look at those logically in that manner.  Hopefuly, that won't confuse anyone.

SOO - the thing with the above, is that I keep having to do the above steps, and I have not figured out a way to have one final 'fix' to permanently correct this REALLY annoying scenario of having no midi activity detected for my midi controller.

On top of the original issue because one midi device moved to a different port, and it wasn't even my midi controller that moved ports - it was actually the audio interface, but it still resulted in Windows remapping the association between devices and ports - so BESIDES this, my desktop has no internal DVD/optical drive - because of the case design, so anytime I have to plug in the DVD drive, that too causes the midi device mapping to associated USB ports to change, and it too causes this issue all over again.

This mapping to ports issue has gone on since at LEAST as far back as Sonar 8, and most folks I know zealously guard, and even map out, the USB ports each midi device is plugged into.

Can't this generic NIGHTMARE get a permanent fix or at least a reliable set of steps that only need be run ONCE, when ports and device mapping gets altered?

Please?

Bob Bone

  • Great Idea 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...