Jump to content
Raj G

ASIO driver stops when resuming from sleep on Windows 10

Recommended Posts

Hi,

I have been using Cakewalk by Bandlab and it is an amazing program - and the recent updates have been really great. 

I am having one issue with Cakewalk. I have a Windows 10 PC with a display connected by HDMI. The display provides a sound device through HDMI (which I use but not with Cakewalk). When I put Windows 10 PC to sleep and resume, I get a notification that the sound device connected by HDMI is disconnected and would I like to route outputs to other available devices. This is annoying as I am not using HDMI sound device in the first place. There is a setting to turn off such prompts (which I am using). However, when this happens, the ASIO driver stops working. I have to click on the button to restart the ASIO driver. Cakewalk works fine after that.

A few requests: can Cakewalk automatically restart ASIO driver when resuming from sleep? Thanks.

Osho

Share this post


Link to post
Share on other sites

I've had much, much bigger problems with sleep mode than having to restart the driver, and I've read dozens of forum posts about having to reboot, loosing changes or worse. There used to be a consensus that it's risky to  use the sleep mode in DAW-work, I don't know how it is with modern equipment and software.

Anyway, controlling the sleep functions is Windows' job, isn't it? I don't know if Cakewalk can do anything about it (??) As there are also HDD's that have their own power saving systems.

Edited by Kalle Rantaaho

Share this post


Link to post
Share on other sites

It's usually not recommended to allow  " sleep " mode when using DAW. Power options can turn monitors off - but Hard drives need to stay awake. There are a number of actual experts on this forum, hopefully they will see this thread and  speak more authoritatively than I can about it.

  • Like 1

Share this post


Link to post
Share on other sites

Never use sleep mode .. Power options must be set up correct for your system to perform !

 

Share this post


Link to post
Share on other sites

The sleep-resume is incidental to this request/issue. 

The issue is that if a device output is disconnected and Cakewalk isn't actually using it - there shouldn't be a popup informing the user. And, at the very least, that shouldn't reset the ASIO driver.

Osho

Share this post


Link to post
Share on other sites

Not all ASIO interfaces can recover from a sleep. Although Windows will correctly restore its ASIO driver state, the interface may not.

If the two are out of sync, an ASIO reset will be required.

Share this post


Link to post
Share on other sites

it's also recommended to disable hdmi sound... you can try power-cycling the tv? (will cause asio disconnect/reconnect)

Share this post


Link to post
Share on other sites

It's sad that we all can't afford better systems. I remember having this problem with my old system which was an i3 system. So, I saved up some bucks for an i7 system 16gig ram and a 2T SSD hard drive. All problems gone! I know not all are running on newer systems or can afford it. Upgrading your old SATA hard drive to a SSD hard drive and adding at least 8gig of ram will speed up your systems reading.  Also clean up your startup programs.

Share this post


Link to post
Share on other sites
12 hours ago, pwalpwal said:

it's also recommended to disable hdmi sound... you can try power-cycling the tv? (will cause asio disconnect/reconnect)

Unfortunately I cannot - I am using that sound device for other (non-DAW) purposes.

Osho

 

Share this post


Link to post
Share on other sites
1 hour ago, _Will_ said:

It's sad that we all can't afford better systems. I remember having this problem with my old system which was an i3 system. So, I saved up some bucks for an i7 system 16gig ram and a 2T SSD hard drive. All problems gone! I know not all are running on newer systems or can afford it. Upgrading your old SATA hard drive to a SSD hard drive and adding at least 8gig of ram will speed up your systems reading.  Also clean up your startup programs.

I have a system with i7 and 32GB RAM and 1TB SSD drive. It is very new and performs very well without any other issues.

This is not an issue due to an under-powered system. This is an issue because of Cakewalk's implementation of how to handle device disconnections. 

At the very least, if ASIO driver can be automatically restarted whenever device disconnection happens - that will be great. Thanks. I am hoping that some developer will chime in.

Osho

Share this post


Link to post
Share on other sites
17 hours ago, msmcleod said:

Not all ASIO interfaces can recover from a sleep. Although Windows will correctly restore its ASIO driver state, the interface may not.

If the two are out of sync, an ASIO reset will be required.

Sure, but in that case it will be great if Cakewalk can automatically reset ASIO driver when resume from sleep is detected.

Thanks.

Osho

Share this post


Link to post
Share on other sites
On 1/26/2020 at 12:49 PM, Raj G said:

The display provides a sound device through HDMI (which I use but not with Cakewalk). When I put Windows 10 PC to sleep and resume, I get a notification that the sound device connected by HDMI is disconnected and would I like to route outputs to other available devices. This is annoying as I am not using HDMI sound device in the first place.

Sorry, I am not a developer, but your issue has me wondering what your setup is. It sounds like you have more than one device. Do you have multiple drivers, too? Or is one driver attempting to route audio to more than one device?  Maybe the answers are in the thread and I missed them. Also, I may have missed which device driver(s) you are using--one(s) from device manufacturers?

Share this post


Link to post
Share on other sites
13 minutes ago, Raj G said:

I have a system with i7 and 32GB RAM and 1TB SSD drive. It is very new and performs very well without any other issues.

This is not an issue due to an under-powered system. This is an issue because of Cakewalk's implementation of how to handle device disconnections. 

At the very least, if ASIO driver can be automatically restarted whenever device disconnection happens - that will be great. Thanks. I am hoping that some developer will chime in.

Osho

Well, something that is old in your system or attached causes that problem. Trust I've dealt with this on so many occasions and level. One thing that I will though is, I don't know about anyone else, but I find cakewalk to run best on Win 7 64bit.  Anyway like I mentioned check your startup programs too. Normally Avast antivirus causes these issues too. Although i'm running Porcelain 10 the latest update. Another well known fellow friend and producer runs the Windows 10 Red stone and said that cakewalk is running smoother there.  

Edited by _Will_

Share this post


Link to post
Share on other sites
10 hours ago, Raj G said:

Unfortunately I cannot - I am using that sound device for other (non-DAW) purposes.

Osho

 

How about the power cycling?

Share this post


Link to post
Share on other sites

I disabled sleep on my DAW. I just shutdown when not using it. Booting up Windows from SSD is almost as fast as resuming from sleep, so why bother with sleep issues?

There is also a known issue with Windows sleep and FireWire. Sleep is not fully supported with FireWire, so anyone using a FW audio interface, best to disable sleep.

  • Meh 1

Share this post


Link to post
Share on other sites
21 hours ago, Raj G said:

I have a system with i7 and 32GB RAM and 1TB SSD drive. It is very new and performs very well without any other issues.

This is not an issue due to an under-powered system. This is an issue because of Cakewalk's implementation of how to handle device disconnections. 

At the very least, if ASIO driver can be automatically restarted whenever device disconnection happens - that will be great. Thanks. I am hoping that some developer will chime in.

Osho

You can reload the ASIO driver manually in Cakewalk at any time by pressing CTRL and clicking the Reset button.
However when I have seen this happen this doesnt solve the problem. Some devices physically need to be power cycled. Its a hardware/driver issue.

panic.PNG

panichelp.PNG

  • Thanks 1

Share this post


Link to post
Share on other sites

I believe it to generally be best to avoid hibernation when running CbB, or any DAW, because of the hit or miss failure by some audio interface brands/models to properly come back to life, which as was pointed out earlier, is something specific to the hardware and/or associated drivers for those audio interfaces, and not anything that Cakewalk can control.

I don't do much tweaking of anything in Windows 10, (or for the computer) for prepping when using a given computer for running streaming audio applications, such as Cakewalk.  I pretty much do only the following:

1) Make sure to store sample libraries on SSD drives that are not the boot drive (not the "C" drive)

2) I modify Cakewalk Preferences, so that most content is moved off to a non-boot drive, as well.  I do this for all of the folders under Folder Locations, except for those folders that by default are stored in the AppData folder on the boot drive.  Please note that in addition to the folder locations under Edit > Preferences > File > Folder Locations, there are a couple more folder paths to modify, under Edit > Preferences > File > Audio Data - and those folders are: Global Audio and Picture Folders (Audio Data and Picture Cache).

3) I whitelist my sample libraries, as well as the Cakewalk Content folder (sub-folders to both are also whitelisted when the parent folders are).  I also whitelist the Cakewalk Core folder in Program Files, as well as the Common Files/VST3 folder and the folder containing all of my plugins (I use VST64).  All files are scanned for viruses when I download them, as my Downloads folder is not excluded from the antivirus software, and any compressed data is scanned when it gets decompressed.

4) I set my Power Plan to High Performance, with Min and Max CPU set to 100%, set it to never turn off the Hard Drives, and I also disable the USB Selective Suspend.

I also never let the computer hibernate on its own.

That's about it. (I don't think I forgot anything)

Bob Bone

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...