Jump to content
Michael Warren

2019.12 Major Latency Problem

Recommended Posts

This just started happening. As I'm playing, first every note is responsive, but then after 2 or 3 measures latency starts and as I continue, it almost takes a second after pressing not for Audio to respond.

I'm using an Oxygen 49 with midi over usb and didn't have the problem. I purchased a Code 61 and after a day the problem started. I switched back today to the 49 and again the latency slowly gets longer and longer as I play through measures. I have tried on various instrumental patches using Kontakt or other plugins with same problem. I have buffer size in Asio panel set at 256 samples. The device is a Steinberg UR22. Any ideal why this is happening? Right now the program is unusable to compose or record with this radical latency.

Thanks in advance,

Mike Warren

 

Share this post


Link to post
Share on other sites

Check you have no "MIDI loops". So Keyboard->Cakewalk->(Something)->Cakewalk->(Something) and so on. It can loop throw "MIDI out" of some synth, external software loopback device or  (rare) not properly configured MIDI keyboard.

MIDI configuration in Cakewalk and projects could be "bugged" when you have attached Code 61, especially if you have connected/disconnected it (and/or Oxygen) to different USB ports or/when Cakewalk was running. In such case cleanup MIDI devices in Windows Device manager and delete MIDI related .INI of Cakewalk (in Windows Explorer search for TTSSEQ.INI in %appdata%).

Share this post


Link to post
Share on other sites

Did you add a CPU-intensive bus processor? (i.e. linear phase EQ, mastering, etc).

Does the latency effect go away if you press the "bypass FX" button in the control bar mix module?

Share this post


Link to post
Share on other sites

I’m using no audio fx. Just tested with kontakt using one patch. Same setup as last 2 years. Beginning to think it’s my ur22 audio interface. I’m going to try changing usb cable and some other usb ports. Never happened before with oxygen 49, now it does with it and the code 61. Everything was fine over the last week until today. All drivers and firmware are up to date.

Share this post


Link to post
Share on other sites

I had an issue with my ur44 where after moving usb ports it changed from asio driver to mme, causing the same latency issues. 

 

Grant 

Share this post


Link to post
Share on other sites

No latency in Finale V25. I then went back to Cakewalk and went to preferences, control surfaces. I had multiple ACT MIDI CONTROLLER - X with in Port Code 61 and Out Port Code 61. I deleted all but the one that said Act Midi Controller - 1 and applied. That seemed to fix the problem, but it's been so squirelly, I'm not sure if that will only work for the next 5 minutes. I give up after hours of wasted time today. I'm stopping for the rest of the day and getting a cup of coffee.

Thank you for all your suggestions. I'll probably post results tomorrow if I can create for an hour. I did move the USB cable to 2.0 instead of 3. Of course it's worked the last 2 or more years in 3.0 usb, but it is a computer and it is Tuesday so who knows.

Thanks to all again,

Mike Warren

Edited by Michael Warren
left out work

Share this post


Link to post
Share on other sites

I thnk Azslow may have been correct with his midi loop suggestion. I have had no problem since deleting multiple ACT presets in cakewalk by bandlab. I’m still not sure because there was no problem usuing multiples with the oxygen 49.  If. It aint broke don’t fix it.  Just a side note. I’m not a keyboard player, but for a controller the code 61 keyboard action feels great. Brochure does not mention semi weighted, but it is. Thanks to all for your suggestions. I’m ending this thread since all is good.

Mike Warren

Share this post


Link to post
Share on other sites
On 1/21/2020 at 10:22 PM, oneofmany said:

I had an issue with my ur44 where after moving usb ports it changed from asio driver to mme, causing the same latency issues. 

 

Grant 

Hi Grant.

How did you solve that problem?

I in Audio Devices have selected the input and output of Roland UA-33 TRI-CAPTURE.

But in the Mode Driver section of MIDI / Playback and Recording, I have selected MME and it does not offer me another option.

Greetings,

Antonio

Share this post


Link to post
Share on other sites

Unfortunately the solution ended up being a fresh windows install.  This allowed me to get the asio to properly install. 

In windows control panel, the steinberg asio applet would not let me adjust the asio, nor show me the left most tab which is asio sample page. I blew driver out of device manager many times and tried to install my steinberg driver, but every time I did, once I reconnected the ur44 it changed to a Microsoft driver. Check your driver to see if same has happened to you. 

On advice in a thread I read here and elsewhere I used a USB reset utility to remove all windows USB device memory from the registry, still no go. 

I then ran windows refresh to save files (not programs) which also did not work. 

After fresh install, same order of operation, install driver, connect device, Asio applet in control panel showed the missing tab, and all worked perfectly. 

Just built a new pc for daw use, did again as above and all has been fine. 

Pretty confident that the combination of moving to a different USB port caused Microsoft to install its driver when I had reattached it, and nothing I tried allowed me to get the steinberg driver to take over. 

 

Again, check driver manufacturer in device manager, and ensure that the control panel applet has (in my case) three tabs, with the left being asio with the sample setting drop down

 

Grant 

Share this post


Link to post
Share on other sites

 

2 hours ago, Antonio Nero said:
On 1/21/2020 at 9:22 PM, oneofmany said:

I had an issue with my ur44 where after moving usb ports it changed from asio driver to mme, causing the same latency issues. 

 

Grant 

Hi Grant.

How did you solve that problem?

I in Audio Devices have selected the input and output of Roland UA-33 TRI-CAPTURE.

But in the Mode Driver section of MIDI / Playback and Recording, I have selected MME and it does not offer me another option.

Greetings,

Antonio

ASIO is an audio standard. It will not show up in the MIDI driver mode drop down. The only choices in this drop down are MME and UWP. Some devices do not support UWP and it requires Windows 10.

The audio driver setting affects "MIDI latency" because the audio driver buffer is where the delay is between hitting a key on the controller and HEARING the result.

Share this post


Link to post
Share on other sites
26 minutes ago, scook said:

 

ASIO is an audio standard. It will not show up in the MIDI driver mode drop down. The only choices in this drop down are MME and UWP. Some devices do not support UWP and it requires Windows 10.

The audio driver setting affects "MIDI latency" because the audio driver buffer is where the delay is between hitting a key on the controller and HEARING the result.

I understand then that when using Windows 7 there will be no other option available other than MME, unless you were using a UWP-compatible device under Windows 10. Thank you.

Share this post


Link to post
Share on other sites

My error, it was early morning and I thought I was replying to the OP. 

Just that the lack of asio caused a delay when I played and sang through the interface 

Grant

Edited by oneofmany
Add

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...