Jump to content
  • 0
Misha

Is there a fast way to reduce CPU usage, besides turning global FX off?

Question

Hi Folks!

Please help with 2 questions.

Trying to improve my workflow.  I use a lot of FX instances on my tracks and often run into situation where CPU is just spiking, distorting the sound.

This is what I know and had been using: 

a) Global FX on/off

b)Freezing tracks

c)Moving tracks to shared bus FX

d)Archiving muted tracks.

Questions:

1)  I was wondering if something  fast (and reversible), similar to Global FX on/off which is internal to Cakewalk can be done to temporarily reduce CPU usage, but still retain audible FX on channels?  

 

2) What is the most important factor in CPU to handle FX better.  Frequency or number of cores if we are talking of processors i7  processors 7th generation or higher.

 

Thank you,

Misha.

 

 

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

All of your methods of reducing CPU that you've mentioned above are good ones, and are the ones I'd recommend.

One other, which is pretty quick would be to increase your ASIO buffer.

This would be less suitable for tracking however. For tracking, freezing tracks would be my first option.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Mark, 

Thank you, but it is for tracking... Increasing Asio buffer would not work.

I was hoping there is a global temporary "render quality" reduction..... or mono or similar? to temporary reduce CPU usage.

Anybody else?

pwalpwal,

Thanks for reply,

when you said "faster CPU" did not answer the question. Faster in terms of frequency or number of cores that specifically responsible for handling VST FX? 

 

Thank you.

 

Share this post


Link to post
Share on other sites
  • 0

I would think that freezing all tracks that you are not working on at the moment would be the simplest thing to do, and give you the most CPU back to use for your current track.  You can freeze tracks with the audio effects in place so you will still hear them in the frozen tracks, but without the extra CPU load from the FX plugin. It is similar to bouncing the track down with FX applied.

Also by creating an FX bus and sending similar tracks to the same FX plugins would reduce the number of duplicate FX plugin instances used in the project, and that should lighten the CPU load.

Share this post


Link to post
Share on other sites
  • 0

abacab, thanks.

That is what I described and exactly what I am doing.  I am looking for a fast  solution, similar to turn global FX off. Not clicking and un-clicking 30+ tracks to freeze/unfreeze something.  I was hoping there is a setting something like temporarily reducing the quality of playback to reduce CPU load... A one or two button operation.  Not 30+ clicks :)  each time.

P.S. An interesting suggestion in request  was submitted by a fellow user  in reply to one of my posts in Feedback Loop section.  A whole BUS freeze/unfreeze.  I thought that was awesome suggestion. 

Share this post


Link to post
Share on other sites
  • 0

A bus has no data to freeze but it may be bounced.

Bounce everything possible through a bus or two to create a submix and archive the bounced tracks/buses after bounce.

Aside from quick groups and control groups, folders are a quick way to archive a group of tracks.

As far as a CPU conservation option there is this.

  • Thanks 2

Share this post


Link to post
Share on other sites
  • 0

One other thing to consider, when running at low latency, plug-in load balancing may be turned off even when the option is enabled. The documentation covers how to adjust this feature.

Share this post


Link to post
Share on other sites
  • 0

And the answer to clock vs. cores is.....both.

The best solution is a fast clock and high core count. If one has to choose, do not give up too much clock for a few extra cores.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, scook said:

Bounce everything possible through a bus or two to create a submix and archive the bounced tracks/buses after bounce.

Aside from quick groups and control groups, folders are a quick way to archive a group of tracks.

Once the source tracks have all been bounced and added to  folder(s), it is a quick one-click operation to archive/un-archive those source tracks at the folder(s) level. 

Good tip!

Share this post


Link to post
Share on other sites
  • 0

I usually just bounce down a whole mix minus what I'm about to record and then "archive" the folders of tracks that use the most CPU.

R

  • Great Idea 1

Share this post


Link to post
Share on other sites
  • 0

Bounce the current mix to another track. Turn of all fx and solo that track plus whatever track you are recording.

Share this post


Link to post
Share on other sites
  • 0

Scook, you are the man! I think this solved it: Plug-in load balancing. No CPU spikes! 

Thank you!

I usually keep things manageable, but have a few larger projects that are just like a giant pasta bowl, I tried "plugin load balancing" on largest, I am sure it will work on smaller projects as well.

Thank you everybody who shared their solutions!

Still want to get more insight on how Vsts impact CPU... I assume, prior to enabling "plugin balancing" I was using only a single core of dual core computer?

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
  • 0
On 1/25/2019 at 11:45 AM, scook said:

One other thing to consider, when running at low latency, plug-in load balancing may be turned off even when the option is enabled. The documentation covers how to adjust this feature.

I have Use Multiprocessor Engine and Plug-in Load Balancing ticked. I'm using iZotope mixing, mastering and metering plugins. My CPU is a 6 core, 12 thread i7-6850K @ 3.6GHz with 32 GB memory. All drives are 256 GB SSD. Two have M.2 interfaces.  I have a Radeon R7 250 series video card.The projects I'm working on now tend to have 8-10 audio tracks, 8-10 aux tracks and 3 buses.  Sample rate is 44.1 or 48 kbps and recording bit depth is 24 bits.

My Focusrite 8i18 (original USB 2.0 version) audio interface adjust the Mixing Latency Buffer Size based on a user selected latency in ms. I have it set to the maximum  of 20 ms for mixing which sets the Mixing Latency Buffer Size to 883 samples. See screenshot attached.  Also note ASIO reported latency values which far exceed the 883 samples.

During playback, all threads hover around the bottom on the Performance module. No threads ever goes above 25% but there's a lot of audible popping and cracking and I don't know why. I've only recently started using the iZotope Production Suite which I really like and I suspect that products represent a significant CPU load, but the CPU doesn't seem to notice them. Any ideas why this is happening or what I can do about it?

 

On 1/25/2019 at 11:17 AM, scook said:

A bus has no data to freeze but it may be bounced.

Bounce everything possible through a bus or two to create a submix and archive the bounced tracks/buses after bounce.

Aside from quick groups and control groups, folders are a quick way to archive a group of tracks.

As far as a CPU conservation option there is this.

Under CPU conservation option, I read the link but didn't understand how to implement GPU throttling. I'm sure I'm missing something obvious but I don't even know where the "pause" key is. 

Also, I keep the Radeon Settings app in the system tray for hidden icons and wonder if that could contribute to the problem.

2019-01-27.png

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, Twisted Fingers said:

 I don't even know where the "pause" key is.

Depends on your keyboard. Mine is the rightmost key on the line with the function keys.

Share this post


Link to post
Share on other sites
  • 0

Scook,

is it possible to "assign" this  PaUsE button to some other button? I could not figure that out also :)

Thank you. 

 

Share this post


Link to post
Share on other sites
  • 0
On 1/27/2019 at 6:21 PM, scook said:

Depends on your keyboard. Mine is the rightmost key on the line with the function keys.

Scook, thanks. I'd forgotten about those. Both the Pause and Scroll Lock keys are present on my desktop keyboard and work as described. They reduce dropouts but don't stop them.  My main question is why am I getting dropouts at all? My CPU seems to be idling along with plenty of capacity left, but I'm still getting dropouts? Is there anything I can do to make the CPU work harder to reduce dropouts? See quoted  DAW performance information below. Thanks.

 

On 1/27/2019 at 6:12 PM, Twisted Fingers said:

I have Use Multiprocessor Engine and Plug-in Load Balancing ticked. I'm using iZotope mixing, mastering and metering plugins. My CPU is a 6 core, 12 thread i7-6850K @ 3.6GHz with 32 GB memory. All drives are 256 GB SSD. Two have M.2 interfaces.  I have a Radeon R7 250 series video card.The projects I'm working on now tend to have 8-10 audio tracks, 8-10 aux tracks and 3 buses.  Sample rate is 44.1 or 48 kbps and recording bit depth is 24 bits.

My Focusrite 8i18 (original USB 2.0 version) audio interface adjust the Mixing Latency Buffer Size based on a user selected latency in ms. I have it set to the maximum  of 20 ms for mixing which sets the Mixing Latency Buffer Size to 883 samples. See screenshot attached.  Also note ASIO reported latency values which far exceed the 883 samples.

During playback, all threads hover around the bottom on the Performance module. No threads ever goes above 25% but there's a lot of audible popping and cracking and I don't know why. I've only recently started using the iZotope Production Suite which I really like and I suspect that products represent a significant CPU load, but the CPU doesn't seem to notice them. Any ideas why this is happening or what I can do about it?

 

Under CPU conservation option, I read the link but didn't understand how to implement GPU throttling. I'm sure I'm missing something obvious but I don't even know where the "pause" key is. 

Also, I keep the Radeon Settings app in the system tray for hidden icons and wonder if that could contribute to the problem.

2019-01-27.png

 

Share this post


Link to post
Share on other sites
  • 0

System issues are beyond the scope of this thread. Extreme settings tend to create problems rather than solve them. There is a setting in Aud.ini to reduce sensitivity to dropouts but there may be more going on in this case, possibly DPC latency, background processes or a hardware issue.

Share this post


Link to post
Share on other sites
  • 0

Maybe i am missing it but what interface and connection(usb,firewire etc) are you using? Also, what are your Asio settings? Perhaps you are expecting too much from the interface and drivers?

I believe Noel has suggested unchecking unused inputs and oututs to help with crackles etc.

Share this post


Link to post
Share on other sites
  • 0
On 1/29/2019 at 12:03 PM, scook said:

System issues are beyond the scope of this thread. 

Thanks scook. Do you mean the Q&A forum or something else? Also, is there a good place on the Cakewalk forum for system issues?

On 1/29/2019 at 12:03 PM, scook said:

Extreme settings tend to create problems rather than solve them. 

Are you referring to setting the audio interface to the maximum latency?

On 1/29/2019 at 12:03 PM, scook said:

There is a setting in Aud.ini to reduce sensitivity to dropouts but there may be more going on in this case, possibly DPC latency, background processes or a hardware issue.

Thanks for the suggestions. 

Share this post


Link to post
Share on other sites
  • 0
18 hours ago, scottfa said:

I believe Noel has suggested unchecking unused inputs and oututs to help with crackles etc.

Thanks scottfa. I did that and it didn't appear to help.

18 hours ago, scottfa said:

Maybe i am missing it but what interface and connection(usb,firewire etc) are you using? Also, what are your Asio settings? Perhaps you are expecting too much from the interface and drivers?

scottfa, I think all these questions in my earlier post quoted below. I've verified that my Focusrite 18i8 drivers are up to date and I'm using the intel Driver Support Assistant to keep other drives up to date.

On 1/27/2019 at 6:12 PM, Twisted Fingers said:

I have Use Multiprocessor Engine and Plug-in Load Balancing ticked. I'm using iZotope mixing, mastering and metering plugins. My CPU is a 6 core, 12 thread i7-6850K @ 3.6GHz with 32 GB memory. All drives are 256 GB SSD. Two have M.2 interfaces.  I have a Radeon R7 250 series video card.The projects I'm working on now tend to have 8-10 audio tracks, 8-10 aux tracks and 3 buses.  Sample rate is 44.1 or 48 kbps and recording bit depth is 24 bits.

My Focusrite 8i18 (original USB 2.0 version) audio interface adjust the Mixing Latency Buffer Size based on a user selected latency in ms. I have it set to the maximum  of 20 ms for mixing which sets the Mixing Latency Buffer Size to 883 samples. See screenshot attached.  Also note ASIO reported latency values which far exceed the 883 samples.

During playback, all threads hover around the bottom on the Performance module. No threads ever goes above 25% but there's a lot of audible popping and cracking and I don't know why. I've only recently started using the iZotope Production Suite which I really like and I suspect that products represent a significant CPU load, but the CPU doesn't seem to notice them. Any ideas why this is happening or what I can do about it?

 

Under CPU conservation option, I read the link but didn't understand how to implement GPU throttling. I'm sure I'm missing something obvious but I don't even know where the "pause" key is. 

Also, I keep the Radeon Settings app in the system tray for hidden icons and wonder if that could contribute to the problem.

2019-01-27.png

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...