Jump to content
Sign in to follow this  
Starise

Sampletank 4 Locks Up

Recommended Posts

Is anyone else having issues with Sampletank 4? I have Sampletank 3 and had not used it much but never recall having any problems with it. Not too long ago I bought Sampletank 4 LE on a deal thinking I might upgrade to 4 later. The library that comes with it looked pretty good for the LE version.

Several weeks ago was the first time I attempted to use ST4 LE. I unzipped the library samples and put them on one of my internal SSDs. Not on my C drive. Cakewalk sees the VST. When I drag the VST to my tracks view ST locks up every time. I went to the IK site and made sure I was using the latest build. Same issue. Tried stand alone and it works maybe 50% of the time or less. The loaded libraries are not all being seen either. The arpeggios are there but not all of the sounds, even though the sounds all show up on my D drive and are unzipped. When I downloaded the library I pointed everything to the library drive for samples.

Slightly disappointing. Updates haven't helped. Updating the Sampletank custom shop hasn't helped. It is pretty much useless to me at this point.

 

Share this post


Link to post
Share on other sites

Yes I went back and made sure I was activated.  I'll attach a pic of the screen I get right before Cakewalk shuts entirely down. I'm not sure what this means.

ST4.png

Share this post


Link to post
Share on other sites

It says the SampleTank 4 VST3 has an issue.   I have a couple of thoughts.

First the exception message indicates SampleTank 4 experiences the issue so you need to get IKMultimedia support involved.  Collect the crash dump file and either provide a link to the file (if it's stored online) or attach the file to your IKMultimedia support  support email.  Look in my signature for the link pointing to a really good thread about how to collect a crash file.

Second, VST3s seem to be more likely to crash than their VST counterparts.  Try using a SampleTank 4 VST if one is available instead of the VST3.  This might keep you going until the VST3 issue is addressed by IKMultimedia.

Third, since the VST3 crashes in Cakewalk by BandLab I would also open a support ticket with Cakewalk by BandLab support.  Cakewalk by BandLab developer Noel Borthwick has stated multiple times the development team will work with software developers to resolve issues.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks Jim.

I guess I wanted to make sure I wasn't overlooking something before I went that far. A few things that seem "off" to me about this. First the  VST is white in the tree when most of the others are orange. The info indicated it's a VST 3 plug in. I will try to post pics of what I mean here. 

Secondly, since I don't have a desktop shortcut I'm going over to the IK programs folder to open ST4. In that folder the icon is off...almost as if something didn't register the graphic. ST4 does however, play some of the sounds ok in stand alone mode. I locks every time in Cakewalk as a VST. 

My product shows up in the purchased list, but does not show up as a purchase in the custom shop Sample Tank area. This happens even when I reload my purchases........

synth list.png

ST icon.png

Edited by Starise

Share this post


Link to post
Share on other sites

SampleTank 3, IIRC, never worked reliably with the VST3 dll, use the VST2 dll. I don't have any IK VST's in my VST 3 folder, everything IK; AmpliTube4, TRackS, are the VST2 dll's. I never upgraded to ST4.

Tom

forgive me if someone already has pointed this out...

Edited by DeeringAmps
added content
  • Like 2

Share this post


Link to post
Share on other sites

The exception message states the VST3 version of SampleTank 4 experienced the issue.  That is why I suggested using a VST2.  However, I don't know if SampleTank 4 is available as a VST2 effect.  The IKMultimedia site does not say and I don't have the product

Share this post


Link to post
Share on other sites

@Starise...I've trouble ticketed the exact crash message you have posted to IK,as I'm getting the same with a brand new ST4 install.

Neil

  • Like 3

Share this post


Link to post
Share on other sites
4 hours ago, Neil Cummins said:

@Starise...I've trouble ticketed the exact crash message you have posted to IK,as I'm getting the same with a brand new ST4 install.

Neil

Neil, please keep us posted if you receive any updates. A viewer of one of my SampleTank 4 vids is having the same issue so any help in finding a solution would be great. There has to be some common denominator somewhere that triggers this on some setups and not others.

  • Like 1

Share this post


Link to post
Share on other sites
22 hours ago, Starise said:

When I drag the VST to my tracks view ST locks up every time.

Have you tried using the Insert Soft Synth? There might be an issue when dragging and dropping. I will try dragging and dropping here and see what happens.

22 hours ago, Starise said:

The loaded libraries are not all being seen either. The arpeggios are there but not all of the sounds, even though the sounds all show up on my D drive and are unzipped. When I downloaded the library I pointed everything to the library drive for samples.

So just checking; when you unzipped them did you run the installer as well (sorry if I misunderstood)? If there is a chance the sounds installer placed them in another directory you can add that path to ST4 and do a rescan to make sure the sounds database is updated.

20 hours ago, Starise said:

Yes I went back and made sure I was activated.  I'll attach a pic of the screen I get right before Cakewalk shuts entirely down. I'm not sure what this means.

ST4.png

This the exact screen that pops up in my friends issue.

*disclaimer; not assuming anything, just trying to help troubleshoot 😎

Share this post


Link to post
Share on other sites

@Simeon Amburgeyand @Starise...in my case,here's a a typical scenario:-

1. Create new project eg using Simple template with 1 Audio and 1 x MIDI track.

2. View Synth rack and load ST4.The crash occurs for me with either VST2 or VST3 version loaded.

3. Select instrument in ST4 and correct MIDI channel.

4. Import MIDI file into the ST4 MIDI track.

5. Test play for audio response,all good so far.So I can use it to generate music...

6. Save project,then exit.

7.Log straight back into project...and crash with the dialogue box as shown above.

8.Sometimes.....if I freeze the synth track to generate an audio file,the project survives up until maybe changing instrument in ST4,then it will fail again as above.

9.ST4 standalone works fine.

CbB and ST4 both up to date builds,I'm running Windows 10,not a high spec laptop but doubt this is relevant.

...05 February update...no change after the CbB 2020.01 load,still seeing the same crash on opening projects containing ST4.

Neil

Edited by Neil Cummins
Update
  • Like 1

Share this post


Link to post
Share on other sites
35 minutes ago, Neil Cummins said:

1. Create new project eg using Simple template with 1 Audio and 1 x MIDI track.

2. View Synth rack and load ST4. The crash occurs for me with either VST2 or VST3 version loaded.

So this is crashing but then - 

37 minutes ago, Neil Cummins said:

3. Select instrument in ST4 and correct MIDI channel.

4. Import MIDI file into the ST4 MIDI track.

So in this step it seems that ST4 loads; so does the crash happen on load or when you pull it up after it is inserted?

Share this post


Link to post
Share on other sites

Sampletank 4 (and all IK instruments) all use OpenGL for their UI.  OpenGL isn't provided by Windows, it's actually provided by your video card driver.  Video card drivers almost always need to be updated/maintained by hand.  Windows won't do it right.  You may want to update your video card drivers.  If Sampletank crashes when you first insert it, that would be the most likely cause.

If Sampletank doesn't crash when you first insert it, but rather when you try to open a project you saved using it.  That's a completely different kind of issue.  Your description of the problem is very unclear.

Problems with Sampletank once it's open and the other things in your first message about instruments and arpeggios, sounds more like an installation problem, which could very well be your crashing issue as well.  Installing Sampletank and all the sound libraries can involve a bit of pain (especially the larger MAX package).   You really need to read and install it exactly how IK describes.

You should have a Sampletank 4 content directory.  You tell Sampletank where this is in the Sampletank Settings dialog, Sound Content panel.  It should have the path to your Sampletank 4 content.  Which is where you should have installed all the content by downloading and running all the content installers, one at a time.

Your Sampletank 4 content library should be stored in a directory you have write privileges on.  This can often mess people up, since the installer runs as admin and they stick the content someplace they can't actually write as a user.  There are other ways to make this fail also, sadly.

If you really have installed everything correctly and you have updated your video card drivers and it still crashes, I hate to tell you this but there is zero chance IK support will be able to help you in the slightest.  I have YEARS of history trying to get them to fix bugs where I've given them exact steps to reproduce the problem, which they confirmed would crash for them to only to have it not be fixed. 

The good news is that it's not crashing like this for most people (me for example) so odds are it's something about your config and installation.  But again only you know how you installed it and configured it.

 

  • Like 3

Share this post


Link to post
Share on other sites

Thanks Matt and others for chiming in. I think I have finally found the answer which was something I overlooked. Since I  recently installed ST4 I was pretty sure I had the latest version. Wouldn't you know it was version 4.0.7 and not version 4.0.9.

I uninstalled that version and reinstalled 4.0.9 from the IK website>products area.  FWIW I went to their forum and this has been occurring on pro Tools , Ableton and Fruity Loops to name a few...so this was not a Cakewalk issue. 4.0.7 and maybe earlier versions are buggy. I loaded the old version into Studio One and I had some kind of a default dummy graphic.   I guess the SE library is lighter than I thought it was. Scanned that twice. Unzipped multiple files and still only have maybe a handful of sounds there. Shouldnt ST 4  show up on my Custom shop ?

I knew something was amiss when I seen the default graphic. See the pics below. If you have the grapic in the first pic there's a problem. Looks as if there's an issue with my TRacks too.

ST icon.png

snip2.png

  • Like 2

Share this post


Link to post
Share on other sites

I wouldn't put too much into Windows icons.  The whole system for how that works is kind of broken.  Software can be installed and work 100% and still not have the right Windows icons.  If you Google around you'll find tons of people with issues and advice on rebuilding the icon cache etc.  But it can be a sign something is wrong too.

I'm not sure what's in the SE library (I have MAX plus a huge collection of Sampletank 3 libraries that Sampletank 4 loads/uses).  You may need to download some installers though.  Here's the sound list:

https://www.ikmultimedia.com/products/include/st4/soundlist/SampleTank_4_SE_Instruments.pdf

That's a pretty big list of instruments (30gigs).  Sampletank 4.0.9 has definitely been better than a few of the earlier releases.  You might want to search your computer to make sure you don't accidentally have older versions of the plugins in other directories.

If your  Sampletank 4 content dir isn't near 30gigs I'd say you're missing something.

Edited by Matthew Sorrels
  • Like 1

Share this post


Link to post
Share on other sites

Thanks Matt for sharing the preset list.

I guess I'm not finished yet. I have nowhere near that number of presets. I set all of my sound files in what is D drive on my computer. I made a folder for it called Sampletank Sounds. I unzipped everything in all of the folders. I pointed ST4 to that folder.

I'll let you know what I find.  I am admin on this computer. Shouldn't be a factor but I've been wrong before. This is the kind of thing that absolutely KILLS any creativity I had in trying to work out these kinds of issues. I know a certain amount of it is inevitable.. I'm just ready to be playing instead of looking for more boo boos lol.

Edited by Starise

Share this post


Link to post
Share on other sites

You may need to download each of the Sampletank sound installers, unzip them and run them and point them to the same directory.  Trying to get around the installer by "hand unzipping" may result in more problems.  There are a lot of downloads and  installers for Sampletank content (even more if you are doing the full MAX version) and it takes forever to fully unzip and run all of them.  When you are finally done, start the stand alone version and it will rebuild the database.  Which takes forever also.  When it's all done though you should have a ton of presets even for the SE version.

  • Thanks 1
  • Great Idea 1

Share this post


Link to post
Share on other sites

Thanks Matt.

I found the issue. I was looking at the middle box for my presets. I didn't see meta data so figured something was amiss. Must have rebuilt my data 5 times. I happened to go to load instrument on the first track and there it was! All of the meta data. Duh..... I thought I pretty swift on learning new software. I will say that I'm still not sure why a few programs show up under the middle drop down box. If nothing had showed up at all it would have been better than seeing a few sounds there and wondering why they all weren't there? 

Once you get to know the way it all works it's pretty nice actually. Seems way more intuitive in that respect than Kontakt for multis. I'm not usually a multi person, but this makes building one look tempting to me. Looking through the presents I didn't see a solo violin. Might have missed it....or they save that for their orchestra package.

Max is a monster! I especially don't understand lines and lines of drum kits/sounds, but that's me. I guess they get loaded across the keyboard and you can mate them or map them to a kit? Using a drum program seems more intuitive in that respect. That's the thing though, all types of musicians are using it who do lots of different stuff. Laying out an instance, mapping the different parts to different keys, Adding movement to it using loops has a lot of potential. I think ST4 is a vast improvement over ST3. It is tough for me to move from Kontakt, but I could see only working in this world and never using Kontakt for some people.

I would give it a 4 out of 10 for intuitive use for first time users of ST4 like myself. Those earlier versions undoubtedly didn't give the product the best rap. An 8 out of 10 for the SE version. I would take that higher for the more equipped versions. The middle version seems to have almost everything the Max version has. ST4 also uses my ST3 sounds.

I have heard comments on the samples not all being the best. The vast majority of the ones I played were nicely done. So far as I know most of the samples don't use the same kinds of techniques used by Spitfire or similar. The stand alone cello sounded good to my ears. I would probably use Joshua Bell violin instead of their violin anyways. The acoustic guitars are pretty impressive for sampled guitars which are mostly on offer with the higher versions...This is another thing that can be covered by others in Kontakt for not a lot of $$  if you have the SE version. Only Max version covers these bases completely. I seldom if ever use sampled electric guitars because I just can't make them sound real. I have acoustic guitars in my studio and I SHOULD be using them.

Edited by Starise

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...