Jump to content
reza sadeghi

pops and crackles

Recommended Posts

Posted (edited)
2 hours ago, reza sadeghi said:

Thanks. I already have done all of them but still same.

Did you disable Intel Speedstep (and possibly C-States) via Windows or BIOS?

Edited by Promidi

Share this post


Link to post
Share on other sites
4 hours ago, Gswitz said:

Usb is showing up in your report.

Are you sure that you have disabled select suspend? How about power save on usb hubs in device manager? Unplug all but your interface, mouse and keyboard. Is your keyboard wireless?

Windows key+x... Select device manager.

What is this coming from?

 

Yes I disabled the suspend  by going to device manager and going to power management on each universal serial bus controller drop down.mouse and keyboard is wireless

Share this post


Link to post
Share on other sites
6 minutes ago, reza sadeghi said:

yes I did.

I was asking whether you disabled Intel Speedstep (and possibly C-States) via Windows or did you do it in the BIOS?

Share this post


Link to post
Share on other sites
Posted (edited)
4 minutes ago, Promidi said:

I was asking whether you disabled Intel Speedstep (and possibly C-States) via Windows or did you do it in the BIOS?

I disabled it in bios and also put the power option in windows on high performance. sorry if  I didn't understand yourInsert other media question 

Edited by reza sadeghi

Share this post


Link to post
Share on other sites

some update:

I installed windows 10 ver 1709 and installed my audio device driver. no pops and crackles. every thing is working perfect . I download all the windows 10 updates to see if the updates cause the issue. I got the ver 1909 which is the latest windows 10 version. All the pops and crackles came back. So it means some thing is wrong with the new version of windows 10. 

I hope someone have a solution. 

Share this post


Link to post
Share on other sites

Keep at it. 

You disabled usb select suspend in advanced power settings?

Removed unnecessary devices?

Click start button, type background, click disable all background services.

In latency monitor, what is still listed in driver tab at the top sorted descending.

Share this post


Link to post
Share on other sites
3 minutes ago, reza sadeghi said:

some update:

I installed windows 10 ver 1709 and installed my audio device driver. no pops and crackles. every thing is working perfect . I download all the windows 10 updates to see if the updates cause the issue. I got the ver 1909 which is the latest windows 10 version. All the pops and crackles came back. So it means some thing is wrong with the new version of windows 10. 

I hope someone have a solution. 

You say you record at 96K.  You also stated that changing windows audio setting to 48 khz and the pops go away.

From that, I gather that changing windows audio setting to 48 khz and the pops return.

Just confirming.  As well as recording at 96K, Are your projects also set to 96K (under tempo)

Preferences | Audio | Driver settings > Default settings for new project , set to 96K?  (I am assuming so)

Share this post


Link to post
Share on other sites

Just curious - is there an active wireless network adapter?  Sometimes, those can cause issues.  A quick temporary disabling, if present, of a wireless adapter in Device Manager (NOT uninstalling, just temporarily disabling), would quickly show, one way or the other, if that was a contributing factor.  For the folks that have issues with streaming audio that are caused by wireless network adapter drivers, find success by disabling them in Device Manager, just prior to launching CbB, and then enabling them when finished with their CbB session.

Bob Bone

 

Share this post


Link to post
Share on other sites
7 hours ago, Promidi said:

You say you record at 96K.  You also stated that changing windows audio setting to 48 khz and the pops go away.

From that, I gather that changing windows audio setting to 48 khz and the pops return.

Just confirming.  As well as recording at 96K, Are your projects also set to 96K (under tempo)

Preferences | Audio | Driver settings > Default settings for new project , set to 96K?  (I am assuming so)

yes I record all my project at 96khz . If you change windows audio setting from 96khz to 48 khz pops go away and if I set it back to 96khz it will start again.

I set to 96 khz for my new projects under Preferences | Audio | Driver settings > Default settings for new project.

Share this post


Link to post
Share on other sites
7 hours ago, Gswitz said:

Keep at it. 

You disabled usb select suspend in advanced power settings?

Removed unnecessary devices?

Click start button, type background, click disable all background services.

In latency monitor, what is still listed in driver tab at the top sorted descending.

yes I disabled them all and removed the unnecessary devices and programs. also disabled the background services.

still shows wdf01000.sys which has the highest number.

Share this post


Link to post
Share on other sites
21 minutes ago, reza sadeghi said:

yes I record all my project at 96khz . If you change windows audio setting from 96khz to 48 khz pops go away and if I set it back to 96khz it will start again.

I set to 96 khz for my new projects under Preferences | Audio | Driver settings > Default settings for new project.

Why not just leave windows audio setting at 48 khz.  ASIO bypasses Windows audio anyway.... so while you're in CbB, windows audio setting is being bypassed.

(Though I can't explain why setting windows audio to 96k give pops and click in CbB)  Maybe a CbB dev could chime in here. 

Share this post


Link to post
Share on other sites
1 hour ago, reza sadeghi said:

yes I record all my project at 96khz . If you change windows audio setting from 96khz to 48 khz pops go away and if I set it back to 96khz it will start again.

I set to 96 khz for my new projects under Preferences | Audio | Driver settings > Default settings for new project.

@reza sadeghi It would appear that this is a driver issue. Please notify the vendor that when Windows is set to 96K it is affecting ASIO playback.
However as ProMIDI says there is no good reason to have Windows use the driver at 96K. In fact you should preferably not route windows to your main audio interface all the time to avoid unwanted interactions with the driver from Windows while using ProAudio applications.

Share this post


Link to post
Share on other sites
36 minutes ago, Noel Borthwick said:

In fact you should preferably not route windows to your main audio interface all the time to avoid unwanted interactions with the driver from Windows while using ProAudio applications.

I second the motion. Leave your onboard sound enabled and set as the default audio device for Windows, browsers and other generic multimedia apps, reserving your Focusrite interface for Cakewalk and other ASIO-optimised apps. If you need to hear multimedia audio through your studio monitors, use an external mixer.

Share this post


Link to post
Share on other sites

Thanks. The reason I put the windows setting on 96khz is because if I play something in youtube or play a music in media player while my cakewalk is open on a 96khz project, my Audio device which is Antelope Orion Studio HD hangs and I have to power cycle the audio device which is so annoying. that's why I set the windows audio on 96khz. 

As I wrote an update above, after I installed a very first version of windows 10 build 1703 there were no pops and crackles. I downloaded some windows update accidentally that one of them was related to usb 3 driver  and even with  build 1703 I got pops . I uninstalled them and problem solved. It means it should be a glitch in windows 10.

Share this post


Link to post
Share on other sites
26 minutes ago, reza sadeghi said:

If I play something in youtube or play a music in media player while my cakewalk is open on a 96khz project, my Audio device which is Antelope Orion Studio HD hangs and I have to power cycle the audio device which is so annoying. that's why I set the windows audio on 96khz.

I am also inclined to suggest using the onboard sound enabled and have it set and set as the default audio device for Windows.

Share this post


Link to post
Share on other sites
On 1/7/2020 at 1:17 AM, Promidi said:

I am also inclined to suggest using the onboard sound enabled and have it set and set as the default audio device for Windows.

Yes. it is a good solution. I contacted to Antelope again and waiting for their response.

Thanks

Share this post


Link to post
Share on other sites

I think this may be the issue:

Highest DPC routine execution time (µs):              2913.868796
Driver with highest DPC routine execution time:       Wdf01000.sys - Kernel Mode Driver Framework Runtime, Microsoft Corporation

On my laptop, the highest DPC routine execution time is 150µs. So Wdf01000.sys may be the culprit. I Googled it and found this thread on the NI website:

https://www.native-instruments.com/forum/threads/help-me-latency-issues-wdf01000-sys-windows-8-1.255434/

Looks like the exact same issue and the exact same results in LatencyMon.

Edited by Scott Reams

Share this post


Link to post
Share on other sites
23 hours ago, reza sadeghi said:

Yes. it is a good solution. I contacted to Antelope again and waiting for their response.

Thanks

I have an RME Fireface UFX and I use my onboard soundcard for all non-pro-audio Windows sounds. I route the analog outputs of that card into my Fireface and monitor it through that, so everything still comes out of the same speakers.

Edited by Scott Reams

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...