Jump to content

Search the Community

Showing results for tags 'low latency'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • News & Announcements
    • Product Release Info
    • Frequently Asked Questions
  • Cakewalk Products
    • Cakewalk by BandLab
    • Instruments & Effects
    • Feedback Loop
  • Community
    • Tutorials
    • Songs
    • UI Themes
    • The Coffee House v2.0

Product Groups

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me

Found 1 result

  1. I recently upgraded some of my home PC's to Windows 10 build 1903 and was curious what audio performance would be like in a worst case under optimized scenario. I was pleasantly surprised!This is a very rough demonstration showing low latency audio using Cakewalk with Windows 10 build 1903 and nothing more than an on-board audio chipset and a really old PC (built in 2008). Audio is low-fi in the video since the sound is going through some ancient desktop speakers and recorded through my phone. This is intentional The machine is a very old Core I7 PC built in 2007 that I recently upgraded to windows 10 build 1903. I was curious about audio performance so I did a quick test in Cakewalk to check audio and was pleasantly surprised when I was able to use WASAPI at the lowest latency setting (144 samples) with no audio glitches whatsoever, using just the onboard RealTek audio chipset. The test showed live playback with a virtual instrument, but it also worked well with standard audio track playback. For this test I used WASAPI exclusive mode with the onboard Realtek audio device, since Windows 10 shared mode low latency only works with the Microsoft inbox HDAudio driver presently. I haven't come across any other on-board devices which support Windows 10 low latency with shared mode. This test shows that WASAPI is finally able to live up to it's promise of low latency audio in Windows with even basic vanilla on-board audio devices! I don't recall this old PC every being able to do low latency playback on prior versions of Windows, so I attribute this to some combo of improvements to Cakewalks optimized low latency WASAPI support, or Windows 10 build 1903 itself. Either way this is impressive on multiple levels. Its great that Windows can do completely acceptable low latency audio support out of the box today. And the fact that Window's 10 works better on an an ancient PC like this is an accomplishment. Microsoft has been getting a lot of flak these days, but after the fiasco with Apple's Catalina breaking music apps, Microsoft deserves some kudos for their support of legacy systems. Its not surprising that some things go wrong with such a massive base of hardware but the fact that a 11 year old PC can perform decently with low latency on a current OS is quite an achievement. Now if Microsoft Surface team can get their act together and release 1903 on their own first party hardware that would be even better lol. I think @Pete Brown might be happy to learn this 🙂 PS: I'm curious to hear what other users performance is like with 1903 and just using on-board audio devices with WASAPI in CbB.
×
×
  • Create New...