Jump to content

bvideo

Members
  • Content Count

    38
  • Joined

  • Last visited

Community Reputation

10 Good

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I'm interested to know how mildly and how substantially overhead might be increased by stacking a mono-timbral synth. Also, I wonder if a multi-timbral synth can run multi-threaded.
  2. I had the problem of my Korg M1 (64-bit VST2) opening properties all blank/white in an existing project. I tried Korg Wavestation (also 64-bit VST2), and the same thing happened. I use the Intel onboard 630, no MSI, no gaming software, only one monitor. The project is fine in Sonar latest Platinum. I worried! The project was last saved by Sonar X2. I resaved it from Platinum, and then those VSTi's worked OK in Cakewalk. Lucky me to have Platinum still around.
  3. I guess my notions of mute and solo come from mixing equipment, where they apply to any signal on a channel. The "soloing tracks" article you posted doesn't say whether it applies to MIDI or audio, and it doesn't refer to the input echo control, or make a distinction between recorded or live signal. The MIDI echo article doesn't refer to mute or solo. So really, the behavior is not spelled out, so it could be anything. It's potentially confusing in its description, and maybe as well in its implementation, since recorded and live signal are merged somewhere along the signal chain, but it's not spelled out for MIDI. I did notice, though, that the behavior for audio tracks is different from MIDI. In particular, solo on one audio track shuts off the incoming live signal on a separate, echo-enabled, track. (simple: project with two empty audio tracks, both echo enabled; listen to audio input through one of them, then solo the other; the audio stops) That is how I expected MIDI to work, too. Here's Cakewalk's audio signal flow. The little tan M and green S operators come well after recorded material merges with live input, so it's pretty clear how audio should work, and it does seem to work that way. I haven't seen the MIDI equivalent signal flow diagram. Sorry I was so late to respond. By the way, I don't use "Always Echo Current MIDI Track". But that possibility just brings up the notion that the echoed "Current MIDI track" with a mute, or some other track with solo, would cause the same behavior as I observed for a conventionally input-echoed track. Bill B.
  4. You could write for Stephen Wright. Actually, here is a Stephen Wright line: "Last night I played a blank tape at full blast. The mime next door went nuts." Your line is funnier.
  5. support@cakewalk.com, for reporting, but no tracking that I know of. It sounds like a bug. Can it be isolated to the playback of just one track or does there need to be a stream from multiple tracks? Generally, people find that those initializing MIDI messages need to be spaced out in time in front of all the notes, otherwise the first notes are all skewed depending on how long the synths take to engage program changes, not just sysex messages. The same might be said for controls & program changes on the same track, namely leaving time after a patch change before the next control. (I come from a world of dino-synths, so maybe today's synths process patch changes or sysex instantly.) Also, MIDI is pretty slow, on the order of just over 3 bytes per ms. That's 1.6 bytes per Sonar's tick at 120 bpm. So putting a sysex in there is guaranteed to delay some of the other messages "on the same tick". Still, order is certainly important.
  6. Oh no. Now I'm getting the impression that solo combined with input echo is goofy too. I echo-enabled two MIDI tracks and soloed one. Data from the keyboard still gets through the non-soloed one. What's more, after I played around with mute, solo, and echo enable, there came a point where all solos and mutes were off, input echoes on, but one of the tracks would not register input on its meter. A few clicks later and it did register. Sorry, no recipe just yet. I sent the original report to Cakewalk support.
  7. Apparently smart mute makes the synth track follow mute operations on the MIDI track, but not vice versa. Not clearly described in the manual.
  8. Gswitz, The icon in the plugin window I referred to is meant to globally set / unset upsampling individually for the particular plugin. It does indeed modify AUD.ini (the list) automatically. From Sonar's Help: To globally enable/disable upsampling for a plug-in, click the FX icon in the upper left corner of a plug-in window, and select Upsample on Render or Upsample on Playback on the drop-down menu. These options globally persists for all instances of the plug-in in all projects, so it only needs to be set once per plug-in.
  9. Dave, Some of those MIDI activity flashes seem weird! Too bad MidiOx wouldn't work there. There is an explanation of instrument track muting in the Sonar help file. There's a reference to "smart mute". "Smart mute" describes a setting that can be accessed in the Synth Settings menu. Maybe you and I have different settings there. My "Enable Smart Mute" is checked. For quick reference: --------- from Help: ----------- Smart Mute for Split Instrument Tracks When a virtual instrument MIDI track is soloed or muted, SONAR automatically manages muting or soloing the related set of audio/MIDI tracks in order to properly playback the soloed/muted tracks. In order to facilitate audio recording on Split Instrument Tracks, Smart Mute is no longer the default behavior for Split Instrument Tracks. By default, you can now individually mute individual split MIDI/audio tracks for soft synths. If you want to enable Smart Mute for Split Instrument Tracks, open the Synth Rack view, click the Synth Settings menu and select Enable Smart Mute on the drop-down menu. Bill B.
  10. Sorry, User 905133, I did not answer your question at first. I edited my answer a few minutes later. I used the right-click menu on the track for step 6. I have not tried a different step 6. However, I have replaced the synth in step 11 two different ways. I get what you're saying about trying different lines while muting the already-recorded part. I would never have thought of doing it that way because of my preconceived idea of what mute should do. And I probably would have wanted to record my trials with further abilities to alternately listen to takes etc. Before the advent of take lanes/tracks, I would have set up a clone track with no data on it for each new take. I don't really remember back that far any more 😀.
  11. True If you have a synth or FX that needs upsample but doesn't do it, Cakewalk offers a pre-upsample, post downsample (Upsample on Render and/or Upsample on Playback in the upper left icon in the plugin window). So from the synth perspective, having your projects at 44.1 is OK.
  12. Thank you for your interest, User 905133. I used the track right-click menu "insert instrument". Later, I used "Replace Synth" from both the synth rack menu and the track right-click menu. And I found that the choice of soft synth did make a difference. I tried 4 different ones. TTS-1 did not show the change of behavior caused by step 24. Three other VSTi synths did, including Korg M1, Rapture Session, and Lounge Lizard. I know M1 is not with Cakewalk. I don't know about the other two, they came with Sonar, probably.
  13. I went step by step as described below. The pattern has a very strict sequence. Also, my scenario did not work the same way using the TTS-1 as compared with the M1 and Rapture Session VSTi's. I started this with Sonar Platinum. No data was ever recorded or entered onto any track. Start with new blank project. Create a MIDI track (track 1). Set Input from keyboard and output to a synth module or external whatever (both channel 1) Enable input echo and make sure your keyboard triggers the synth (just make sure your MIDI is going through Sonar, not direct). Hit Mute and verify the oddity that notes from the keyboard still play on the external synth, but the meter doesn't move. Create an instrument track (I used the M1 VSTi & Rapture session will also reproduce this, but not TTS-1) Choose input from your keyboard, channel 1. Don't play anything now. Create an audio track, with input from some legitimate audio channel. (Won't actually send any audio though) Save this test project & exit Sonar Start Sonar and load the project (I started from this point when I repeated my scenarios) (optionally, you can "replace synth" in the instrument track menu to try this on different VSTi's) Split the instrument track Repeat the MIDI track test on track 1, i.e.: Enable track 1 input echo and make sure your keyboard triggers the external synth Hit Mute and verify the oddity that keyboard notes still play You can disable track 1 input echo now Test the split instrument track pair (tracks 2 & 3): Enable input echo on the MIDI track (2) Demonstrate echo from keyboard to VSTi works Observe meter operates on both MIDI & synth tracks (2 & 3) Mute the MIDI of the pair. Observe the synth track mutes too. Play notes and observe no echo & no meter movement. Unmute the synth track -- still no echo & no meter movement. Enable input echo on the audio track (track 4). Now play notes on the instrument track pair just as you did before. Now synth meter moves (track 3) but not MIDI meter (track 2), and sound plays! I had a little trouble reproducing this at first. Yesterday I did this with the M1 VSTi, but I wanted to use something included with Bandlab Cakewalk, so I tried it with TTS-1 and it did not reproduce step 26 23. But it did reproduce with Rapture Session & Lounge Lizard. (probably steps 13-15 aren't needed). It happens with Sonar and Cakewalk. At steps 22 and 23, this is how I would expect mute and input echo to interact properly. Steps 5 and 26, not. Starting from step 10, it is possible to rerun the experiment with different VSTi's. I suspect step 24 sets something that cannot be unset, so starting over from step 10 is necessary to reproduce.
  14. Dave, The weird thing that happened with the split instrument track was done without any prerecorded notes. I made a test project with a pure MIDI track, a split instrument track, and a pure audio track, with no data on any of them. My aim was only to test the behavior of mute in connection with echo input for those three cases. After playing with the pure MIDI track, and seeing what I reported in the OP, I played with the split instrument track next. It seemed to behave the way I would expect. I echo-enabled the MIDI track and muted it, and unmuted the synth track, then played notes matching the MIDI track. There was no sound. Then I played with the audio track muting and echo-enabling it & maybe un-echoed (exact step here, I don't remember). It behaved as I would expect: no input echo sounded when muted. Then when I went back to the split instrument track & played notes, the synth track sounded the notes. I had not touched widgets on the split instrument track, it just started behaving differently. I realize this is not a very precise set of steps to reproduce, & I may not get a chance to nail it down until tomorrow evening.
×
×
  • Create New...