Jump to content
no1shero

Need help with MIDI

Recommended Posts

Hi everyone,

I just decided to download this DAW and give it a try the other day, so yes, very new to it. All good so far, but there's one annoying issue I'm having and I can't seem to find the appropriate answer to it after quite a bit of googling & reading.

I made a 4 bar midi clip for an arp, I have drawn in the first four notes of the clip and am trying to copy those 4 notes through the rest of the 4 bar clip. The problem I'm having is when I try to select those 4 notes it seems to select the whole clip, and instead of copying the notes it copies the clip over & over.

What am I doing wrong here?

  • Like 1

Share this post


Link to post
Share on other sites

Are you using the PRV to select these notes ?

Because its impossible to select individual notes trying to edit the clip itself. you can drag select to highlight only the portion of the clip you need. Then use CNTLR+V.

Share this post


Link to post
Share on other sites
1 minute ago, chuckebaby said:

Are you using the PRV to select these notes ?

Because its impossible to select individual notes trying to edit the clip itself. you can drag select to highlight only the portion of the clip you need. Then use CNTLR+V.

Yes, I am using PRV.

I right-click drag over the 4 notes, CTRL-C, then CTRL-V...but it copies the whole clip instead of just the selected notes inside the clip. I can manually draw out the rest of the notes in the clip, but it'd be much easier to fill the clip using copy/paste.

Share this post


Link to post
Share on other sites

Here's a picture example of what keeps happening vs what I want. I made the one I want by drawing all the notes manually, but there must be a way to copy them without the clip copying. 

Screenshot (2)_LI.jpg

  • Thanks 1

Share this post


Link to post
Share on other sites
3 minutes ago, scook said:

When done filling out the 4 bars, select the clips in track view then use the Track View Clips menu bounce to clip(s) function to create one 4 bar clip.

 

Ah this should work, thanks!

Share this post


Link to post
Share on other sites
14 minutes ago, no1shero said:

Yes, I am using PRV.

I right-click drag over the 4 notes, CTRL-C, then CTRL-V...but it copies the whole clip instead of just the selected notes inside the clip. I can manually draw out the rest of the notes in the clip, but it'd be much easier to fill the clip using copy/paste.

If it's just four notes, you can select them individually:
copy_paste_notes_prv.gif

  • Like 2

Share this post


Link to post
Share on other sites

Yes, I would keep in the habit of using "Bounce to clips" frequent and often. It helps tidy up clip fragments and prevents things such as "double notes", selection issues (like your having now).

I use Bounce to clips every few minutes when doing heavy editing, only because I don't want to forget it and also I like working in full clips (as long as slip edit data is not needed). This is also helpful when the midi clip is completely finished, I then drag that whole midi clip from a completed track to my browser (in a folder) for back up purposes. Because if a project becomes corrupt (which doesn't happen often) your screwed. Midi is embedded within the CWP file itself and non retrievable. Unlike audio clips which can be retrieved from the project folder. 

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, no1shero said:

Yes, I am using PRV.

I right-click drag over the 4 notes, CTRL-C, then CTRL-V...but it copies the whole clip instead of just the selected notes inside the clip. I can manually draw out the rest of the notes in the clip, but it'd be much easier to fill the clip using copy/paste.

Sometimes, when cutting and pasting acts up, I switch to the Selection Tool.   Then, it's left mouse click and drag.

Share this post


Link to post
Share on other sites
1 minute ago, RobertWS said:

Sometimes, when cutting and pasting acts up, I switch to the Selection Tool.   Then, it's left mouse click and drag.

I also tried that, but was still having the same issue sadly.

Share this post


Link to post
Share on other sites

Drag-move/copy in the PRV should always automatically extend the clip boundary to encompass the moved/copied material in the existing clip.  Pasting will create a new clip if the start of the paste is more than about half a measure past the end of the existing clip. To avoid that, you can drag the end boundary of the clip further out in the track view before editing in the PRV. But be aware that if you move the clip in the track view, the boundaries will revert to note/controller start/end points.

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, David Baay said:

Drag-move/copy in the PRV should always automatically extend the clip boundary to encompass the moved/copied material in the existing clip.  Pasting will create a new clip if the start of the paste is more than about half a measure past the end of the existing clip. To avoid that, you can drag the end boundary of the clip further out in the track view before editing in the PRV. But be aware that if you move the clip in the track view, the boundaries will revert to note/controller start/end points.

I do not believe my selection is more than half a measure past the end of the existing clip. I have created a clip 4 bars long, and the measure of my notes is approximately 1/2 of a bar. I select my notes from last to first trying to copy them across the full length of the current clip, and considering my first/only 4 notes only take up the first half bar of a 4 bar clip, I think I can safely assume that I'm not selecting anything over the length of the current clip.

Share this post


Link to post
Share on other sites

- Enable 'Use Paste Special Options on Paste' under Preferences > Editing.

- Ctrl+Alt+V to make the first paste with Paste Special options.

- Select the radio button to Paste into Existing Clips, and OK.

- Regular Ctrl+V will now paste into existing clips, and will persist until you use Paste Special again to change it. 

Alternatively (preferred)

- Select the one-beat clip in the track view.

- Ctrl+L to enable Groove Clip Looping.

- Drag the end of the clip out to 5:01 with snap enabled at a quarter or measure.

  • Thanks 1

Share this post


Link to post
Share on other sites
9 hours ago, David Baay said:

- Enable 'Use Paste Special Options on Paste' under Preferences > Editing.

- Ctrl+Alt+V to make the first paste with Paste Special options.

- Select the radio button to Paste into Existing Clips, and OK.

- Regular Ctrl+V will now paste into existing clips, and will persist until you use Paste Special again to change it. 

Alternatively (preferred)

- Select the one-beat clip in the track view.

- Ctrl+L to enable Groove Clip Looping.

- Drag the end of the clip out to 5:01 with snap enabled at a quarter or measure.

Perfect, exactly what I was looking for. Thank you!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...