Jump to content
Sign in to follow this  
lychee

"Input echo" in conflict with some plugins ???

Recommended Posts

Hello!

For years I thought that my audio interface Motu 828 mk3 no longer worked, while it was my microphone that was dead.
Today I try to put my home studio back on, integrating my two old external synths through Cakewalk and my Motu.


So I clicked input echo to be able to apply the Cakewalk plugins in real time on my external synths, I lowered the latency in the asio drivers, and I muted the inputs on the interface so as not to have some kind of chorus effect.
Everything worked well until I added some plugins like Izotope Vocal Doubler, or the Cakewalk L-Phase EQ (LP-EQ).
I don't know why, but its two plugins (and probably others) generate a monstrous latency on the input echo tracks, even if they are not on the tracks in question.

Is there a solution to the problem or is it a Cakewalk bug?

Another problem, it seems that in the project settings I can not put the clock on internal, obviously the option comes back every time on the audio clock.

 

Share this post


Link to post
Share on other sites

Some plug-ins need large look ahead buffers to work. Often plug-ins that introduce latency have some mention of it in their documentation. These plug-ins are designed for mixing and mastering where latency is not an issue. They are not designed for tracking.

Linear phase EQs need a large look ahead buffer. The Cakewalk L-Phase EQ  is no exception. The plug-in has an option to reduce its buffer by setting the Precision to Non-Linear in the Expert menu (page 19 of the LP EQ help). The good news is linear phase EQ settings may not be the best choice for tracks anyway.

The internal clock setting may be used any time the project is MIDI only. If there is ANY audio coming from the DAW (including the audio metronome), the clock is set to audio.

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Thank you for your clear and precise answer Scook.
Effectively putting the Non-Linear option solves the problem for LP-EQ.


But what should I do if I don't have that kind of option in a plugin like for Vocal Doubler for example?
And why is the problem there, even on tracks not affected by the plugin?

 

Edited by lychee

Share this post


Link to post
Share on other sites

I do not have Vocal Doubler. Bypassing effects is a quick way to determine if plug-ins contribute to plug-in delay compensation.

Some plug-ins are not suitable while tracks. For those plug-ins either replace them with a low latency plug-in that performs a similar function, bypass the plug-in entirely, temporarily freeze the track or bounce the entire project to a temporary scratch track and archive all the tracks while continuing tracking. Maybe the PDC override can help too.

All plug-ins a project can contribute to plug-in delay compensation because the delay is applied to all tracks so they stay in sync.

 

 

 

Share this post


Link to post
Share on other sites

Steve's got you covered.  To summarize:

- Know which of your plugins uses an internal lookahead buffer that adds latency, and avoid using them in the tracking stage of a project.

- Such 'mastering' plugins (including most of Izotope's stuff) are generally intended to be used in mixing/mastering stage of a project when latency doesn't matter

- When using hardware synths, this means recording the audio as soon as you're finished recording and editing the MIDI.

- If you must record with a delay-inducing plugin in a project, you can use the PDC (bypass) button in the Mix Module to disable Plugin Delay Compensation on input-monitored tracks.

- PDC Bypass can only work on tracks that don't have the delay-incuding pluging somewhere in their path to the output.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...