Jump to content
  • 0
Matthew Solomon

Crackling Noise in Audio Playback and while playing Virtual Instruments after Update

Question

Hi, I started getting crackling static noise during playback after the latest Cakewalk update. Even when only one track is loaded there is still static. Tried uninstalling and reinstalling but it doesn't work. I know it's in cakewalk because playback in sforzando and Kontakt Player is normal. 

 

EDIT:

Solved it

I was stupid and just had to choose MME 32 bit (I am new to this sorry)

Edit again: Choosing MME 32 bit solved the issue

Edited by Matthew Solomon
Solved it and forgot to choose another option for audio driver

Share this post


Link to post
Share on other sites

20 answers to this question

Recommended Posts

  • 0

If you are running Windows 10 I would suggest trying WASAPI instead of MME. It will produce much lower latency.

I suppose if you are just playing back tracks, you should be fine using MME (except for the occasional 1 sec delay after pressing play).

But you might find much better results using anything but MME.

Share this post


Link to post
Share on other sites
  • 0
13 minutes ago, chuckebaby said:

If you are running Windows 10 I would suggest trying WASAPI instead of MME. It will produce much lower latency.

I suppose if you are just playing back tracks, you should be fine using MME (except for the occasional 1 sec delay after pressing play).

But you might find much better results using anything but MME.

Oddly, when I chose WASAPI that's when the crackling sounds were consistently there.

It was gone when I selected MME

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, Matthew Solomon said:

Oddly, when I chose WASAPI that's when the crackling sounds were consistently there.

It was gone when I selected MME

Then I assume you are running Windows 10 ?

Anything is better than MME my friend. This is how you set it up...

https://www.cakewalk.com/Documentation?product=SONAR&language=3&help=AudioPerformance.29.html

 

To enable WASAPI mode in SONAR

1. Go to Edit > Preferences > Audio - Playback and Recording.

2. In the Driver Mode list, select WASAPI Exclusive or WASAPI Shared.

3. Select the Audio - Devices page tab (Edit > Preferences > Audio - Devices).

4. In the Input Drivers and Output Drivers lists, select the desired input and output ports.

5. Click OK to close the Preferences dialog box.

Share this post


Link to post
Share on other sites
  • 0

I am experiencing the same thing: I installed the update (to version: 2019.11) and got static when playing back tracks with virtual instruments. Selecting MME (32 bit) as the Driver Mode under Audio -> Playback and Recording cleared it, but that caused other occasional playback hiccups. Windows 10 is my OS. The problem runs across more than one project and more than one my personal VSTs. Note: the problem does not happen with Cakewalk TTS-1 but does happen with other bundled instruments like the string section.

I think rolling back to the prior version of Cakewalk might be a good solution, assuming you can. I never used Cakewalk when it was Sonar, so I don't (at least I don't think) I have a Cakewalk account and thus can't get into the CCC. So, in my case I don't think I can. Note: the web page to migrate the forum account to a Cakewalk account comes up as 'not completely secure' in Chrome. That isn't necessarily mean the information isn't secure, but I tend to be paranoid.

On the other hand, maybe it's a problem that will effect enough people that Bandlabs will have to do something up it in the next update. Or, maybe let people know exactly what the fix is.

Hope something I said helps.

Share this post


Link to post
Share on other sites
  • 0

I had the same issue on one machine (one where I didn't have a pro-sound card attached).  Had to adjust the latency in a fairly narrow window to get it to work properly.  

Honestly shouldn't be the case.  

Share this post


Link to post
Share on other sites
  • 0
12 hours ago, Matthew Solomon said:

Hi, I started getting crackling static noise during playback after the latest Cakewalk update. Even when only one track is loaded there is still static. Tried uninstalling and reinstalling but it doesn't work. I know it's in cakewalk because playback in sforzando and Kontakt Player is normal. 

 

EDIT:

Solved it

I was stupid and just had to choose MME 32 bit (I am new to this sorry)

Edit again: Choosing MME 32 bit solved the issue

ASIO not available?  If so, choose that.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Promidi said:

ASIO not available?  If so, choose that.

Selecting ASIO instead of WASAPI seems to have done the trick for me. I didn't know what ASIO was but after some very brief research it seems all you need is WDM and my sysinfo tells me I have it so I installed ASIO4All and the static is gone so far.

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, Promidi said:

What audio interface do you have? Have you updated the drivers?

Drivers are updated

But I don't have an audio interface (yet?). Not sure if I need one since I'm only starting out

I just listen through the audio jack 

But then it was working fine even through the audio jack before

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, Steve_001 said:

Selecting ASIO instead of WASAPI seems to have done the trick for me. I didn't know what ASIO was but after some very brief research it seems all you need is WDM and my sysinfo tells me I have it so I installed ASIO4All and the static is gone so far.

I installed ASIO4all then selected ASIO

It works now

Thanks!

Share this post


Link to post
Share on other sites
  • 0
14 hours ago, chuckebaby said:

Then I assume you are running Windows 10 ?

Anything is better than MME my friend. This is how you set it up...

https://www.cakewalk.com/Documentation?product=SONAR&language=3&help=AudioPerformance.29.html

 

To enable WASAPI mode in SONAR

1. Go to Edit > Preferences > Audio - Playback and Recording.

2. In the Driver Mode list, select WASAPI Exclusive or WASAPI Shared.

3. Select the Audio - Devices page tab (Edit > Preferences > Audio - Devices).

4. In the Input Drivers and Output Drivers lists, select the desired input and output ports.

5. Click OK to close the Preferences dialog box.

Installed ASIO4all and selected ASIO and the noise is gone now

Where can I read more about the differences between them? (that a beginner can understand)

Thanks!

Share this post


Link to post
Share on other sites
  • 0

I am having a similar problem, in Windows 10, with no audio interface besides the vanilla "Realtek high definition audio".

Just so we're on the same page, here's what I mean by "same" problem:

  • playback of VST softsynths is both buzzy/crackly and too slow (notes do not sound in tempo)
  • TTS-1 works fine, other softsynths do not
  • this happened after I updated this morning, was fine yesterday before update
  • switching from WASAPI Shared to WASAPI Exclusive makes no difference (problem is still there); ASIO makes no sound at all on any track; MME-32 does remove the problem but (predictably) causes other horrible latency issues across all tracks.

I can add the following observations, which is why I'm adding to this thread:

  • if I run the same softsynths in standalone mode (for example, Kontakt can run standalone, i.e. not in a DAW) the problem is NOT there. It sounds fine.
  • if I freeze the softsynth track and play the resulting audio, the problem is NOT there.... meaning, it can mixdown perfectly fine

So, only realtime playback is compromised, and only when run through Cakewalk.

I hope the folks at Bandlab can issue a hot patch (quick follow-up update) to address this.  In the meantime, I guess I finish the composing work in glitchy-sounding  MME-32 and then switch back to WASAPI for mixdown.

Share this post


Link to post
Share on other sites
  • 0
On 11/28/2019 at 3:32 PM, johnchowseymour said:

I am having a similar problem, in Windows 10, with no audio interface besides the vanilla "Realtek high definition audio".

Just so we're on the same page, here's what I mean by "same" problem:

  • playback of VST softsynths is both buzzy/crackly and too slow (notes do not sound in tempo)
  • TTS-1 works fine, other softsynths do not
  • this happened after I updated this morning, was fine yesterday before update
  • switching from WASAPI Shared to WASAPI Exclusive makes no difference (problem is still there); ASIO makes no sound at all on any track; MME-32 does remove the problem but (predictably) causes other horrible latency issues across all tracks.

I can add the following observations, which is why I'm adding to this thread:

  • if I run the same softsynths in standalone mode (for example, Kontakt can run standalone, i.e. not in a DAW) the problem is NOT there. It sounds fine.
  • if I freeze the softsynth track and play the resulting audio, the problem is NOT there.... meaning, it can mixdown perfectly fine

So, only realtime playback is compromised, and only when run through Cakewalk.

I hope the folks at Bandlab can issue a hot patch (quick follow-up update) to address this.  In the meantime, I guess I finish the composing work in glitchy-sounding  MME-32 and then switch back to WASAPI for mixdown.

I have the same problem as you... (in my case is with "Ozone 9" and all of Plugins) whats happens .. I have a good PC

 

  • if I run the same softsynths in standalone mode (for example, Kontakt can run standalone, i.e. not in a DAW) the problem is NOT there. It sounds fine.
  • if I freeze the softsynth track and play the resulting audio, the problem is NOT there.... meaning, it can mixdown perfectly fine

So, only realtime playback is compromised, and only when run through Cakewalk.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Jose Guadalupe Garcia Garcia said:

I have the same problem as you... (in my case is with "Ozone 9" and all of Plugins) whats happens .. I have a good PC

 

  • if I run the same softsynths in standalone mode (for example, Kontakt can run standalone, i.e. not in a DAW) the problem is NOT there. It sounds fine.
  • if I freeze the softsynth track and play the resulting audio, the problem is NOT there.... meaning, it can mixdown perfectly fine

So, only realtime playback is compromised, and only when run through Cakewalk.

You might want to start a new thread.  When you do, can you give us more information - like audio interface, buffer size driver mode, what you have tried so far?

Share this post


Link to post
Share on other sites
  • 0

I beg your pardon Cakewalk by Band Lab... CbB was o.k 

(a) First: 

One the problem was the bad-Performance and Settings of Windows 10 for Audio-Production. Let's be honest,  everybody wants to Record, Mixing & Master music using a DAW and at the same time enjoy Social Networks & Mutimedia (Facebook, Youtube, Instagram, Web Cam.. etc...) You can choose both, but you have to turn off some of caracteristics of Windows to be able performance much better the DAW's integration.. and that's what I did...

I want to thank to this video for the help:

(b) Second:

As you know I was having a lot of problems with Audio & Pugins through Cakewalk (Pops, Noise, and Crackling during Recording, Playback & Mixing) despite of have a powerful PC.. and the solution was too: I had to delete these two files (AUD & AUD.INI) C:\Users\"pc-name"\AppData\Roaming\Cakewalk\Cakewalk Core) and That's it... cakewalk regenerate automatically these files once reopen the Program. 

Thanks! now I'M HAPPY.. no NOISE, no Pops, no Cracking.. all Good... (y) I also got back 7GB of RAM memory...

 

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...