Jump to content
  • 0
Alcar28

MIDI : Hearing piano and drums in my drum track

Question

Hi,

I can't fix that problem.

I'm using M-Audio Code 61 keyboard in Cakewalk by Bandlab, on win7 64 bits, Roland Octacapture.

Using virtual instruments, when I go to my drums tracks to play and record, I can hear the piano sound as well.

How can I fix this ?

Thanks

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

In Preferences Midi - Playback and recording uncheck "Always echo current Midi Track" under Playback. Be sure to turn on/off Echo in the tracks too. That does it for me.

HTH

Cheers 😊

Share this post


Link to post
Share on other sites
  • 0

That is a good idea. Having Always Echo Current MIDI Track enabled is part of the problem. When this feature is enabled, any track that has its input set to None will have the input changed to Omni when the track has focus because input must be set to echo something.

Having the track set to Omni will pick up all MIDI data at its input. This will include the controller and any plug-in with "Enable MIDI Output" selected. Any synth that can send/generate MIDI data will have "Enable MIDI Output" selected by default. "Enable MIDI Output" for a plug-in instance is available on the Soft Synth Options dialog when adding the plug-in and the VST2/3 drop down in the standard header (scroll down to be bottom of the page for the description and image) after the plug-in is added to the project. A good practice is only "Enable MIDI Output" when needed. This along with manual control of input echo should take care of unexpected MIDI data hitting instrument and MIDI track inputs.

 

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...