Jump to content
  • 0
Apeirofobia

Audio stretching

Question

Hi guys

Ive been experiencing some trouble everytime I import wav audio files. When I change the tempo of the project it automatically stretches the audio clips. 

I changed their "time base" in properties to "absolute" (it used to work that way) but its still stretching them.

 

Thanks in advance

 

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Within the Clip Properties, under the Groove Clip section, have you got "Stretch to Tempo" checked ?

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, msmcleod said:

Within the Clip Properties, under the Groove Clip section, have you got "Stretch to Tempo" checked ?

It's not checked.

Share this post


Link to post
Share on other sites
  • 0

There must be tempo information in the wav file you're importing.

After importing, select the clip, then right click and select "Bounce to Clip(s)". This will remove the tempo information and stop it from stretching when you change tempo.

Share this post


Link to post
Share on other sites
  • 0

Have you confirmed the audio actually plays at a different tempo? The M:B:T timeline is the fixed reference in Cakewalk, and the Now cursor just travels faster or slower at different tempos. As a result, when you change tempo, the displayed length of audio clips will change, but they aren't actually being 'stretched'.

Edited by David Baay

Share this post


Link to post
Share on other sites
  • 0
21 hours ago, msmcleod said:

There must be tempo information in the wav file you're importing.

After importing, select the clip, then right click and select "Bounce to Clip(s)". This will remove the tempo information and stop it from stretching when you change tempo.

Thanks. I'll try that. 

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, David Baay said:

Have you confirmed the audio actually plays at a different tempo? The M:B:T timeline is the fixed reference in Cakewalk, and the Now cursor just travels faster or slower at different tempos. As a result, when you change tempo, the displayed length of audio clips will change, but they aren't actually being 'stretched'.

Yes, I've played the file and it actually changes its tempo.  I don't know what could be causing this. 

Share this post


Link to post
Share on other sites
  • 0

Then I would go with Mike's suggestion that they were already REX/Groove-enabled before you imported them, and need to be bounced. But they'll automatically take on the project tempo when imported, which could already be different from the native tempo of the clip(s).

Share this post


Link to post
Share on other sites
  • 0
55 minutes ago, David Baay said:

Then I would go with Mike's suggestion that they were already REX/Groove-enabled before you imported them, and need to be bounced. But they'll automatically take on the project tempo when imported, which could already be different from the native tempo of the clip(s).

Thanks

How can I verify if the wav file has tempo information included?

Anyways, its strange because when I import the file it is still on the original tempo (160bpm) but when I see the groove info it displays 116.xx Bpm(Inside Cakewalk).

 

Edited by Apeirofobia

Share this post


Link to post
Share on other sites
  • 0

Thank you! In fact now I realized that they're groove clips cause when I select them, the help module it showed me groove clips information.

Now the strange thing is that Cakewalk says that when I open one of these files, the software is supposed to match the tempo automatically.  But now I see that the info displays this, that the clip is 116.9 BPM and the project is still on 120bpm.  And this files comes from a FL Studio project that was 160BPM.

Finally, I realized that unchecking the "Looping" option on the groove clip info stopped the audio stretching. ¿Does someone know what exactly does that function? ¿How did it stop the audio stretching?

 

Thanks in advance!

 

 

groove.jpg

bpm.jpg

Edited by Apeirofobia

Share this post


Link to post
Share on other sites
  • 0

I don't actually work much with 'looped' audio . So far as I know, just having looping enabled makes a clip follow project tempo. I'm not sure why there's a separate 'Stretch to Tempo' option.  If you imported the clip into an existing project, it should have taken on the project tempo, but as long as it is, there may have been an error when the tempo was set on export from FL Studio.  Loops typically aren't that long.

If you just want to work with this audio in Cakewalk at the original tempo, I suggest you go back to the source, and make sure it exports as an ordinary .WAV file. If it's not a loop, it won't matter whether you set the Cakewalk project to 160bpm before or after importing it

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...