Jump to content
Freyja Grimaude-Valens

ASIO Driver Drops out after a certain period

Recommended Posts

Okay so I have been getting this weird issue where the ASIO driver just silently disconnects from the DAW and wouldn't come back, spitting this error message whenever I tried to play back. Usually restarting the app brings the ASIO driver mode back, but seeing this like 30 mins after opening the project is unacceptable. I have has no other apps open at the time.

7175f97034276fc1099dc481a1016146.png

Share this post


Link to post
Share on other sites

I think I may have figured it out. I had CleanMem installed to clean up unused memory every 30 mins. I installed that thing years ago and never touched it since. I have since uninstalled it and it seems to alleviate the problem. Worked around for 2 hours without issues afterwards. (Then i went to bed)

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, martsave martin s said:

on device manager USB hub,uncheck all usb-hub (allow this computer to close this turn-off..)

If enabling the 'Share drivers with other programs' approach doesn't fix this for you, then you might consider altering the default Windows default behavior on something called USB Selective Suspend, which is what was suggested in the 1st reply above.

A little clarification to the above might help: Windows, by default has an advanced power plan setting 'enabled' that will result in Windows disconnecting USB-connected devices after a period of being idle.  This can cause things like midi controllers or USB-connected audio interfaces to become unavailable to Cakewalk, and for folks doing music production - like using Cakewalk, this setting should be changed to disable this Windows behavior.

There are a couple of ways of changing this behavior in Windows.

The first way is as noted above, which is to go into Windows Device Manager, and then to expand the category 'Universal Serial Bus Controllers'.  Then, double-click on each USB Hub entry, to bring up its Properties.  If you don't see a tab for Power Management, you don't need to do anything with that particular entry, so close Properties and move on to the next entry.  For those entries that DO have a tab in Properties for Power Management, click on that tab, and then, if checked, remove the check for the option labeled: 'Allow the computer to turn off this device to save power', and then click OK - then close Properties for that entry and move on to the next one, etc.,

The other way of accomplishing the change to the default USB Selective Suspend behavior, is to edit the Windows Power Plan setting called 'USB Selective Suspend'.  To do this, launch Control Panel, then click on System and Security > Power Options, and at this screen, it is recommended to also select the High Performance power plan.  OK, then for the High Performance plan, click on Change Plan Settings, and then click on Change Advanced Power Settings.  Now, scroll down to, and expand, the category for 'USB Settings', and expand USB Selective Suspend Setting, and change the setting to 'Disabled', click Apply, then click OK and back your way out.

I hope the above helps explain things a bit, and hopefully, one of the above methods will fix this issue for you.

Bob Bone

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, Freyja Grimaude-Valens said:

I think I may have figured it out. I had CleanMem installed to clean up unused memory every 30 mins. I installed that thing years ago and never touched it since. I have since uninstalled it and it seems to alleviate the problem. Worked around for 2 hours without issues afterwards. (Then i went to bed)

I'D BE VERY CAUTIOUS ABOUT SUCH AN APP (CLEAMMEM) and rather deal with any apps showing a memery leak, and also check what you have running in the background

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...