Jump to content
seadude

Take Lanes & MIDI Record

Recommended Posts

Haven't really used take lanes before, just used lots of tracks. However thought I'd try it out. Recording a MIDI drum track from an external keyboard doing different bits as different takes, e.g. bass drum first, hihat second, etc.  Using take lanes in just the one track, when I record the hihat I can't hear the bass drum during record. I've checked the correct preferences settings and there is no problem hearing the MIDI playback during record when bass drum is on one track and hi-hat is on another.  Am I missing something?

Share this post


Link to post
Share on other sites

To hear previously recorded lanes, make sure recording mode is set to "Sound on Sound" in preferences or by holding down the record button to bring up the options menu,

Share this post


Link to post
Share on other sites

I typically don't use lanes in MIDI but tested before posting and it works for me.

  • Added Superior Drummer to a new project as an instrument track with echo enabled, armed for recording
  • Changed recording mode to Sound on Sound
  • Recorded a kick
  • Rewound the transport and recorded a snare...the kick was playing
  • Rewound the transport and recording a tom...both the kick and snare were playing
  • Opened up the take lanes and saw three takes lanes, one for each instrument.

Share this post


Link to post
Share on other sites

Thanks for checking that out. Suggests there's something not correct with my setup. More investigation.....

Share this post


Link to post
Share on other sites
26 minutes ago, scook said:

I typically don't use lanes in MIDI but tested before posting and it works for me.

  • Added Superior Drummer to a new project as an instrument track with echo enabled, armed for recording.

That would be the "input echo" button, yes?

Share this post


Link to post
Share on other sites

Okay, followed scook's step-by-step - it works.

However.........

Open new project
Select MIDI track 10 with midi in/out enabled, echo on, sound-on-sound selected (my default option)
Record bass drum to track 10.
Expand track 10 to show take lane with bass drum.
Add new take lane. Set to record.
Bass drum isn't heard when recording hi-hat.
On playback both bass drum and hi-hat are heard.

The work-around  is to follow scook's process or just use separate tracks.

Share this post


Link to post
Share on other sites
9 hours ago, seadude said:

Add new take lane. Set to record.

It's arming the individual take lane that causes previous takes not to be heard. Arm the parent track.

Share this post


Link to post
Share on other sites

So what’s the difference between your process and scook’s? Just that you’re creating lanes manually? Either way, it should be working so long as the lane isn’t armed individually.

Share this post


Link to post
Share on other sites

Well.....that got me thinking why is there a record button in the take lane?  David I did what you suggested but then my hi-hat recording after the bass drum just gets assigned to the bass drum take lane as well. If I hit the record button in the take lane the hi-hat is allocated there but that's when bass drum playback can't be heard.  I'm not really looking for a solution, just interested to know why it's doing this. I think it's easier for me to record to separate tracks and not use lanes.

 

Share this post


Link to post
Share on other sites

Do you have 'Create New Lanes on Overlap' enabled?  Even though you're manually creating your own new lane, you need to have this enabled to get CbB to use it.

Share this post


Link to post
Share on other sites

General midi uses midi channel 10 for drums.

You are writing about midi track 10.

Maybe some mix up with that?

Share this post


Link to post
Share on other sites

I use midi channel 10 for drums from my external keyboard. My midi tracks in cakewalk are organised from 1 to 16 and track 10 is for channel 10 drums.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...