Jump to content
panup

Help troubleshooting: audio chunks lost during recording

Recommended Posts

I have a longstanding issue I have not been able to fix: every now and then I record audio there are little parts (app. 20-500 samples) missing. This creates ugly clicks in the audio but also makes the recorded audio go out of sync.  It happens so randomly (0 ... 5 times per recorded 5 minutes of audio, sometimes even hours without any glitch) that I have no idea where to search for the cause.

I know this:

- May happen in any project.
- Bypass all FX does has no effect.
- Record on a new project with no FX does not prevent glitches.
- It happens in the last SONAR version, too; thus it's not CbB era related.
- I tested DPC latency with DPC latency checker tool; latency is very low and there are no problems.
- PC is fast i7, 32 GB RAM, Windows7 Ultimate (automatic updates disabled),  dedicated to audio work. It's on net.
- Audio is recorded to dedicated hard drive. System is on different SSD disk.
- I have tried to delete AUD.ini.
- Audio interface RME UFX (ASIO) has latest driver and firmware. I have replaced the USB cable and tried to connect it to a different USB port.
- Changing ASIO buffer size has no effect (256-1024).
- Always 44.100 Hz, RME clock is locked and in sync.
- I have disabled all other sound devices in Device Manager.
- Windows sound cheme is "No sounds".
- AxeFX II is connected via USB2, driver is disabled. Keeping Axe FX2 power off has no effect on this.

- Glitches are not heard in direct monitoring (in RME Totalmix), they appear only on the recorded clips in CbB/SONAR.

This is most probably *NOT* CbB's fault - otherwise there would be thousands of other users complaining this - but also the RME drivers are tested to death.

Is there a tool available to test and troubleshoot this kind of issue?
Any fresh ideas to hunt for the cause of the issue?

 

 

Share this post


Link to post
Share on other sites

No idea, but I had trouble once with ASIO buffers that required the EXACT one or it wouldn't work. Only way to find it was try each one separately: 100. 105, 140, 147, 150, etc.

I also had issues with 64 bit Double Precision Engine.

  • Like 1

Share this post


Link to post
Share on other sites

Check defender / security essentials. Maybe it does a quicksearch at awkward times.

  • Like 1

Share this post


Link to post
Share on other sites

Do the missing chunks exactly match the buffer size at the time of recording? Losing the audio in your buffer do to dpc latency could cause your symptom. Have you run latency monitor to check your system.

Edited by Gswitz

Share this post


Link to post
Share on other sites

Is disk write caching enabled (default is no caching)? Maybe rename Aud.INI, and try using the default INI file for a while. Or try setting a suitable non-zero Record Pre-allocate value.

Share this post


Link to post
Share on other sites
3 hours ago, Gswitz said:

Do the missing chunks exactly match the buffer size at the time of recording? Losing the audio in your buffer do to dpc latency could cause your symptom. Have you run latency monitor to check your system.

Thanks for your help!

 

Size of missed chunks varies randomly and I have not seen any relation to buffer sizes.
I tested DPC latency; values are very low and system should be more than capable to record audio perfectly.

Share this post


Link to post
Share on other sites
3 hours ago, David Baay said:

Is disk write caching enabled (default is no caching)? Maybe rename Aud.INI, and try using the default INI file for a while. Or try setting a suitable non-zero Record Pre-allocate value.

Disk caching was disabled.
I tried to rename AUD.ini already (did not help). I'll try to enable pre-allocate next.

Thanks for the tips!

Share this post


Link to post
Share on other sites

Friday I made a recording. I was shuffling around in winter in slippers and a couple of times sent static electricity through the gear. Each time, I had to power cycle my rme ucx. It did not happen during recording... Only set up. Possible something similar is happening to you?

Share this post


Link to post
Share on other sites
2 hours ago, Gswitz said:

Friday I made a recording. I was shuffling around in winter in slippers and a couple of times sent static electricity through the gear. Each time, I had to power cycle my rme ucx. It did not happen during recording... Only set up. Possible something similar is happening to you?


I would not look after static electricity in my case because  my UFX unit functions perfectly all the time; real time monitoring is sample perfect, only the recorded audio has those missing chops.  Thus I believe it's software issue rather than hardware failure. 

There is "Errors" count in RME control panel.  It always shows zero which means that RME driver has no clue that audio samples are lost in the way. Also Cakewalk/SONAR  seems to be totally unaware of the problem.  I have to take a closer look at all running processes.

Share this post


Link to post
Share on other sites

Sounds like it might be a driver or click issue.

 

Have you looked at that side?

Share this post


Link to post
Share on other sites
39 minutes ago, Keni said:

Sounds like it might be a driver or click issue.

Have you looked at that side?

Hi Keni!

I have updated RME driver and firmware but the problem has stayed the same. Maybe the next step is to disable as much background processes as possible to keep the system running and see what happens. It will take some time, though, because detecting the missed chunks requires recording + listening and sometimes problem may be absent for hours. 

...

Microsoft Security Essentials is disabled, I have no virus scanners running at all.

Checklist:

- Adobe Creative Cloud is running on background. Disable.
- Google Backup And Sync is running on background, too (synced folder is on the system SSD). Disable.
- Check all new programs that are installed during the past months.
- Check Windows error logs.

Share this post


Link to post
Share on other sites

Ok... Since you have an rme, download digicheck from the rme downloads and make a recording with that and see if you get the problem.

I'm starting to wonder if an unauthorized plugin is the problem. I know you said you bypassed all plugs but still...

Recording with digicheck should help narrow down the issue.

When rme loses buffers, it continuously records. It doesn't leave a space. All tracks lose exactly one buffer at the same instant. This is true in digicheck.

I think cakewalk would drop out.

I'm curious whether you've ever installed demo plugins that you didn't end up buying.

I'm thinking that if the problem occurs in cakewalk and not in digicheck that this will help narrow down possible causes.

One last thing. You can record with digicheck and sonar at the same time. That should ensure that both differ the same system wide events.

Clicking record enable in cakewalk causes buffer drops btw in digicheck. I know this from the videos I make. So that is expected.

Edited by Gswitz

Share this post


Link to post
Share on other sites

Gswitz, your Digicheck tip is awesome! I will try it asap. Recording with Digicheck will also be a good backup in critical recording session.
I believe all plugins are registered properly but I can verify this one, too..

Share this post


Link to post
Share on other sites

I only do big sessions with digicheck. I don't launch Sonar/Cakewalk until I get home. 🙂

Digicheck kicks a$$.

The only thing it doesn't give you is wave form over time. Make sure you know how your meters are set up. There are level bars and holds you can set. Like The meters can be RMS or Peak. If you're used to Cakewalk you might set them to peak. You can set the text to peak and the meters to RMS (I think this is the default). I use RMS +3dB which differs from Sonar RMS which doesn't do the +3, I believe. You may want to set infinite hold on. Double clicking it will reset the counters.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...