Jump to content
  • 0
Matthew Nuttall

How do I fix the message "There are no audio devices for the current driver model on your system?"

Question

So, I recently installed the latest Cakewalk update (I believe it's version 2019.07, I'm not 100% sure on the name, though. 25.07.0.79, maybe). After this update, every time I attempt to open Cakewalk, I receive the message "There are no audio devices for the current driver model on your system. Please go to Edit | Preferences | Audio | Playback and Recording and choose a different driver model." Then afterwards, I press "Okay," Cakewalk opens, and I can open a project, where I receive the message "The following tracks and buses are currently assigned to a silent hardware output. The items listed below will by silent in your project until their outputs are reassigned to an appropriate hardware output." Below it, it says simply "Master." Then none of my projects will play back- I can press play, but it is completely silent. I also am unable to record- I can press arm for record, but then the record button does nothing. 

I did what the first message asked, and went to change my driver model. I went through every driver model I have available, and all of them had the same effect. I can't use any of them. Then I did a bit more research, and learned that the second message I receive after Cakewalk is open can also occur due to track or bus output being assigned to “None,” which I don't believe is my issue, but maybe? I've never had this issue with Cakewalk before this update, and I'm not 100% clear on what to do to fix it. 

Sorry  if my question was phrased poorly or badly explained, I'm fairly new to Cakewalk and music production in general. 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Best to provide information about the audio interface, driver mode and project sample rate being used. The interface or driver mode is not setup properly or has changed since the project's creation.

Make sure the correct audio interface is selected in preferences and set the driver mode.

Here is a setup guide that may help with interface and driver mode setting. Use "SONAR Platinum" as the product. If the guide recommends MME and the PC is running Win10, try the WASAPI driver mode settings.

There are two ways CbB sets the sample rate for a project.

  1. If the project does not contain any audio clips, the sample rate is read from the Default Settings for New Projects - Sample Rate in preferences
  2. If the project contains audio clips, the sample rate is read from one of the audio clip headers.

 

Share this post


Link to post
Share on other sites
  • 0

I had the exact same message just today. The problem was caused by a power blink. All I did to fix it was unplug my interface from the computer and plug it back in. After that I opened cakewalk up and a window popped up that said a new device (focusright scarlett 18i20) was recognized, do you want cakewalk to add it? Just hit yes. This added my interface to the list of outputs I was able to choose from. This can be caused by other things than just a power blink. Its basically cakewalk not recognizing all available outputs.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...