Jump to content
Ricebug

MIDI Tracks "Maxxed" Out

Recommended Posts

sonar.png.ccc504d749a32d0290ae3ea34471b19b.png

All of a sudden, my MIDI tracks lool like audio files set at maximum volume and then clipped. The piano roll reflects the blue track above. They play fine; I just don't like the looks of them. Hard to see what's going on. Any ideas?

Share this post


Link to post
Share on other sites

It's hard to see exactly what's going on with the screenshot cropped so tightly, but  my first guess would be the track scale is maxed out. Double-click the scale between the tracks pane and the clips pane to zoom out fully.

Share this post


Link to post
Share on other sites

Here's a larger screenie. Tried what you suggested. No change. Even rebooted the machine.

Sonar2.jpg.32a90f2ac308b3db2a6b0c0f71dca3d8.jpg

Those lines look like velocity peaks. Playing around with the values did not change anything. Oh, yeah... Parts of the same tracks look normal, while other parts are jacked up, as shown above.

Share this post


Link to post
Share on other sites

Could those be volume controller information?  It looks like you are in clip mode in the track view. If I recall - the track view can show volume controller info.

Share this post


Link to post
Share on other sites
Posted (edited)

Here is the CWP, a WIP. You may not have the same VST's but you can at least poke around and see what I'm missing.

X-Eyed Mary.cwp

EDIT: Just looked at the bass track in my MIDI program. Those lines are all CC#75. Don't know how they got there.

Edited by Ricebug

Share this post


Link to post
Share on other sites
Posted (edited)

Did you look at the event listing for all (or any of the tracks)?  If not, maybe that will show some useful diagnostic info.  I don't think I have any of your VSTs, so what I see might not be accurate, but I see a lot of notes at the same velocity (100) and a lot of CC data (mostly 126/127).

Steve

PS: Not sure if this is the case with your gear, but I have had CC data "jitter" from knobs and sliders. To my eye, it looks similar to what you have--CCs bouncing back and forth between 126 and 127.

Edited by MusicMan11712 (aka Dr. Steve)

Share this post


Link to post
Share on other sites

See edit above. I'm just going to write this off as a glitch. No sense in worrying myself silly. 

Share this post


Link to post
Share on other sites
11 minutes ago, Ricebug said:

See edit above. I'm just going to write this off as a glitch. No sense in worrying myself silly. 

True enough!  If it is bogus CC data from hardware or software "jitter," you should be able to just delete all of them using the Event List--just so long as you don't delete intentional CC data.

Share this post


Link to post
Share on other sites

I used to get random pitch bend data generated from a midi controller, and until I replaced the controller, I turned the pitch bend wheel off on the controller, and my random data issue was instantly resolved.

Maybe you can figure out which knob/button/ghost is causing your errant data and either filter it out or find a way to disable whatever is causing it.

Bob Bone

Share this post


Link to post
Share on other sites

I'm almost too embarrassed to admit this, but I think I found the cause. I left my Jethro Tull songbook on my MIDI controller keyboard while messing around with something else.  Saved the project to answer a call. Came back a few hours later, loaded it up, and started scratching my head. DOH!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×