Jump to content
  • 0
Sign in to follow this  
rlared

MIDI Clip Length Behavior

Question

Last night I spent an undue amount of time extending the MIDI clip lengths because they either didn't start exactly on the measure, or they didn't finish exactly on the measure.  The problem is that if I don't make these adjustments, then copying/pasting or groove clip looping doesn't work like I want it to.

For example, when I drag in a 2-bar drum loop from Addictive Drums, Cakwalk will consider it to be slightly less than 2 bars, possibly because it doesn't have a MIDI note right at the very end.  But this also happens with MIDI playing.  Or even while making edits, it seems like Cakewalk is overly eager to make my MIDI clip lengths less than I want them! :)

Other DAWs don't seem to have this behavior. . . they round off to the nearest bar with the MIDI clip.

Does anyone else deal with this issue?  Is this something to do with my settings?  Or is this is a Cakewalk-unique workflow that I need to understand better?

  • Sad 1

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

In Preferences/Editing/MIDI, do you have Non-Destructive MIDI Editing checked? I ran into this one myself, and if I remember correctly, that solved it.

The option is not-well documented. I may be wrong about it. Try it and let me know if it helps.

I do know that I have the option checked and that I haven't had occasion to be exasperated about it lately, so there is hope. 😁

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×