Jump to content
PJH

Control Toolbar DPI Issue

Recommended Posts

Hi,

I hope that somebody can assist me.

I recently upgraded to 2x 4k Displays and am running at Native 4k Resolution, with increased DPI settings (150%)

I have found that the mouse cursor is offset when trying to select the Control Toolbar.

I have to run the higher DPI settings due to a Vision issue so reverting to 100% DPI is not an option.

Has anybody been able to find a workaround for this?

Thank you

Share this post


Link to post
Share on other sites
Posted (edited)

I don't know about this, but let me try to restate the issue...

You have a high def display that looks beautiful but now things are too small to distinguish.

So you use a video driver feature to enlarge the size of cakewalk to 150% of normal. Now you can see it. But the mouse doesn't read properly so you hover over one button but when you click you activate another.

Just for clarity, If you set size to 100% it works fine? And if you reduce the screen resolution in Windows does it get bigger and easier to see?

Edited by Gswitz

Share this post


Link to post
Share on other sites
36 minutes ago, Gswitz said:

I don't know about this, but let me try to restate the issue...

You have a high def display that looks beautiful but now things are too small to distinguish.

So you use a video driver feature to enlarge the size of cakewalk to 150% of normal. Now you can see it. But the mouse doesn't read properly so you hover over one button but when you click you activate another.

Just for clarity, If you set size to 100% it works fine? And if you reduce the screen resolution in Windows does it get bigger and easier to see?

Yes, that's exactly right.

Reducing the Resolution to 1080 and setting the DPI to 100% does fix the problem.

However I would like to be able to retain the sharpness of 4k. The Higher DPI paired with 4k res works great for me in my other applications as well.

Cakewalk is the only software I am stuck on currently.

Share this post


Link to post
Share on other sites

I just tried 150% scaling on my 4k monitor (I normally always use 100%) and didn't notice any problems with the CbB control toolbar (latest release).  Do you perhaps have some of the High DPI settings enabled under Compatibility?

B8eXdq.jpgMeYBfG.jpg

 

It could also be something to do with your video card driver and even your mouse I suppose.  Cakewalk reports to Windows that it's unware of high DPI settings.  I think that means you get whatever your video card/Windows can come up with for scaling.  Might be something Cakewalk could fix, but I wouldn't hold my breath, fixing apps to support high DPI settings may require a fair bit of re-working.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...