Jump to content

Recommended Posts

I'm trying to record along to a click track, but what I hear in the headphones is slightly delayed from the input, which creates an echo and makes it confusing as hell. I've got the latency set to zero, I've tried both ASIO and WASAPI Exclusive as suggested by Cakewalk tech support, and nothing helps so far. I'm using a Komplete Audio 6 interface. 

Anyone have any suggestions?

Thanks,

Spyder

Share this post


Link to post
Share on other sites

You can't set latency to 0 so I don't know what setting you are talking about. The latency is dependent on your audio buffer size set in your audio interface.  You can access the settings usually in the same place that you set what driver you are using.  

Share this post


Link to post
Share on other sites

Make sure you don't have any plugins in your project that use look-ahead buffers that induce Plugin Delay Compensation.  If such a plugin is on a  track or bus that's not in the chain of the track you're recording, you can use PDC [bypass] button in the Mix module to  bypass the delay on an input-monitored track that you're recording, but if it's on that track you'll just have to remove it.

Common offenders that you may or may not have, depending on how you got CbB are Cakewalk's Linear Phase EQ and Multiband Compressor and Transient Shaper. Convolution reverbs and many guitar FX processors will also induce PDC.  in general plugins that need PDC should not be used until tracking is complete and you've moved on to mixing and mastering.

Share this post


Link to post
Share on other sites

Thanks Reginald -- well, maybe I didn't say it right. I moved the slider all the way to the left (fast). It was almost there, so I just took it the rest of the way. I had to switch to WASAPI Exclusive to do that. But I'm back in ASIO and either way there's no difference so I'm still experiencing the problem.

David, I've recorded 15 CD's over the years with Cakewalk, then Sonar and yet I have very little tech knowledge or background, so I don't understand what you're telling me to do. I've never had this problem before. I recorded the previous 15 with a Tascam interface, but I'm using the Komplete Audio 6 now. I don't know if that's where the problem is or what...

 

Share this post


Link to post
Share on other sites
15 minutes ago, David Baay said:

Make sure you don't have any plugins in your project that use look-ahead buffers that induce Plugin Delay Compensation.  If such a plugin is on a  track or bus that's not in the chain of the track you're recording, you can use PDC [bypass] button in the Mix module to  bypass the delay on an input-monitored track that you're recording, but if it's on that track you'll just have to remove it.

Common offenders that you may or may not have, depending on how you got CbB are Cakewalk's Linear Phase EQ and Multiband Compressor and Transient Shaper. Convolution reverbs and many guitar FX processors will also induce PDC.  in general plugins that need PDC should not be used until tracking is complete and you've moved on to mixing and mastering.

Hey David, is there a quick way to tell if any given plugin needs PDC? Like, with guitar pedal vsts e.g. you can "play through" them same as w/ an amp sim and only experience the Normal "playable" latency you would in such cases. But if you try playing in real time through some other plugs you'll get a very noticeable delay. I believe I had that problem when trying to play my guitar through Sound Toys' Alter Boy when trying to use it as an octave pedal w/ my amp sim and there was way too much latency of which nothing could be done about, likely because of PDC. 

So RevSpider, I believe David is asking if you have such a plugin in your recording chain that you may be recording through in real time like you would w/ an amp sim, where during recording your signal is having to pass through this plugin before getting recorded, and as you listen while recording you hear and experience this latency as a delay/echo. 

Share this post


Link to post
Share on other sites

At this point all I'm using is a mic through my Komplete Audio 6 and a midi drum track for me to sing over. So as far as I know I don't have any plug ins going. Does that make sense?

Share this post


Link to post
Share on other sites

Make sure the direct Monitor button is off and/or the Monitor volume set to 0?

Share this post


Link to post
Share on other sites
Posted (edited)

Re-reading the original post, if you have an echo, then you must be hearing both direct and input-monitored sound. Is the direct sound just what bleeds through your headphones directly from the guitar, or are you somehow getting mix of direct-monitored signal from the interface, and input-monitored signal coming out of the DAW?

Edited by David Baay

Share this post


Link to post
Share on other sites

Do not monitor the microphone through the DAW, use the direct monitoring available on the interface. IOW, turn input echo off the recording track. The Komplete Audio 6 has a knob to the right of center that controls the mix of the interface inputs and DAW output.

Share this post


Link to post
Share on other sites
Posted (edited)

Latency has but two sources:

  • Audio Interface
  • Latent Plugins

If sounds like you're trying to monitor via software (vs. the audio interface's onboard hardware based mixing which is close to zero latency).

If that's the case, you're dealing with round-trip latency.

Round-trip latency is the sum of the following:

  • ASIO input buffer
  • ASIO output buffer
  • The driver's (often hidden) "Safety" (sometimes called "Streaming") buffer
  • Latency of the A/D and D/A converters

To reduce Round-Trip Latency:

  • Set your ASIO buffer size as small as possible
  • If the audio interface allows you to change the Safety Buffer size, set it as small as possible
  • You can also reduce round-trip latency by using higher sample-rates

Note that reducing Round-Trip Latency comes are the expense of higher CPU use.

 

Regarding Latent Plugins:

All popular DAW applications feature Automatic Plugin Delay Compensation.

If you have a latent plugin inserted ANYWHERE in the project, Automatic Plugin Delay Compensation (Automatic PDC) delays all other audio to maintain sample-accurate sync.  

To work around this issue:

  • Avoid latent plugins while tracking
  • Some DAW applications feature a global PDC bypass feature (enable this when tracking)
Edited by Jim Roseberry

Share this post


Link to post
Share on other sites
Posted (edited)
11 minutes ago, scook said:

Do not monitor the microphone through the DAW, use the direct monitoring available on the interface. IOW, turn input echo off the recording track. The Komplete Audio 6 has a knob to the right of center that controls the mix of the interface inputs and DAW output. This will allow you to hear the microphone in sync with the click track from the DAW.

Input echo is off. I don't know what IOW is... The only knob to the right of center is labelled Monitor. It has a volume control, an On button and a Mono button. The On button switches the 1/2 light on and off. Not sure what you're referring to, but if you can clarify based on what I described, that would be great. Thanks.

Edited by RevSpyder

Share this post


Link to post
Share on other sites

The link in my post above is the current model. I found an older model that may be the one used here. Here is the description of the monitor section from page 17 of the user manual https://www.bhphotovideo.com/lit_files/374206.pdf

Quote

MONITOR section: The ON switch turns direct monitoring on/off. With direct monitoring activated,  the  unaffected  input  signal  will  be  heard  with  zero  latency.  The ON switch  also  doubles  as  a  monitor  selector  switch.  When  held  for  one  second,  it  cycles  through  three  monitor modes: monitor  signal  to  outputs OUT  1/2; monitor  signal  to  outputs  OUT  3/4;  and  monitor signal to both output pairs OUT 1/2 and OUT 3/4. The LEDs from the MONITOR section on the device's top panel display which monitoring mode is currently active.

The MONO switch  toggles  the  monitor  output  selection  between  a  mono  signal  and  a  stereo signal. Switching to a mono setting aids in monitoring a mono signal, such as a guitar’s mono input.

The VOLUME control lowers/increases the output level of the monitor signal.

This is how this interface implements zero latency monitoring

Share this post


Link to post
Share on other sites

Well thank you! I think we may be making progress. Setting the Monitor switch to 3/4 and the headphones the same, I eliminate the echo. However, it also eliminates the drum track. The whole point is to hear the drum track and sing or play along to it. To hear the midi drum track from the DAW I have to set the headphones to 1/2. With the monitor set at both 1/2 and 3/4 but the headphones at 1/2 (so I can hear the drum), there is still an echo. 

Share this post


Link to post
Share on other sites

Both the computer output and the direct signal need to be sent to the same interface output pair. Adjust the monitor volume knob to control the mix of DAW and direct signals.

Share this post


Link to post
Share on other sites

OK cranking the Monitor volume all the way up helps some. Doesn't eliminate it, but it's a bit better than it was...

Share this post


Link to post
Share on other sites

I was on the phone with Sweetwater tech support for 2 hours this morning and they were stumped.

Here's the current situation: If I set the monitor button for 3/4 or 1/2 & 3/4 the latency disappears. If I set the headphones to 3/4 the latency is still gone but I get no sound at all from the computer, whether in Cakewalk or YouTube or audio files on my media player. If I set the headphones to 1/2, I get full sound but the latency is back.

Does this give anyone a clue?

Still stumped....

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/7/2019 at 5:01 AM, RevSpyder said:

Well thank you! I think we may be making progress. Setting the Monitor switch to 3/4 and the headphones the same, I eliminate the echo. However, it also eliminates the drum track. The whole point is to hear the drum track and sing or play along to it. To hear the midi drum track from the DAW I have to set the headphones to 1/2. With the monitor set at both 1/2 and 3/4 but the headphones at 1/2 (so I can hear the drum), there is still an echo. 

Seems like your cakewalk project's master output is routed to only the 1/2 output hence you dont hear the midi drum track or the echo. Based on your observation that the echo only appears on 1/2, that means the latency is probably caused by having the input monitoring in the cakewalk turn on.

Just turn input monitoring off (speaker icon becomes grey) and switch back your monitor button to 1/2 and you should be able to hear cakewalk, youtube etc.
input monitoring button in cakewalk:
image.png.ff7606dfd40aacb9a1a0ad947bde366e.png

if direct monitoring is too soft, you can probably turn down your backing music (or the drum track) and turn everything way up. 

if turning input monitoring off doesnt fix the echo, it could be the "listen to this device" from windows recording device:

find your interface input under the recording device tab and make sure "listen to this device" is not checked

image.png.22459d653d1b98d662ed5082abb0adcb.png

if you really want to hear your vocals through certain plugins/effects you need to use low latency plugins and have a low buffer size/interface with good drivers. Let us know whats the latency number your interface is currently reporting.

Press P (for preference)>driver settings and check the round trip latency value
image.png.06bf907c61e313bb63f2729f9c2a1839.png

Edited by JL

Share this post


Link to post
Share on other sites

Thanks for all the suggestions. I never had the input monitoring turned on, but I tried it both ways and it made no difference. I don't run vocals or anything else through plug ins. I record everything dry and apply effects, if any, after.

HOWEVER: the suggestion to uncheck "listen to this device" worked! Problem solved.

Thank you so much, JL!

  • Like 3

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...