Jump to content
  • 0
joemango

Why is export performance SO SLOW?

Question

I am running cakewalk 2019.05 on the following specs:

Ryzen 5 1600

16 GB ram (ddr4,2400)

Samsung EVO NVME 500GB (2.4 GB/sec tested write speed)

using HDMI audio thru a NVIDIA gtx1050Ti

using fast bounce on my export, MMCSS, multiprocessing, etc

 

...and the Export performance is ABYSMAL. My cpu utilization never goes over 12%, and nothing else is bottlenecked... my disk utilization is at 7% and RAM util is below 4GB. A mixdown of 34 tracks at 48k/24, about 45m long, takes over 10 minutes to export and my PC seems bored with it. I'm only using sonitus effects (a few compressors and reverb fx)

WIth this much power, exports should take 2 minutes, not 10.  Whats going on here?  Why did I bother to get a fast computer if the software is crippled like this?

 

Can anyone give me insight?

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I can only offer 2 possible determining factors that would contribute to long Export times.. An old Plug in or your Soundcard (which you didn't list above).

I have an Intel I7 8200 and my Export times are around 60 seconds. that's for 30-40 tracks, 4 min song, up to 3 plug ins each track, editing, automation, the house. But a 45 min song, that's going to take time.

So I would look at those 2 things first.

Share this post


Link to post
Share on other sites
  • 0

Guessing this is an export to wav. Other formats could be the issue.

It could be plug-in related.

Modifying BounceBufSizeMsec in preferences might make a difference. While there make sure AllowOfflineRenderMixThreads is enabled and ThreadSchedulingModel is set to 2. These settings are documented here.

There there is the song length. Export time is a function of a lot of variables, track count and song length have a big impact.  Given the numbers cited by Chuck, your export times may be about right. I have never had such a long piece to export. Freezing tracks may help considerably with repeated exports.

Share this post


Link to post
Share on other sites
  • 0
On 7/24/2019 at 1:33 AM, scook said:

Modifying BounceBufSizeMsec in preferences might make a difference. While there make sure AllowOfflineRenderMixThreads is enabled and ThreadSchedulingModel is set to 2. These settings are documented here.

I was having similar slow (too slow) audio export problem in wav format.  Strange part is no problem happens in case of mp3 format . Following scook's suggestion my problem fixed! Thank you so much!!!!

By the way I set "BounceBufSizeMse" to 250 (max value) from 0. I am wondering if this is adequate??

Share this post


Link to post
Share on other sites
  • 0
On 7/23/2019 at 12:33 PM, scook said:

Modifying BounceBufSizeMsec in preferences might make a difference. While there make sure AllowOfflineRenderMixThreads is enabled and ThreadSchedulingModel is set to 2. These settings are documented here.

There there is the song length. Export time is a function of a lot of variables, track count and song length have a big impact.  Given the numbers cited by Chuck, your export times may be about right. I have never had such a long piece to export. Freezing tracks may help considerably with repeated exports.

I modified these and not much changed.  Setting MixThreadCount to 100 (max value) made it run a little faster but still pretty slow, maybe 35% CPU, and no other bottlenecks.

This is an extremely simple mix from a live multitrack recording, 45 minutes in length with 36 equal length WAV tracks.  Mixing to native format (48k/24b) with only cakewalk plug-ins (a couple of compressors and reverbs) being used.  Real time mixing only gets to maybe 5% CPU, so plug-ins aren't my issue.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...