Jump to content

Most unusual A dropout has stopped the audio engine situation


Recommended Posts

Hi Folks.

For  quite some time now, I was having issues with dropouts. Specifically:

"A dropout has stopped the audio engine"  - My biggest  Cakewalk nemesis. The things I have tried to resolve this in the past few years  would probably not fit into the page and I will spare you of these details and try to get to the point.

My recent project was pretty heavy with all kinds of plugins / synths and was giving me the dropout thing, stopping audio engine. For the test purposes  I decided to test the actual limit my computer can handle and compare my working project with test project. So I created another  project within same Cakewalk session. I started with 5 audio tracks and slapped 3 FX plugins on each (some that have look ahead function). Everything was fine. Then I duplicated all 5 including events and FX,  everything was running smoothly. Then I increased amount of audio tracks (with audio data) to 40+ with  at least 3 plugins each.  And it was running fine(!)

So I switched back to my main project (same Cakewalk session!) and started deleting things.  1) I deleted all synths 2)Deleted all Midi tracks 3) froze all remaining tracks.  Issue of dropouts persisted. Then I:  4) Deleted  all plugins from the buses and tracks. Issue remained (!) Then I started to delete tracks one by one, just for the sake of the test and BiNgO! Single  muted frozen drum track was causing Hard drive I/O overload!!! 

A Project with 40 not frozen audio tracks and over 120 Plugins (!) runs fine and one with 5  audio tracks and NO plugins causes overloads. How can that happen? If I delete that drum track, it would not overload.

One can say, sure, just get rid of that track and live happily ever after. But  this is a long running issue. How would I know next time which specific track causes this?  Is there a reasonable explanation for this situation? Kindly let me know. Attaching a screenshot of the project. When/if replying, kindly keep in mind that this test of two projects was run under the same Cakewalk session.

Thank you. 

P.S. Both projects are 44.1kz / 16bit. The hard drive is SAMSUNG 980 PRO 1TB PCIe NVMe Gen4 Internal Gaming SSD M.2.



Link to comment
Share on other sites

My first guess would some problem reading that particular file.  The performance meter is showing not a lot of free space remaining on that disk. I don't know much about failure modes or behavior of SSDs when they get old, extremely fragmented and/or full, but would probably suggest some of the same things you would do with a conventional drive: free up space, scan for errors, defrag and re-save the project to a new location with Copy All Audio enabled to consolidate it.

Link to comment
Share on other sites

Thanks for replies.


I have over 100GB free.  Samsung 980 Pro SSD HD is not old (and not overused). 


"A dropout has stopped the audio engine (01)" Same code I was getting for few years on different machines.


I should have been a little more clear.  It is not that I can't tinker with projects that have "A dropout has stopped the audio engine (01)" , I can. 

But during mixing  / adjusting plugins, or when just playing, it could stop a dozen times  during single session. 

Also for the test described above I had Asio at highest 2048, safe mode on.  Cakewalk-latest,  Windows up to date, interface firmware/drivers latest.

I sincerely doubt it has to do with hardware. The track in question, plays fine by itself. 


Link to comment
Share on other sites

Yeah, really weird. That's basically a starved buffer error, which at 2048 shouldn't be a thing at all on what sounds like a pretty beefy system like you have.

If this was an isolated thing, I would point the finger at a crosslinked audio file on your SSD or something like that. With Cakewalk closed, if you do an error check on the drive this file is on, do you get anything back?

But if this is persisting across different projects, it's an odd case for sure!

Does this happen if you bounce the problem track to a new track instead of freezing it?

Link to comment
Share on other sites

L. Tim.

Yep, this is the most ridiculous one I have ever experienced. Bouncing did nothing. I even tried saving as Cakewalk Bundle which copies files, so there is no shared / cross related issues. 


Yep I tried that too :)  I had an issue with previous interface (Apogee one). Larger projects, even at 2048 would cause buffer overflow, making interface stuck and sound distorted. The only way to solve that except for relaunching Cakewalk was to lower the buffer to make interface heal. Current interface is from Arturia Mini Fuse.  I experienced same issue: A dropout has stopped the audio engine (01)"  with Yeti Pro, Motu M2, Apogee One and now with newly released Arturia Mini Fuse.  The only interface that worked smoothly ever for me is/was Arturia Audiofuse - the original   that was released in 2015. 


might be that all these interfaces I have issues with are under powered. Only original Arturia Audiofuse  uses external power supply, all others are USB power fed. Original Arturia Audiofuse, would light up that "drive" icon in Cakewalk's Performance monitor, but will not cause Audio engine to stop. 


I will try to free up additional 100GB on the main drive today and check if Samsung has a firmware update for it. Other than that I am out of the ideas. I have tried all solutions mentioned in Cakewalk documentation regarding  Stopped audio engine 01,  Sweetwater Cakewalk guide regarding same thing, Power plan set to Ultimate. Nothing spikes in Task Manager. Plenty of resources. Must be some kind of glitch possibly with Hard Drive handling Cakewalk or not enough power (by design) of those interfaces, that do not use external power supply. 





Link to comment
Share on other sites

16 minutes ago, Misha said:

ep I tried that too :)  I had an issue with previous interface (Apogee one). Larger projects, even at 2048 would cause buffer overflow, making interface stuck and sound distorted. The only way to solve that except for relaunching Cakewalk was to lower the buffer to make interface heal.

Oh well...I've definitely heard of cases where too high a buffer caused issues.

Post it as a cwb somewhere so someone else can test (if you're OK with that, of course)?

Link to comment
Share on other sites

The first thing I would try is open the exact same CPW on a different machine and see if you get that dropout. The dropout is unlikely to be related to the disk since the code is different for disk underrun errors. If you share a link to the project and its reproducible we can look into it.
PS: Also I’m not sure if you are aware of it but you can completely disable dropout detection via preferences | configuration file. If its an intermittent dropout this might be useful to do.

Link to comment
Share on other sites

High oversampling during mixing cause dropouts. Effects such as iZotope plugins gives the code 1 dropout too - others would be 32bit plugin versions. I have an issue with Nexus 2 which is 32bit and it does not want to befriend CbB - even with the latest jBridge installed. 

Try to check for these things too 

Edited by Will.
Link to comment
Share on other sites

Will, Thanks for trying!

I gave up on Izotope plugins about a year ago. In my view,  they are just resource sucking leaches, compared to most others, except for their older/legacy plugs.  My main plugins are from Fabfilter.


Thank you for replying! I was just about to post to topic and got your reply. I freed about 100gb from the hard drive and HD icon at resource monitor is not lit any more.  For "disable dropout detection" You mean: Mask Dropout detection = True?   

My final thoughts on this is that all  most USB  bus only powered interfaces do not work well with larger projects. I have tried 4 and had same issue on all 4.   The 5th interface Original (rev1) Arturia Audiofuse  was a "Rosetta Stone". Because it can run bus power only and with external AC. Running Audiofuse without external power supply at highest buffer gives same  "Stopped audio engine 01".  As soon as I plug in the AC cord, all issues go away. 

I picked up MiniFuse, thinking that it is a newer interface that should take the load well. I guess not. I am not sure of true Thunderbolt bus powered interfaces, perhaps they get enough power to pull heavier projects.

Edited by Misha
Link to comment
Share on other sites

  • 5 months later...

Hi all, justed wanted to share a little episode I had with dropouts, although it's almost a joke it may help other people to avoid the same aggravation :-)

All of a sudden I started to have a (11) code dropout message consistently and continuously. It was a long time, after trying a lot of different things such as suggested in this thread and in the Cakewalk manual, that I realised that I had the function active with a zero length loop segment (i.e. start point = end point).

It was this that was causing the dropout, I think I must have pressed Shift-L inadvertently. As it happens, if you press SHIFT-L without any selection (as when you have just opened a projet) Cakewalk sets a loop segment with both beginning and ending at "now time" and activates loop mode. 

  • Like 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...