Jump to content
msmcleod

New update to MMcL Mackie Control

Recommended Posts

I've updated my version of the MackieControl for Cakewalk to automatically assign the fader offsets as you add your control surfaces within Cakewalk preferences. So the first device you add will control 1-8, the second device you add, 9-16, and so on. This only affects adding Mackie Control & Mackie Control XT devices (i.e. not the C4).

This is useful for control surfaces that do not have v-pots, or do not have a display, making the "Configure Layout" mode difficult to use.

You can override the automatic assignment by using the "Configure Layout" button on the dialog, or alternatively removing all the control surfaces within preferences and adding them again in a different order.

Latest version is here: http://msmcleod.co.uk/cakewalk/MMcLMackieControlSetup.zip
Latest readme: http://msmcleod.co.uk/cakewalk/MackieControl-MMcL.pdf
...and for those of you who want to see the source code: https://github.com/msmcleod/Cakewalk-Control-Surface-SDK

As usual, no need to uninstall - just run the installer and it'll update everything. Just make sure Cakewalk isn't running when doing the install.

Remember - to use this version you must choose "MMcL MackieControl #1" as your control surface not "Mackie Control", which is Cakewalk's version.

Edited by msmcleod
  • Like 1
  • Thanks 2

Share this post


Link to post
Share on other sites
On 12/9/2021 at 7:52 PM, Anders Madsen said:

The interface will not start when I click it under utilities.
And after one try, it goes grey/inactive.
Wut?

Maybe Windows has blocked the DLL ? 

You can unblock it by:

1. Go to  C:\Program Files\Cakewalk\Shared Surfaces in Windows Explorer
2. Right click on MackieControl-MMcL-1.dll and select Properties from the context menu
3. Check the unblock checkbox, click Apply, then click OK.
4. Do the same for MackieControl-MMcL-2.dll and MackieControl-MMcL-3.dll.

unblockSurfaceDLL.gif

  • Like 1

Share this post


Link to post
Share on other sites

Thanks. That windows behaviour has given me several problems. Knowing them help fixing them.
But that was not the case here.
I fixed it, but I do not know how. I have two midi controllers; An Icon Qcon pro 2 and a Komplete kontrol A61.
When the Icon was disconnected, I could not start interface for KK.
I Removed, installed again, connected/started them in different orders, and by today, they both start.

Share this post


Link to post
Share on other sites

@msmcleod, thanks so much for this.

I am using the Studiologic Mixface and everything seems to be working, except for the following:
CREATE NEW MARKER
LOOP Selection

The MIXFACE has a selection for both Reaper and Studio ONE (they seem to be the same Mackie Control), and the Set Markers and Enable Loop function in each as expected. Just wondering how we could get that integrated into this control surface plugin?

Thanks again!
Simeon 
 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...