Jump to content
Frank DeFede

Universal Control on Firestudio changes buffer size

Recommended Posts

I am wondering if anyone could offer suggestions on why my Universal control for the Firestudio by Personus changes the buffer size.  I have had this problem a long time.  I have been dealing with it by just setting it back, but sometimes it crashes.  For instance,  I may have it at at higher number like 512, 1024, or even 2048 at 44.1Khz, in the normal mode, and it may play fine for a while, but then switch to a lower number like 128 or 256 where I start hearing clicks and pops.  If i move it back it will sometimes crash the program or even the entire computer where I get a blue screen of death.

I think part of the problem is that maybe I don't know exactly how it works or how to set it up correctly.  I am always so busy recording or producing something that I haven't taken the time to deal with this.

Any help is much appreciated.

Thank You

Share this post


Link to post
Share on other sites

If you are using the Firestudio as your "Windows" default sound device, that will cause the issue.  I also grappled with this for a long time (as well as Sample Rate Changes) and as soon as I changed the default Windows audio device to the integrated Realtek soundcard the problems went away. To get around not being able to hear web audio, I patched the speaker output to inputs 7/8 on the FS.  If I need the inputs for tracking, I just unplug soundcard outs... I have also considered a second pair of speakers specifically for that.  Hope that works for you!

Share this post


Link to post
Share on other sites
Posted (edited)

Thank you so much for the info on the Firestudio.  I am away from home for another 4 weeks so I won't be able to try it until them.  I am anxious to see how I have it set up.  I think that maybe I do have FS set up as the default.  I am wondering if you also got the blue screen of death at times, and if so did it go away when you changed the default.  I am using Windows on a powerful Xeon Processor Machine.  I had wondered if being a Xeon had anything to do with it.

Thank you

Edited by Frank DeFede

Share this post


Link to post
Share on other sites

AFAIK, audio interfaces don't tell the driver what buffer sizes to use. That has to come from an application, or from Windows itself (which I think only initializes settings on bootup). So Blindeddie is on the right track, I think. Something's overriding the instructions that Cakewalk sent to the driver when you first opened the project. 

You didn't specify which driver you're using, so I'll assume it's ASIO. If that's the case, give WASAPI a try. WASAPI supports multiple audio streams, each with its own sample rate. I'm just spitballing here, but it seems that if each data stream can have its own sample rate and wordlength, that implies that each one has its own buffers , making it immune to having two applications fight over buffer settings. 

If you are already using WASAPI, try switching to ASIO, which normally can only be used by one application at a time. I would think that would preclude interference from other processes.

[EDIT]

I checked out the WASAPI documentation to be sure I wasn't blowin' smoke. WASAPI does indeed support multiple independent audio streams, each with their own buffers. But that only applies to shared mode. In exclusive mode, WASAPI works more like ASIO, in that only one application at a time can have control over the driver. Exclusive mode is also more efficient, obviously, since it doesn't have to juggle multiple data streams. I use WASAPI here, and I have no problem running other programs while Cakewalk is open, e.g. watching a YouTube video.

ASIO and WASAPI can be used at the same time, as they are separate worlds. You should be able to use ASIO for Cakewalk and WASAPI for Windows, and there won't be a conflict.

Share this post


Link to post
Share on other sites

Thank you for that information!  I can't wait to get back into my studio to try out the suggestions. 

I am using ASIO.

It will be around Aug10th before I can see the results.  I will be sure to post the results.

Share this post


Link to post
Share on other sites

 

4 hours ago, Frank DeFede said:

I will be sure to post the results.

Good on ya, Frank. Too often an interesting problem is posted but then never subsequently updated, depriving us all of the opportunity to learn something. Once you've figured it out - and you will - be sure to also edit your initial post to preface the thread title with "[RESOLVED]".
 

Share this post


Link to post
Share on other sites

Sorry it took me so long to get back to you all on this.  I just started working again on projects.

I set the default to the realtek hi definition as suggested, but the problem still persist.  When I try to set the buffer size to a higher number it usually crashes the computer, and I get a Windows stopcode.  Any other suggestions are much appreciated.

Thank you.

Share this post


Link to post
Share on other sites
43 minutes ago, Frank DeFede said:

Any other suggestions are much appreciated.

Maybe asking over at the Presonus forum?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...