Jump to content

Question

Can anyone help me track down why my output is Harsh and Tinny and has some weird digital distortion?  I'm using Melodyne to tune audio and the problem I'm having is particularly on vocals though happens to some cymbals and drums too.  Siblance or syllables like "Shh" from "she" or other phrases really grate on my ears in the output - however when playing back inside Cakewalk it sounds perfect!   I'm trying the files in windows as well as using them for a music video constructed in Davinci Resolve - this may be more pronounced in Resolve too. 

No matter if I export an mp3 (at 256 with highest fixed quality) or a 48000 wave file - some parts of the song just sound really painful like grating digital or harsh tinny, sounds - only on specific parts.  This doesn't sound like clipping.  But why would it sound awesome inside Cakewalk but be littered with annoying issues when in Windows or in Resolve or it its video output?  Is this a Melodyne Rendering artifact that only affects mixdown?

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 1
Posted (edited)

It's because you don't have an accurate monitoring environment as well as everything else in your previous thread on the same subject.

Edited by bdickens

Share this post


Link to post
Share on other sites
  • 0
5 minutes ago, bdickens said:

It's because you don't have an accurate monitoring environment as well as everything else in your previous thread on the same subject.

I’m using pro Audio Technica headphones to edit and mix and the same to test the output. I would think that isn’t it?

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, bdickens said:

It's because you don't have an accurate monitoring environment as well as everything else in your previous thread on the same subject.

Thank you for reminding me, but I checked my previous thread and the spatial audio settings are off this time. I’m wondering if I’m pushing melodyne too hard but for some reason the real-time melody be sounds fine but the render audio does not? How else can I track it down? Is this a compression thing? I thought waves we’re uncompressed. 

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

If you import the file back into Cakewalk and play it, how does it sound?

 

"pro Audio Technica headphones" doesn't mean that they are accurate.

Edited by bdickens
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Are you rendering your Melodyne clips before you export?   You should always render after editing with Melodyne. 
 

Watch video 27 and you might also benefit from watching # 28, 29 and 24 which explains setting up a proper export  

 

  • Great Idea 1

Share this post


Link to post
Share on other sites
  • 0

This could be many things.

I wouldn't worry about your headphones as a source of confusion. After all, you can hear the artifacts using the same headphones in programs other than Cakewalk. Curious, though: what model AT's are you using? My go-to cans are M50x's, which are brutally capable of revealing details like this. In general, any hard-wired MT series should be delivering pretty honest headphone mixes, from the M20x on up. Bluetooth has to go through extra CODEC's, and the fewer of those your audio passes through, the better.

Get a copy of Bitter and put it in the FX rack of whatever bus you're taking your export from, or that last one you route through before it goes to the hardware outs (Cakewalk's default "Entire Mix" export location). For whatever reason, you may be getting intersample clipping, and Bitter can find those. The mystery is why it's only happening during Export and not simple playback, but you can try to address that in the following ways.

I don't take my exports from the hardware outputs. I set up a dedicated bus that I route the Master bus to. I have a sophisticated metering plug-in on this bus (I use Mastering the Mix LEVELS, but Meldaproduction's MLoudnessAnalyzer from their FreeFX bundle will also work) to make sure that the levels I'm sending to the rendering engine are the same as what I'm listening to.

Is it possible that during export, you're bypassing a limiter or compressor that is engaged during mixing? That might result in the export having interstage clipping. Also, too low a level during export can also result in degraded sound quality. With digital, the sweet spot is huge, but there are still ways to get outside it.

Also: are you using plug-in oversampling, the 64-bit mix engine or the 64-bit rendering engine, or any combination of the above? Some plug-ins go sideways with combinations of the above. I've found that for safest reduction of aliasing, if I just render the project at 88.2KHz I get the benefits without the possible unwanted side effects. Then I use a separate converter program on the exported file to generate formats for distribution or use in video production (MediaHuman is my favorite freeware convertor). In your case, you would render at 96KHz, as that is double your project rate.

Try doing a render with all of your FX bypassed and listen to the results. Maybe a plug-in is going weird at render time, and that might help find it.

  • Great Idea 1

Share this post


Link to post
Share on other sites
  • 0

I see that you've done some investigation into the matter of other playback programs routing through the Windows mixer, as opposed to Cakewalk, which goes direct if you're using WASAPI or ASIO. Which you always should be regardless of what audio device you're listening through.

If Resolve can use WASAPI, switch to that and see if you still get the crappy sound.

There are also good music players that can use WASAPI and ASIO (and therefore bypass the Windows mixer). MusicBee is freeware and can do this. I recommend using it or something similar for listening to final mixes. If it sounds good in MusicBee in WASAPI Exclusive but not in other programs, then you know for sure that the export is good and there is something wrong with the output configuration of the other programs.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
14 hours ago, John Vere said:

Are you rendering your Melodyne clips before you export?   You should always render after editing with Melodyne. 
 

Watch video 27 and you might also benefit from watching # 28, 29 and 24 which explains setting up a proper export  

 

Thanks for that - I will check out the export tips - appreciate that!

And no, I haven't been rendering Melpdyne tracks before mixdown - I've been worried about going a step too far and needing to edit something so have been avoiding freezing or Rendering the Region FX.  I've also been using the Take lanes for vocal comping and then creating a Region FX on that for Melodyne, so I end up duplicating the original tracks for backup in the project before the comping, and duplicating again after Melodyne editing the regin FX, and then final effects etc on the 3rd dupe.  I assume that's the safest way to keep stuff if I have to go back.  Sometimes I grab a word or syllable from another track's Melodyne and paste it into another Melodyne track, and if I render I can't do that anymore late in the game.

 I tend to use greyed out track colors and folders to store backuped original tracks in case I screw up and need to redo a step.  My laptop has so far been pretty powerful and my FocusRite seems solid so it's not too cluttered.

I'll read what you sent, but do you suggest Flattening the Comp before creating the Melodyne Region FX?  I also don't Freeze tracks - should I be doing that?

 

Thanks!

Share this post


Link to post
Share on other sites
  • 0
38 minutes ago, Starship Krupa said:

This could be many things.

I wouldn't worry about your headphones as a source of confusion. After all, you can hear the artifacts using the same headphones in programs other than Cakewalk. Curious, though: what model AT's are you using? My go-to cans are M50x's, which are brutally capable of revealing details like this. In general, any hard-wired MT series should be delivering pretty honest headphone mixes, from the M20x on up. Bluetooth has to go through extra CODEC's, and the fewer of those your audio passes through, the better.

 

Yes, mine are the ATH-M50x too - I love them.  Yeah I never use Bluetooth for headphones mostly because of latency.  I love these - I just wonder if I'm doing a poor man's monitor like bdickens mentioned and I'm introducing bad mixes into the workflow.  But I thought these were relatively flat?

 

Get a copy of Bitter and put it in the FX rack of whatever bus you're taking your export from, or that last one you route through before it goes to the hardware outs (Cakewalk's default "Entire Mix" export location). For whatever reason, you may be getting intersample clipping, and Bitter can find those. The mystery is why it's only happening during Export and not simple playback, but you can try to address that in the following ways.

I don't take my exports from the hardware outputs. I set up a dedicated bus that I route the Master bus to. I have a sophisticated metering plug-in on this bus (I use Mastering the Mix LEVELS, but Meldaproduction's MLoudnessAnalyzer from their FreeFX bundle will also work) to make sure that the levels I'm sending to the rendering engine are the same as what I'm listening to.

 

Thanks for the tip on Bitter - I'll check it out. And I'll google "intersample clipping" I know what clipping sounds like - but I don't know what you mean here exactly.  I have a series of VSTs that are decent (I think?) - I picked them up during the last major IK sale - I have T-Racks 5 with a few metering plugins plus the Stealth Limiter and the Lurssen Mastering Console - but admittedly I'm a huge noob with them and have barely touched them yet.  I'll check out the one you mentioned to see how the metering works on that.  I had been considering an Izotope metering plugin I'd seen that seemed very comprehensive and had spectrum analyzers too.

 

Is it possible that during export, you're bypassing a limiter or compressor that is engaged during mixing? That might result in the export having interstage clipping. Also, too low a level during export can also result in degraded sound quality. With digital, the sweet spot is huge, but there are still ways to get outside it.

Also: are you using plug-in oversampling, the 64-bit mix engine or the 64-bit rendering engine, or any combination of the above? Some plug-ins go sideways with combinations of the above. I've found that for safest reduction of aliasing, if I just render the project at 88.2KHz I get the benefits without the possible unwanted side effects. Then I use a separate converter program on the exported file to generate formats for distribution or use in video production (MediaHuman is my favorite freeware convertor). In your case, you would render at 96KHz, as that is double your project rate.

Try doing a render with all of your FX bypassed and listen to the results. Maybe a plug-in is going weird at render time, and that might help find it.

 

I'm fairly certain that all boxes are ticked in the export panel and nothing is being omitted.  The signal is hot enough too, so it's not that.  I have no idea whether I'm using plugin oversampling or not. In the past before I got my FocusRite 4i4, I wasn't sure about messing with sampling rates in case my hardware couldn't handle it, I think it can now, but my Cakewalk rate is only set to 48000, but I'm ok with that in the mix and it sounds ok to me in my M50x headphones.  I'd be worried about changing it after I started the project because I have a lot of recorded tracks.

Thanks for the tips! I will keep investigating.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
55 minutes ago, Starship Krupa said:

I see that you've done some investigation into the matter of other playback programs routing through the Windows mixer, as opposed to Cakewalk, which goes direct if you're using WASAPI or ASIO. Which you always should be regardless of what audio device you're listening through.

If Resolve can use WASAPI, switch to that and see if you still get the crappy sound.

There are also good music players that can use WASAPI and ASIO (and therefore bypass the Windows mixer). MusicBee is freeware and can do this. I recommend using it or something similar for listening to final mixes. If it sounds good in MusicBee in WASAPI Exclusive but not in other programs, then you know for sure that the export is good and there is something wrong with the output configuration of the other programs.

Yes a previous sound quality issue I had was related to the playback outside of Cakewalk being affected by Windows Spatial and audio Enhancements.  I've since turned all that off in the Windows settings and that problem from then is gone now.  I think the Fairlight page in Resolve is set to use ASIO and the Focusrite 4i4, and it sounds ok in Resolve, but the exports from Resolve are bad too.  I think it might be AAC compression in the MP4 settings that you can't edit.  Perhaps I shouldn't try a YouTube export option (even though that's the target), but instead do the highest export possibly and let YouTube compress it?

Again thanks for the tip - I will check MusicBee out as well and see how that sounds. :)

Edited by whipsmart

Share this post


Link to post
Share on other sites
  • 0
34 minutes ago, whipsmart said:

it sounds ok in Resolve, but the exports from Resolve are bad too

Ah, so you have Resolve set to use ASIO, and when you play the file you export from Cakewalk in Resolve, it sounds fine? Then the exported project from Resolve sounds poopy again?

That points to whatever player program you're using on your desktop. Try using VLC for your audio and video playback. By default, VLC does go through the Windows mixer, but you can configure it otherwise. It will at least help you sort out why your audio playback sounds so crappy in Windows.

And again, don't worry about somehow giving your mixes cooties by monitoring with your industry standard pro-level cans. I use the same ones and my exports sound fine. If anything, headphones can be more revealing than speakers. As I said, if the artifacts are audible on the cans in one situation, that means the cans are able to reproduce them accurately. If they're hiding them in Cakewalk and Resolve, they would be hiding them in other programs as well.

@bdickens is actually employed by the audio equipment industry to promote purchases of gear. 😂 (just kidding, I love ya, ya big lug)

Share this post


Link to post
Share on other sites
  • 0

And I did note you had 64 bit engine engaged in preferences so turn that off.  The consensus around here has been if you don’t understand what it’s for don’t use it as it is not necessary. 

Share this post


Link to post
Share on other sites
  • 0
On 6/26/2022 at 7:18 AM, John Vere said:

And I did note you had 64 bit engine engaged in preferences so turn that off.  The consensus around here has been if you don’t understand what it’s for don’t use it as it is not necessary. 

I am one who should, and does, leave it switched off, because even when Noel explained it, it sounded like its purpose was "marketing." When I released "Sensation," I tried various permutations of playback and export, using plug-in upsampling or not, exporting at 44.1 vs. 88.2, 64-bit Double Secret Probation Engine or not, and the 64-bit Engine selection didn't make any difference that I could hear (plug-in upsampling and exporting at the doubled rate did, however, with the higher rate export being the safest in terms of unforeseen behavior from plug-ins).

image.png.77a22a701e47e993165112e3fada21b1.png

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...