Jump to content
DallasSteve

MIDI Channel Confusion

Recommended Posts

Posted (edited)

I don't understand how I should use MIDI channels in Cakewalk and normally that has not caused me any problems.  I'd rather not spend a lot of time learning the details if I can get the work done.  But now I have imported an old Cakewalk file (from back in the 80s or 90s) and when I try to assign a track to my Kontakt Evolution guitar plug in I get no sound.  If I assign that track to Cakewalk TTS-1 synth the notes make a sound.  On my other songs before this I just created the notes in piano roll and they always produced a sound.  I never had to worry about what channel was what.  That's how I like it.

So I clicked on a few notes and instead of being assigned to channel 1 they are assigned to channel 2 or some other channel.  I don't know why.  That was 30 years ago.  If I change the channel to 1 then the notes will sound in Evolution.  But I haven't found a way to quickly change all of the notes to channel 1.  Can you tell me how to do that or can you tell me how to adjust Kontakt Evolution so that it will make a sound for other channels?  As a last resort you can try to teach me MIDI channel basics, but if it gets very deep  I will go some other direction.  Spending a lot of time in MIDI theory is not something for me, and I've already produced 25 songs without it.

Edited by DallasSteve

Share this post


Link to post
Share on other sites

So there could be lots of reasons, so it's a little hard to trouble shoot.

Some synths don't make sounds in certain note ranges. Like a bass synth might only go so high and piccolo only go so low.

Different synths sustain differently. Some slowly fade the tone and some keep it playing indefinitely until the note-off event.

For your synth of choice, open piano roll view and click the notes on the piano to hear the ranges that make sounds. Then note the ranges of the notes in your piece.

  • Like 1

Share this post


Link to post
Share on other sites
51 minutes ago, Gswitz said:

So there could be lots of reasons, so it's a little hard to trouble shoot.

Some synths don't make sounds in certain note ranges. Like a bass synth might only go so high and piccolo only go so low.

Different synths sustain differently. Some slowly fade the tone and some keep it playing indefinitely until the note-off event.

For your synth of choice, open piano roll view and click the notes on the piano to hear the ranges that make sounds. Then note the ranges of the notes in your piece.

Thanks for the reply.  Those are good tips, but that's not the problem.  I just went back to one of the notes that don't sound in Kontakt Evolution.  I double clicked the note and it was assigned to channel 3.  I changed it to channel 1 and I went back to the piano roll  view and now that one note sounds in Evolution.  It is definitely within the range of the notes it will play.  So again, I hope someone can tell me how to change all of the notes to channel 1 in one quick move.  I tried doing a Google search and I didn't find it, but I may search deeper.

 

Share this post


Link to post
Share on other sites

I found a solution to the problem, although I don't understand why it works.  In the Cakewalk interface shown below I set MIDI channel for the track to channel 1 and now the notes sound even though they are assigned to channel 2.  Maybe that overrides the channel setting on the individual notes which still shows 2.

Cakewalk2.jpg

Share this post


Link to post
Share on other sites

By default, CbB sends MIDI data, as is, to the plug-in.

Channel is a note property. 

It is possible to force the channel assignment in all the notes at the track level using the Channel drop down as show in the image above.

There are a couple of ways to change the channel assignment for some notes in a track. Here is one, 

  • make sure the Channel drop down in the track is set to None
  • select the notes to change
  • set the channel in the Event Inspector

 

  • Like 1

Share this post


Link to post
Share on other sites

Kontakt uses MIDI channels to assign  MIDI inputs to a specific  instruments.  Kontakt is a multi instrument sampler that can have many instruments loaded. Each will have it's own MIDI channel and audio output. It is not unlike a Sound canvas  hardware sound module in this regard except for audio output. 

In Cakewalk  there are provisions for MIDI output and MIDI channel. 

Looking at the screen shot under the instrument name the output is for audio output  the MIDI ch is for MIDI input.  I like to have these two independent things the same only because it make for neater "housekeeping". They do not have to be the same.  Kantakt can have many MIDI inputs in many banks. It can also have multiple audio outputs. 

709611761_Kontakt1.thumb.jpg.c638a3652ffba442aee9486d31a69cc5.jpg

  • Like 1

Share this post


Link to post
Share on other sites
22 hours ago, scook said:

By default, CbB sends MIDI data, as is, to the plug-in.

Channel is a note property. 

It is possible to force the channel assignment in all the notes at the track level using the Channel drop down as show in the image above.

There are a couple of ways to change the channel assignment for some notes in a track. Here is one, 

  • make sure the Channel drop down in the track is set to None
  • select the notes to change
  • set the channel in the Event Inspector

 

scook

Thanks.  That's what I was looking for.

 

Share this post


Link to post
Share on other sites

John

Thanks for that reply.  I don't see the Input/Output selection in my interface below.  Do you know how I display those options?

Cakewalk2.jpg

Share this post


Link to post
Share on other sites

In your picture  where the title of the instrument is you see a camera icon and to its right and ( i ) icon click that, the i that is. It will switch from your view to inputs and outputs as in my screen capture. 

 

P.S. If can get the full version of Kontakt. It is a great sampler. 

  • Like 1

Share this post


Link to post
Share on other sites
23 hours ago, John said:

In your picture  where the title of the instrument is you see a camera icon and to its right and ( i ) icon click that, the i that is. It will switch from your view to inputs and outputs as in my screen capture. 

 

P.S. If can get the full version of Kontakt. It is a great sampler. 

John

That worked.  I had never click on the i icon.  You are an official Kontakt guru.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...