Jump to content

Recommended Posts

Posted (edited)

if I run them at 256 it goes away. I have a single audio track playing a stereo mix (24/44.1) and 2 empty audio tracks. No effects or plugs at all running. Sometimes I can do tracking at 128 without this issue, most of the time I get this distorted mess. Any ideas? I am running 32 gigs of Ram and according to the performance meters, it’s barely registering.
 

https://youtu.be/MoFMInaTffE

Edited by Mr. Torture
Fix link

Share this post


Link to post
Share on other sites
Posted (edited)

Most audio interfaces can achieve low latency while playing a single stereo track like that.

Look for an updated driver for your interface.

Maybe disable your Windows sound card and any other sound devices in the device manager.

Try not sharing drivers with Windows.

Maybe borrow a different brand audio interface and see if you get better performance.

You have a bottleneck somewhere, your processors are barely moving.

32 mb of even slow ram should not perform that bad. 

Try a different audio interface, your interface drivers may not like Windows 10.

I think the problem is the interface and its drivers.

Edited by RexRed

Share this post


Link to post
Share on other sites

I am using the RME PCIe card, which is one of the most stable cards in existence. The computer is completely optimized for recording audio, it has been gone over extensively. 

Share this post


Link to post
Share on other sites
Posted (edited)

I have the same card and amount of memory. No issues seen like this. Does not seem like a performance issue (your PC is more than capable for a few tracks), sounds like something else is not in order. Weird that 256 does works, however, do you have an AMD processor? The first generations suffer from internal latency issues (I have a first generation Threadripper and ran into this problem once in a while, however extensive tweaking and a little overclocking especially memory has mostly eliminated my problems).

I would also use latencymon to see if any specific process is responsible for problems. It has helped me a lot finetune my PC in the past. 

 

The things below I wrote in first instance, but considering that you have no problems at 256 they probably are not applicable to your problem. I leave them here, just in case...

I can't see it very well on your video, but it looks like your audio signal on the track itself is way to high. Maybe just a case of gain staging (reduce the gain on the track)?

Did you check your cables, connectors and pots on external hardware? I once found out that a jack was hardly making any connection after many year of use. It took me hours of checking everything I could think of before I find the culprit. Just cleaning it did the trick. 

 

Below some things that are probably not related to your current problem, but worth knowing anyway:

Windows updates also reverses certain settings once in a while, so it doesn't hurt checking if all tweaked AudioPC settings have changed in the mean time... 

With GPU driver updates I also found that at moments when I did not pay enough attention new audio drivers were installed, messing up my preferred settings.

I just found out that my latest network driver update also had restored power management (which needs to be off...)

Also, regularly make sure your runtimes are up to date : up to date Runtimes all in one package 

Edited by Teegarden
better understanding of the problem

Share this post


Link to post
Share on other sites

Have you ever had ASIO4ALL (or other ASIO drivers) installed on that system? I remember I had similar effect back in time, but I can't remember why. It can be that time I was testing ASIO4ALL on my primary computer, which did something with all other ASIO drivers. This I couldn't revert till the next major Windows update...

And since that is fast to do... Have you checked in RME panel there is no errors?

Another (relatively) quick and overall test (Cakewalk does not really show RT load, LatencyMon is more to find the reason of some problems then to detect which problem exists): install REAPER (portable), create the same track, open View/Performace meter, right click and enable everything (except Hold RT). Start playback and watch if some numbers look strange. Press "Record arm" on the track (no reason to stop playback for that...), check everything is still ok (in performance dialog).

  • Like 1

Share this post


Link to post
Share on other sites

And just add. I worked at 128 for years with my Focusrite interface but I bought a Motu more than a year ago and it crackles at 128. I had to bump up to 258. Same system, same projects. So it’s complicated,  the person who ever 100% understands PC audio will rule the world. 

Share this post


Link to post
Share on other sites
Posted (edited)

All audio drivers updated including firmware. Internal sound disabled, windows updates shut off. Everything was optimized from pc audio labs.

computer is nearly 12 years old but runs an i7 processor.

I added the 4 channel RME input expansion in 2017. Problems really began when I upgraded to windows 10. But I didn’t use the expansion a lot until recently. It utilizes pcie too, maybe that’s an issue? Thinking about disconnecting and see what happens.

 

Edited by Mr. Torture

Share this post


Link to post
Share on other sites

The expansion cards for the RME AIO don't utilize PCIe (no conducting paths).

But the distortion in your example is really severe and doesn't sound like only buffers dependent.

Could that be a recording of two sources at once with "Remove DC Offset During Record" enabled/checked?

Look in Preferences > Audio > Playback and Recording and uncheck the above option if enabled.
 

Share this post


Link to post
Share on other sites
Posted (edited)
16 minutes ago, Klaus said:

The expansion cards for the RME AIO don't utilize PCIe (no conducting paths).

But the distortion in your example is really severe and doesn't sound like only buffers dependent.

Could that be a recording of two sources at once with "Remove DC Offset During Record" enabled/checked?

Look in Preferences > Audio > Playback and Recording and uncheck the above option if enabled.
 

Thank you for the information about the expansion, good to know! I will check that setting, but if I simply change the buffers to 256, all that distortion and weird clicking goes away. I just imported in that stereo mix for the example, it would do the exact same thing if I tried to record a single track of guitar.

Edited by Mr. Torture

Share this post


Link to post
Share on other sites

Have battled similar issues, finding mine to be more related to CPU performance. Projects that used to run fine have stuttered/stumbled during playback. Raising the buffer to 1024/2048 samples has not always made a difference. However, I recently reviewed every single performance setting (most already mentioned above) and for the first time, set the CPU to be overclocked. CxB has been running like a champ every since, with fairly heavy projects (unfrozen VSTs) that used to grind to a halt. 

planning for an upgrade, but currently running an i7-5820K, nom @3.3GHz, but it will O/C up to 4-4.2 GHz under load.  Keeping an eye on CPU temp, but hanging in there.

you might try hovering the mouse over the CW performance monitor in the control bar to see if notes excessive dropouts, lost buffers.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...