Jump to content
Bad Mac

VST3 synths supported in Cakewalk?

Recommended Posts

Posted (edited)

I am noticing that no VST3 synths / instruments work in cakewalk or at least my version of cakewalk. OtherVST3 plugins like iZotope or Amplitube seem to work just fine. Just issue with the Synths.

 

Does cakewalk support VST3 Synths / Instuments? Or is there a setting somewhere?

Edited by Bad Mac

Share this post


Link to post
Share on other sites
Posted (edited)

which VST3 insrument works and i will get it and try it. perhaps i have something wrong with my latest version of cakewalk.

 

Either ay, i cannot get VST3 synths to work in cakewalk. Any sugestions?

Edited by Bad Mac

Share this post


Link to post
Share on other sites
5 minutes ago, Bad Mac said:

which VST3 insrument works and i will get it and try it. perhaps i have something wrong with my latest version of cakewalk.

 

Either way, i cannot get VST3 synths to work in cakewalk. Any sugestions?

 

Share this post


Link to post
Share on other sites

Here, all my VST3 works just fine.

May be you need to re-scan the VST plugins and make sure first that they are properly installed.

  • Like 1
  • Great Idea 2

Share this post


Link to post
Share on other sites
19 minutes ago, Andres Medina said:

Here, all my VST3 works just fine.

May be you need to re-scan the VST plugins and make sure first that they are properly installed.

again, no specific example!  which ones work? none of mine do.  I have done rescans, reinstalls (a few times), looked thru all the options, menus. done a bunch of stuff.   it would be helpful to have an example of a VST3 synth that actually works. this may help me troubleshoot where the issues is. thanks!

 

please give me a specific VST3 synth that works, i will install and see if it works on my machine. 

Share this post


Link to post
Share on other sites

I had an issue loading some AAS VST3s that was related to their calls to OpenGL to render the GUI that was resolved by updating Nvidia drivers. Have not had a problem with any VST3 before or since.

Share this post


Link to post
Share on other sites
56 minutes ago, Bad Mac said:

Does cakewalk support VST3 Synths / Instuments? 

Yes

I have quite a few VST3 synths installed and they all work.

I just updated Superior Drummer 3 after reading this thread to grab their new VST3 plug-in. It runs just fine.

 

47 minutes ago, Bad Mac said:

All of the VST3 instruments i have do not work.

Could you be more specific?

Do they crash the DAW?

Do they display an error message when loading?

Do they load and not play?

 

Share this post


Link to post
Share on other sites
28 minutes ago, Andres Medina said:

 

scook, i just updated SD3 and have their latest VST3 synth and it does not work. i am getting a crash. the total amount of user interaction to run the SD2 to SD3 update was clicking the "install" button. so what could i have done wrong?  I have uninstalled and reinstalled a couple times with not luck. I re-downloaded and reinstalled again with no luck. i have the latest version of cakewalk i think. you are the first person to verify any particular VST synth that works in cakewalk, thank you!  everyone just says their works fine. and tells me to do the things i have already done. so now that i know that SD3 VST works, i know for a fact that it should work on my machine.

I also purchased EZDrummer3 which only comes in a VST3 version. And it is doing the same thing that SD3 is doing. I have done all the same things, reinstall etc. I went to the toontrack forums and there are lots of people having the same issues in cakewalk. so then i started looking and noticed no VST3 synths work for me. again, they are all installed by clicking and install button in a product manager portal software. so they are installed and cakewalk see them so they show up in the browser. I do not know what else to do at this point. 

they do not work for me. and i am stuck now. don't know what to do.

So i have created a few posts with different title to try to get an answer. so far you have told me that SD3 works. Now i need to know if EZD3 works. Did someone actually get it to work or am i just spinning my wheels on EZD3.

 

 

 

Share this post


Link to post
Share on other sites

Really don't need a thread for each VST3 plug-in.

 

See if the crash generates a minidump,

Here is more info on how to report a crash

 

Share this post


Link to post
Share on other sites
22 minutes ago, scook said:

Yes

I have quite a few VST3 synths installed and they all work fine.

I just updated Superior Drummer 3 after reading this thread to grab their new VST3 plug-in. It runs just fine.

 

Could you be more specific?

Do they crash the DAW?

Do they display an error message when loading?

Do they load and not play?

 

 

Do they crash the DAW?  yes they crash the DAW, after a DUMP error comes up. see pic

Do they display an error message when loading? DUMP error comes up. see pic

Do they load and not play? they do not load

 

all of the greyed out VST3 do not work for me (see pic below)

 

Thank you!!

dump error.PNG

browser pic.PNG

Share this post


Link to post
Share on other sites

The error message is coming from the plug-in NOT the DAW. 

The dump is generated by the plug-in.

Send the dump to Toontrack support.

 

As mentioned in one of your other threads, the colors used in the CbB plug-in browser indicate the plug-in format only.

The colors used are theme dependent.

The VST3 plug-ins are not "greyed out".

The browser does not show "disabled" plug-ins.

Share this post


Link to post
Share on other sites

just curious, when you zoom in on the VST3 icons, it looks like 2 plugs that are not plugged together and greyed out, so i assumed this meant it was broken or not compatible.  the VST2 ones are NOT Greyed out and the icon looks like 2 plugs that are connected, i assumed this mean they are good to go and working properly

so the greyed out are always VST3 and the icon doesn't mean anything? 


Thanks for your help!!

closup.PNG

Share this post


Link to post
Share on other sites
5 minutes ago, scook said:

The error message is coming from the plug-in NOT the DAW. 

The dump is generated by the plug-in.

Send the dump to Toontrack support.

 

As mentioned in one of your other threads, the colors used in the CbB plug-in browser indicate the plug-in format only.

The colors used are theme dependent.

The VST3 plug-ins are not "greyed out".

The browser does not show "disabled" plug-ins.

our posts crossed in the mail. saw this post after i posted my last one.  thank you!! I will contact Toontrrack.

Share this post


Link to post
Share on other sites

In addition to color, different plug-in formats use different icons.

The icon like the color is theme dependent.

The "2 plugs that are not plugged together" show the default VST3 icon.

The other three are show the default VST2 icon.

Share this post


Link to post
Share on other sites

Like I said in your other post, your issue is not Cakewalk, your issue is with the vendor of the plug in. Your obsessing over the plug in icons?? that is just plain weird. We have all told you that is what they look like, that is nothing to do with a plug in not working.

E mail support for the plug ins that are not working it takes a lot less time than you are spending posting here.  I am honestly sorry we really can't help. All those VST 3 plug ins work just fine for the rest of us. I use as many VST 3 plug ins as available from vendors. They are all working great.  

  • Like 1

Share this post


Link to post
Share on other sites

I'm getting a crash on EZD3 also. I submitted a ticket to CBB and Toontracks.

Share this post


Link to post
Share on other sites

All I can offer is sympathy for the OP Bad Mac . . . as I have had an issue for many years with FabFilter ProQ3 VST3, a very mainstream + widely used VST Effect . . . load it up, instant Cakewalk crash out, yep workaround VST2 version works just fine . . . no one has been able to offer help or explain why ? Yes, FabFilter ProQ3 VST3 loads up nicely in my other DAW, which actually BTW sucks in so many ways compared to my Cakewalk. As Bad Mac says  . . . Not everything works, reasons unknown.

Tech support just says re-install, that's all they got.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...