Jump to content
Anders Madsen

Midi keyboard/soft synth lag

Recommended Posts

I got rid of my midikeyboard soft synth lag by pressing "E" and disabling all plugins. (Plus changing windows profile to Power mode)
I still do not understand why it is not enough to disable VST's on the main bus (And common effect bus: Reverb etc.)
How can a heavy VST on say vocal, have any performance effect in regards to keyboard inputs to a software synth?
Totally different channels. Playback is smooth after with ALL vst's activated.
Lag seems to me, a bit 1990s..  :)

Share this post


Link to post
Share on other sites

The usual reason that enabling effects causes a large increase in latency is that one of the effects uses a "look-ahead" buffer. The effect requires so much processing time that it needs to begin to work before the timeline would normally reach the data. Since the effect cannot actually get data from the future, it needs to slow down the rest of the processing and move all of the tracks into the past relative to the look-ahead time. If all of the tracks continued in real time while the effected track was  taking the time it needed, then the effected track would go out of sync and fall behind the rest of the project.  Hence a "compensation delay" has to be introduced into the progress of the timeline so that new data is going to be added later--that is the delay that keeps new input lagging behind real time. Generally speaking, the plugins that use substantial buffers for this purpose are marketed as "mastering plugins," which indicates that they are unsuitable for use in real time tracking. Best advice is to use a less calculation intensive effect (or none at all) until you have finished inputting real time data. You can substitute the slower effect when mixing/mastering, in which case the delay is generally tolerable. 

 

  • Like 5
  • Thanks 1

Share this post


Link to post
Share on other sites

Well said! I experienced this when running a linear phase plugin in my project (which definitely needs a "look ahead" buffer).

A simple workaround in my case was to use the "non linear" mode setting that the plugin offered. Then it is a simple matter to switch the mode setting back later after recording is done and you are ready to mix.

 

Edited by abacab

Share this post


Link to post
Share on other sites
19 hours ago, Moxica said:

I got rid of my midikeyboard soft synth lag by pressing "E"

Really?  From the online help:

Enable/disable the Play List      E

 

Share this post


Link to post
Share on other sites
30 minutes ago, RobertWS said:

Really?  From the online help:

Enable/disable the Play List      E

 

For CbB, look in "Preferences > Keyboard Shortcuts".

You will find that "E" is assigned to "Bypass All Audio Effects".

"E" only enables/disables the playlist when the playlist is in focus. If you minimize the playlist, then "E" controls audio effects.

 

Edited by abacab
  • Like 2

Share this post


Link to post
Share on other sites
On 6/13/2019 at 8:57 PM, Moxica said:

Lag seems to me, a bit 1990s..  :)

That is when Cakewalk was born. And Cakewalk engine as well. It has survived at least untill now, so good it was written... Cakewalk still does the whole processing in real time, the consequences are PDC and heavy resource requirements.

Share this post


Link to post
Share on other sites

I would add that during recording, the ASIO Buffer Size should be kept relatively small - but not so small as to put too much a burden on the CPU, and then when moving on to mixing/mastering, the ASIO Buffer Size should be jacked way up, to give room for the types of effects that add lots of latency - like the Linear Phase or Convolution Reverb effects, to do their thing.

While I could go smaller, I usually run at 128 samples during recording, and then change it to either 1024 or 2048 for mixing/mastering.  Running at 128 samples gives me low enough latency to where the CPU isn't taxed too much, but is still small enough to where I do not experience audible lag during recording.  I may change to 64 samples for recording, just to see if everything still hums along nicely.

Bob Bone

 

Share this post


Link to post
Share on other sites
On 6/14/2019 at 9:21 AM, abacab said:

For CbB, look in "Preferences > Keyboard Shortcuts".

You will find that "E" is assigned to "Bypass All Audio Effects".

"E" only enables/disables the playlist when the playlist is in focus. If you minimize the playlist, then "E" controls audio effects.

 

Maybe your keyboard bindings were customized.  As shipped, that shortcut ain't there.   (Seems like a good shortcut to have though!)

43928645_ScreenHunter101.png.4054c466dc906fb4c9c44907007f4d57.png

Share this post


Link to post
Share on other sites

By default, "E" is the global binding for Bypass All Audio Effects. It is documented here

The image above seems to show the Keyboard Shortcuts preference screen when no project is loaded. Make sure a project is loaded to see the shortcuts like this

vI7whSd.png

Regardless, default bindings do not show in the function list box. The default bindings are listed directly below the key list like the red box and arrow show in this image.

  • Thanks 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...