Jump to content

Recommended Posts

hello! for some reason when i work with midi specifically adding a drumpad to add my samples there is a feedback that really bugs me and the only solution that exists for me is to assign an input from my keyboard midi controller, this error only happens when i use the drumpads and this is my day to day since I make urban music and I really need you to reconsider and fix that problem, thank you I will be eternally grateful.

Share this post


Link to post
Share on other sites
Posted (edited)

I do not work for Cakewalk, but I was wondering about your post.  Are you saying that adding a specific midi device (your drumpad), Cakewalk adds audio feedback (squealing)?  If you mean it creates midi feedback, to me that suggests a routing issue possibly related to midi data being re-sent over and over (aka a midi loop). You seem to be suggesting it is a Cakewalk bug, but perhaps it can be fixed by changing your midi routing or gear settings. 

Now that I think about it, I used to have a drum machine midi loop issue (play a note or pattern and the midi data would be re-sent over and over), but that was a few decades ago.  IIRC the issue was caused by midi out from the hardware going into the software and then midi out from the software going back into the hardware and the hardware resending the incoming midi data. 

Just trying to be helpful. Maybe you ruled the midi loop issue out already?   

Edited by User 905133
to add "and the hardware resending the incoming midi data"
  • Like 1

Share this post


Link to post
Share on other sites

 

10 hours ago, Beraca Music said:

there is a feedback that really bugs me and the only solution that exists for me is to assign an input from my keyboard midi controller

That would be standard operating procedure to avoid receiving input from unintended ports, either physical or virtual (e.g. output from a MIDI-generating drum VSTi). This is not a problem if Input Echo is disabled, but if you have Always Echo Current MIDI Track enabled in preferences, every MIDI/Instrument track needs to have an appropriate port/channel selected for Input.

  • Like 2

Share this post


Link to post
Share on other sites

I was just about to say. I have never come across a feedback from my midi controller | nor | drum machine - with a bunch of other long explanation, but then David said it in a smaller paragraph. 

"Just turn your echo input off." Like bdickens said: It is by design. 

Share this post


Link to post
Share on other sites

I explain better with a video watch this for yourselves here I explain the error

watch it from minute 6 so you can see well

Share this post


Link to post
Share on other sites

I'm not familiar with it, but it appears Poise has a MIDI THRU function, and you need to go to the synth properties for Poise and disable MIDI OUT.  Or set all other track inputs to something other than MIDI Omni as discussed.  This is just how it works.

Share this post


Link to post
Share on other sites

friends please understand it is not the vst, I use other drumpads like sitala, or litle speedrum and all of these give me the same problem, the conclusion I reached was that this only happens to me when I use a drumpad otherwise the problem does not exist, but man it shouldn't create that feedback in any way, I wanted to make it an option to remove MIDI OUT. Or but I don't know how to do it since it is established forever, and not have to do it every time there is a new project

 

Share this post


Link to post
Share on other sites

First of all, unless you need it, you should turn off MIDI Out on the VSTi.  This can be done from the VST2 / VST3  menu on the title bar of the plugin UI window.

If you do use MIDI Out on the VSTi, be selective about which MIDI IN is selected for that track - i.e. don't set it to None or Omni.

If you're using a hardware controller, you should either:

1. Disable the MIDI out to your controller within Cakewalk's MIDI devices, or
2. Turn "local off" on the controller, and use MIDI echo in Cakewalk, or
3. Leave the controller as is, and turn MIDI echo off within Cakewalk.

Which option you choose depends on a number of factors, but unless you need Cakewalk to output MIDI to your controller, option 1 is the easiest.

Share this post


Link to post
Share on other sites
Posted (edited)

Videos #2 and #12 cover proper Midi set up and explain how to avoid Midi loop back 

 

 

Edited by John Vere
  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...