Jump to content
Chance K

Lost connection to MIDI keyboard

Recommended Posts

This has been an ongoing problem for many years through many versions of the program, (currently running latest Bandlab). Periodically I will lose MIDI connectivity. The drivers are still shown and checked in the settings dialog. Playing a MIDI sequence works fine. I can even trigger MIDI by mouse clicking on the virtual keyboard in a VST. But  playing the keys on my keyboard triggers no MIDI. I'm using a NI S49. The little Sonar keyboard in the Windows tray is not blinking.

Usually someway, somehow I will get MIDI working. At this time, i'm out of ideas and ready to throw my rig out the window. I've tried reinstalling the keyboard drivers, rebooting my PC, switching the MIDI input between my keyboard driver, All Inputs, Omni and None. All to no avail. Does anyone know how to fix this?

NOTE: Everything works fine in Ableton, so this does appear to be a Cakewalk problem.

 

 

Edited by D Chance Gold

Share this post


Link to post
Share on other sites

Check your MIDI driver mode:

image.png.bfa909a49e3d05429267448fda2de753.png

If you've got it set to UWP rather than MME, that might be the issue. Not all MIDI devices support UWP, but pretty much all of them support MME.

  • Like 1

Share this post


Link to post
Share on other sites

One thing you might like to check is head to Device Manager and expand "Universal serial bus controllers". 

Right click on all devices that has "Root Hub" and then select properties.  Head to the power management tab deselect "Allow the computer to turn off this device to save power"

Do this for all devices that has "Root Hub" in the devices name.

This may help.

Share this post


Link to post
Share on other sites

I had MME selected in Settings and all of the Root Hubs in Device Manager already had that option deselected. 

ATM I'm back in business after unplugging the S49's USB cable and reconnecting it, which I tried before without luck. I hope I don't have this problem again, but...

Share this post


Link to post
Share on other sites

FYI - I have had, in the past, Windows Update updates reset the USB Selective Suspend option in the Advanced Power Plan Options, so it is worth checking to see if that has gotten reset - don't know if this applies to the settings on individual Driver Management hub entries.

One other thing - there are Power Management options for other USB connections, not just Root Hubs, for instance, I have several of these (maybe there is some sort of Intel flavor of these, as well, on Intel-based computers):

"AMD USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)" - I don't know what connects to them, but I also made sure these too all had the Power Management selective suspend option unchecked, as well.

Bob Bone

Share this post


Link to post
Share on other sites

Have you tried cleaning the USB cable at both end with some 90+% alcohol, contact cleaner  and/or some DeoxIT?  Also leave the cord connectors wet with the cleaner/Detoxify and plug and unplug them a few times to clean out the port contacts.

Share this post


Link to post
Share on other sites

Couple of things I found worked for me when my M-Audio Keystation 88 Pro used to lose connection.

1. Make sure it was the only USB device connected to a USB hub, I did this by never connecting to a USB port next to another USB port on my PC.

2. You could try rebuilding TTSSEQ.INI this file is located in C:\Users\{YOUR USERNAME}\AppData\Roaming\Cakewalk\Cakewalk Core.  Either delete or rename the file to TTSSEQ.INI.OLD, CbB will rebuild the file based on connected and enabled hardware on restart, so make sure all your USB devices need for CbB are turned on before starting CbB.

Once I moved the keyboard to the new  USB port and rebuilt TTSSEQ.INI the keyboard no longer lost connection. 

Share this post


Link to post
Share on other sites

Well that didn't last long, MIDI connectivity lost again.

USB Selective Suspend is disabled. 

None of the other USB connections in my Device Mgr have the power management option.

I don't think the cable is the issue, I've tried swapping cables, and Bandlab does see the keyboard drivers.

I have too many USB devices to plug the S49 into a port that doesn't have anything plugged into an adjacent port. But I did get MIDI connectivity back after deleting TTSSEQ.INI, so thanks for that tip! We'll see how long it lasts and I'll try it again if it goes out.

Share this post


Link to post
Share on other sites

I have to delete TTSSEQ.ini every time I open Cakewalk(or Sonar Platinum for that matter). This started happening after one of the last few Sonar updates...probably a Win10 "fix" that screws with my Win 7 Ultimate system. I'm used to it now but it's still annoying.

Bill

Share this post


Link to post
Share on other sites

Hi. The same goes for win7 Pro after last updated 2019.12 (Build 26, 64bit).

It's a Roland A49 keyboard. With Cakewalk Artist it works, but there in MIDI/Playback and Recording, there is no MME or DRIVER MIDI. Obviously the matter is MME.

Nor by renaming or deleting TTSSEQ I have managed to solve. Any ideas?

Happy new year!!

Share this post


Link to post
Share on other sites

If you go into Device Manager, then click on View > Show Hidden Devices, and expand the Sound, Video, and Game Controllers category, if you have multiple drivers for your midi controller/keyboard, where there is one entry that is darker than the duplicate ones (like those would show a fainter gray color), then that means you have what are commonly called 'ghost entries', and what that is evidence of, is that your device drivers for that midi controller were at one time plugged into a different USB port. 

SO, those ghost entries are showing you that there are drivers from other USB ports, but they are not currently active.  When the USB port mapping changes for an audio interface or midi controller, Windows creates a new internal association between the device and the USB port, and because all you see, in both Cakewalk and in Device Manager, is the NAME given to that device, you cannot readily tell that its internal association to a USB port has changed.

When the above occurs, even though you see the device in Preferences > Midi > Devices, it really is not mapped to the current Windows internal association to the new USB port, and so Cakewalk won't detect any midi activity for that midi controller.

I do not have a foolproof resolution to the above, if that is what has happened on your system, but what I end up doing is the following, and please note that I have to keep doing this whenever I open up an existing project, because those projects were saved using the old and invalid internal association between the midi controller and the old USB port:

01) Open project

02) Go to Edit > Preferences > MIDI > Devices

03) Remove the midi controller from Inputs and the Outputs sections, by removing the X from the check boxes for that midi controller, and click Apply

04) Save project and close it

05) Open the project again

06) Go to Edit > Preferences > MIDI > Devices

07) Declare the midi controller again as a valid Input and Output midi device, and click Apply, and exit Preferences

08) Immediately save the project, so that it has the above changes saved.  You should be OK now

 

The above is what I worked out to fix the condition of a USB port mapping for my midi controller having internally changed

Bob Bone

 

  • Thanks 2

Share this post


Link to post
Share on other sites

I also had this problem with one of my midi keyboards, I followed your steps 1-8 and now it works.

Thanks a lot Bob.

  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks Bob. It has worked by following in your steps, although changing usb port.

Good weekend. Greetings.

Edited by Antonio Nero
  • Like 1

Share this post


Link to post
Share on other sites

For me, this is almost always caused by cakewalk having the midi mapped to a controller in preferences.

If you have a midi controller... Then unplug the controller... Cakewalk will assign the next midi input to that controller on cakewalk restart. This prevents you from using that input for a midi track but not from selecting that input on the midi track. Additionally, it separates you in time from the triggering change, making it harder to associate the action with the outcome.

Personally, i think this is a use-case-bug. Perhaps not an actual programming mistake, but a use-case that stymies users from success using cakewalk. 

When a user attempts to record midi routed to a controller, the user should get a warning like when a bus is routed to an output that doesn't exist.

I find it necessary to delete controllers in preferences when they are not plugged in or leave them plugged in. It is a bit of a pain. Every time i plug in my controller, there is a bit of configuration i must repeat.

Edited by Gswitz

Share this post


Link to post
Share on other sites
5 hours ago, Gswitz said:

For me, this is almost always caused by cakewalk having the midi mapped to a controller in preferences.

If you have a midi controller... Then unplug the controller... Cakewalk will assign the next midi input to that controller on cakewalk restart. This prevents you from using that input for a midi track but not from selecting that input on the midi track. Additionally, it separates you in time from the triggering change, making it harder to associate the action with the outcome.

Personally, i think this is a use-case-bug. Perhaps not an actual programming mistake, but a use-case that stymies users from success using cakewalk. 

When a user attempts to record midi routed to a controller, the user should get a warning like when a bus is routed to an output that doesn't exist.

I find it necessary to delete controllers in preferences when they are not plugged in or leave them plugged in. It is a bit of a pain. Every time i plug in my controller, there is a bit of configuration i must repeat.

Exactly why I continue to seek a permanent solution, so I don't have to keep going through deletion and adding the controller back in, for every existing project.

Bob Bone

  • Like 1

Share this post


Link to post
Share on other sites

I've had the same problem and just ran into it again during a session last week. The messed up part was, my Yamaha P115 was totally working in Ableton Live on the same machine, driver showed up properly in Cakewalk but there was nothing coming in Midi wise.

I can always get it to work again by either reinstalling the Yamaha USB-Midi driver, or sometimes I have to go into Device Manager and clear out all the "hidden" ghosted midi devices and then reinstall.

 

Again, the bizarre part is that in Ableton Live I do NOT have this problem!

 

R

Share this post


Link to post
Share on other sites
2 hours ago, Rico Belled said:

Again, the bizarre part is that in Ableton Live I do NOT have this problem!

@Rico Belled Right! I think the problem is being driven by a failure to understand that your midi input is being bound to a controller by default because you have a controller specified and the original midi input for that controller is not available. In this case, Cakewalk binds a different midi input to that controller and doesn't tell you. I don't think it even impacts the project until you close the Cakewalk and re-open it, making it hard to know the cause. 

From Cakewalk's perspective, it's working as expected.

I challenge whether it SHOULD work that way.

For me, if the midi input I selected for controller is not available, I don't want Cakewalk to use on of my other midi inputs for it. They aren't controllers. 🙂

Share this post


Link to post
Share on other sites
8 minutes ago, Gswitz said:

@Rico Belled Right! I think the problem is being driven by a failure to understand that your midi input is being bound to a controller by default because you have a controller specified and the original midi input for that controller is not available. In this case, Cakewalk binds a different midi input to that controller and doesn't tell you. I don't think it even impacts the project until you close the Cakewalk and re-open it, making it hard to know the cause. 

From Cakewalk's perspective, it's working as expected.

I challenge whether it SHOULD work that way.

For me, if the midi input I selected for controller is not available, I don't want Cakewalk to use on of my other midi inputs for it. They aren't controllers. 🙂

Except it's not! I specifically will choose the correct input Midi port, set the channels and everything and there's NOTHING!

Share this post


Link to post
Share on other sites
22 minutes ago, Rico Belled said:

Except it's not! I specifically will choose the correct input Midi port, set the channels and everything and there's NOTHING!

Ah, gotcha.

That's different. I haven't had that particular problem. I'm sorry.

I can sympathize that it's frustrating when you can't get a midi signal and it's Cakewalk's fault. You do a lot of unrelated troubleshooting before you id Cakewalk as the offender.

Share this post


Link to post
Share on other sites

Yeah, it is because things have changed internally for the midi controller, but we cannot see this has occurred.

The only fix I know, is to do the steps as I laid out. Does not mean those ARE the steps, just means those are the ones I have been able to get past the issue.

I WELCOME someone giving me better steps.

Bob Bone 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...