Jump to content
Tubeydude

Crashing on project open, A LOT.

Recommended Posts

So I've been an avid cakewalk SONAR used since Sonar 4.  One of the things I have always told people that I love about SONAR is how it hardly EVER crashes.  Well, last night during our weekly recording session it crashed 4 times when attempting to open a project.  It then came up with a fatal error and asked if I would like cakewalk to attempt to save the data.  I said no because I don't want to risk corrupting anything.  It crashed again.  No biggie, I thought.  I'll open it in SPLAT.  That now crashed too.  I think I have had maybe 2 crashes of SPLAT in the 2 years I have been using it.  This happened on 3 different projects.

This is frustrating.  Any ideas?

I have a music only computer (made by studio cat... has been running perfectly for about 4 years) running an i7 processor, windows 8.1, updated as of a couple months ago.  It is only connected to the net long enough to do either windows updates or daw/ vst updates.  Running the latest version of cakewalk 5/2019.

Also, when I tried launching the bandlab assistant to do the latest update, I would just get a white rectangle and nothing more.  I opened task manager and found 4 instances of the assistant running.  After ending those, I was able to open the assistant again, but had to re log in.

Thanks

 

 

Share this post


Link to post
Share on other sites

I just checked windows update and there are 4 updates loading now.  We'll see if that helps.  It was last updated 5/2/19.

Share this post


Link to post
Share on other sites

So windows update did not help.  Though now when it crashed it told me that it was one of my VSTs.  Crunchesser from Voxengo.  I opened the project in safe mode and deleted it and it works.

In the meantime, I found a thread about jbridge.  Is it worth installing that instead of using the native wrapper?

I occasionally get "Teleport server has stopped working" when I exit either SPLAT or CbB.  I was told that was the native vst wrapper barfing.  I still have some legacy 32 bit plugs and I am now on a 64 bit OS.

Share this post


Link to post
Share on other sites

JBridge is definitely worth getting if you use 32 bit plugins. There's far more options to tweak for compatibility, but even aside from that, it's much more stable than BitBridge.

Share this post


Link to post
Share on other sites

Thanks,  do I need to run it first outside of the DAW to make it the default wrapper?  Or do I have to click the "use jbridge" option in the plug in manager for each vst that needs it. 

I know that is probably a basic question, but this is the first Ive heard of jbridge... 

Thanks!

Share this post


Link to post
Share on other sites
24 minutes ago, Tubeydude said:

Thanks,  do I need to run it first outside of the DAW to make it the default wrapper?  Or do I have to click the "use jbridge" option in the plug in manager for each vst that needs it. 

I know that is probably a basic question, but this is the first Ive heard of jbridge... 

Thanks!

Definitely use the "use jbridge" option in the plugin manager.

If you use jbridger to create separate wrapper DLL's, they end up with new plugin id's.

The Cakewalk "use jbridge" option allows you to easily swap back and forth between JBridge and BitBridge without it thinking its a different plugin.

It's also a lot less hassle than using jbridger.

Share this post


Link to post
Share on other sites
41 minutes ago, Tubeydude said:

I still have some legacy 32 bit plugs

It's not too late to stop using them. The support for 32bit plug-ins is unlikely to improve.

Share this post


Link to post
Share on other sites

Yeah, my newer project typically only use the vst3 or 64 bit plugs.  However, when I open an older project to show somebody, or work on it, it would be nice if I didn't have to go safe mode and delete the errant plug.  At least I'm not using dx plugs.   :)

 

  • Haha 1

Share this post


Link to post
Share on other sites
On 6/6/2019 at 9:22 AM, Tubeydude said:

Also, when I tried launching the bandlab assistant to do the latest update, I would just get a white rectangle and nothing more.  I opened task manager and found 4 instances of the assistant running.  After ending those, I was able to open the assistant again, but had to re log in.

Thanks

 

 

When I have had this issue it seems to be that my broadband connection has flaked out for whatever reason (modem hiccups?).  I think both Bandlab and Cakewalk "phone home" somehow and if the connection isn't there, it freezes.  I know, I know we've been told it is possible to work offline but.... experience says otherwise.

Share this post


Link to post
Share on other sites

I have a hatred for using 32 bit plugins in 64 bit OS/DAW  system, go all 64 bit, you won't regret it. Personally, I wish they would remove the native bridge from Cakewalk and make it 64 bit only. Other DAW's have done this and people adjusted to it.

Other DAW's that use native bridges have the same problem, barely a week goes by without a few complaints on their forums about instability or crashing that is inevitably traced back to using some (usually really old) 32 bit plugin in a 64 bit DAW.

Just replace them with the 64 bit version in your old projects, as Pwalpwal has pointed out there is a 64 bit version available for Crunchesser. If you cant replace them, find a similar 64 bit plugin and live with it.

Edited by Tezza

Share this post


Link to post
Share on other sites

Update.  Jbridge seems to have solved the issue.  I was using the latest version of Crunchessor as well.  Re-scanning and re-inserting the VST seems to have solved that aspect. 

I will replace the 32 bit plugs as I go along.

I keep my machine off the net, unless I am downloading updates.  I guess I'll have to kill bandlab assistant in task manager each time before I go to update, so I can start it with an internet connection.

Thanks all!

 

Share this post


Link to post
Share on other sites

There is no reason to run BA when not connected to the internet. There is an option in the BA Settings for "Launch on startup," If this is off, BA will not start automatically. Then run BA when needed.

There is no reason to kill BA using the Windows Task Manager. "X"ing out of the UI does not shut down the program, it just kills the UI. The program still runs in background. The "Quit" button on the BA settings screen actually shuts down the program.

Click the gear in the upper left of the BA UI to open the Settings page.

  • Like 1
  • Great Idea 1

Share this post


Link to post
Share on other sites

I will try turning off auto start.

Killing it in task manager was my only option.  The UI came up as just a white, vertically oriented rectangle, with no graphics or link, or anything other than white.  This is after I had established an internet connection.

There was not even an option to close the UI as there was no X in the upper right of the UI.

Opening task manager showed the application running.  Killing that (assuming that was just the UI) did make the window go away.  However when re-starting BA the white box is all I got.  In task manager I saw three instances of BA running under processes.  Killing the application, and all three processes is what finally allowed the proper UI to load.

I only ever run BA when connected to the net.  I agree, there is no reason to run BA is there is no internet connection. 

Share this post


Link to post
Share on other sites

Yeah, don't use 32-bit plugins. The time for them has long since passed, and better 64 bit versions have already replaced them comprehensively. I've had the same issue when digging up old projects from the vault, and Cakewalk keeps crashing as a result due to using plugins like SFZ+ Professional (Replaced by Plogue Sforzando and Roland SCVA) and Cakewalk AmpSim (Replaced with TH3 and Amplitube 4).

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...