Jump to content
  • 0
aleo

Problem with Piano Roll Snap To

Question

When adjusting the positions of notes in PRV using only the global Snap To settings in the Control Bar (PRV Snap To off) everything works fine and notes snap to their proper position according to the resolution set on the Control Bar.   However, if I then turn on PRV Snap To and set a different resolution some of the notes jump when you try to move them with either the Move tool or the Smart tool and as you try to slide them with the mouse, they avoid the vertical line of the resolution level set and settle at a point several milliseconds either before or behind the line.  I tried testing PRV Snap To with several simple MIDI projects where I would play and record a simple melody of about six or eight quarter notes a little off beat.  Next turn on Global Snap To, set the note resolution to a quarter note.  All of the off-beat notes were easily moved to their correct position--Snap To worked.  Next, turn on PRV Snap To and set resolution to Measure.  Some notes now jump when you try to move them and won't settle exactly on the measure line.  For example, when I tried to move a note to 3:01:000 it settled at 2:04:953 and couldn't be moved any closer, unless Snap To was turned off. 

I'm currently using CbB v. 2022.02.  I don't think I've encountered this problem in any of the previous versions.  Please advise.

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0
Posted (edited)

Snap 'By' instead of 'To' enabled for PRV snap?

Or the Snap to MIDI Events button is enabled?

Edited by David Baay
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 1

Its definitely snap to. What you can do is: Within the PRV, locate the View tab, scroll down to Grid Resolution and set it to FOLLOW SNAP SETTINGS. This will give you a more accurate snap setting every time you change the global snap in the PRV. 

The snap setting you see next to tracks are the note lengths to draw in. 

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Funny you mentioned this as I had this happen yesterday as well. I just turned off the PVR snap option and the notes I drew follow the Control bar setting. Bug?  I realize I never have used the PVR option in the past. 

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

I've seen this behavior in Sonar as well. I find it best to turn PRV Snap off and just use Global Snap.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Everyone, thanks so much for your responses and suggestions.  Will, I especially appreciated your visual aid and suggestion about setting Follow Snap Settings in PRV.  I think we are all in agreement that there is some kind of glitch in Piano Roll Snap and it could go back a ways--I can't remember the last time I used this feature.  Hopefully, the Bakers will get it straightened out in a future update :)

 

Share this post


Link to post
Share on other sites
  • 0

I don't see any glitches or issues here. It works as it should my side.

Share this post


Link to post
Share on other sites
  • 0

Thanks Will. Once again a setting you forget about and it is per project not global,  so easy to miss. 

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, aleo said:

I think we are all in agreement that there is some kind of glitch in Piano Roll Snap and it could go back a ways--I can't remember the last time I used this feature.

Actually, no. I use it all the time and have not seen unexpected behavior for a long time except when settings were not right for what I wanted to do - i.e. user error.

There were some issues within the first couple years of its introduction  (back when major releases were only annual) but so far as I know everything has been ironed out at this point.

I'd be really interested to see a copy of a project that isn't working as expected.

Share this post


Link to post
Share on other sites
  • 0

I stand corrected!  and David's suggestion lead me to my error.  I went back to my test project and discovered that in PRV Snap when you set the note duration, at the top of that tall white rectangle of note values you also need to make sure you check Snap To if that is the way you want to move the notes.  I thought it was set to Snap To, but it was set to Snap By.   Once I made that change, everything worked fine.  You have to keep in mind that the Snap mode you've set in the Control Bar (global Snap) is independent of what it is set to in PRV Snap.

Again, I want to thank everyone for their help.  I will sleep contentedly tonight knowing that all is well in Cakewalk World 😌. . .  i think.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Good deal. I should have made it clear where the PRV-specific To/By setting is; it's a bit hidden.  Cakewalk is so deep it's really easy to overlook things like this, but I try to trust the software and question myself first when something  unexpected happens.

  • Thanks 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...