Jump to content
  • 0
sjoens

[SOLVED] MIDI Outboard Synth Issue

Question

A project has 8 MIDI tracks output to my synth's onboard 8 track sequencer.

Each synth track is assigned a sequential MIDI channel (1-8).

Each DAW track is assigned to the same MIDI channel with it's own voice.

When I hit PLAY, the DAW:

 1. Sends a random note at the beginning that shouldn't be there.

 2. Changes current synth screen voice to track 4's voice and plays it on all tracks.

When I hit STOP the random note plays indefinitely.

 

What am I doing wrong?

Edited by sjoens

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

First, double-check the synth settings. If any (or all) of the synth's voices are set to omni, that could account for the strange behavior. Each voice would play correctly when soloed but interfere with one another when played concurrently.

If that part checks out,  then we have to assume that the synth is receiving unexpected data. Go to the List View and look at the early events there. I know, you've already done this, but you may have missed something.  Problem events don't always stand out at first glance. Make sure you enable all classes of events, including RPNs, NRPNs and SysEx. Try experimentally deleting all of the first measure's events and see if the symptoms change. If it does, then you know you have to zero in on that portion of the event list, perhaps deleting individual events until you identify the one that was causing you grief.

Is this project an original composition or a MIDI file you obtained elsewhere? 

Share this post


Link to post
Share on other sites
  • 0

What OS are you using.  Is your OS fully patched? What USB to MIDI interface are you using?  Are you using the latest driver for it. Are you using a USB port directly on your PC and not a USB hub.  If using Windows 10, have you tried different MIDI modes (MINE and UWP)?

Also, on a MIDI project , select all and then use event list to make sure there are no stray events therein.  Do your start notes and events start bang on 1:0:0 or do you have a "lead-in" measure before the events start.  Does your project initialise patches for each track? - some MIDI hardware needs time to respond to these patches before sending other events.  Do you have any initialisation strings set as sysex data.

Share this post


Link to post
Share on other sites
  • 0

Yes, yes, yes, dunno, & wha..?! ;)

I have to use a lead in as starting at 1:1:000 refuses to play the first note - another issue I forgot to mention. 

Instead of playing the synth voices assigned to each track, it changes, and then plays, only the Base Channel voice.

Event View shows nothing odd.

Once upon a time this just worked. Now it doesn't. Maybe the synth (90's pre GM) is just too old to handle it or I am. :S

AAR, I found a tedious workarond where I play & record each track separately and soloed so whichever device having the problem ignores the problem. 

Edited by sjoens

Share this post


Link to post
Share on other sites
  • 0

What MIDI interface are you using?

I've found the cheaper USB to MIDI cables are extremely problematic. The reason being is that their internal buffer size is extremely small, so if they're overloaded with MIDI data they drop notes... and for sysex, they are totally useless.

Bear in mind also that at 1:1:000 any program changes, CC settings (pan, volume etc) are being sent all at once.  Maybe moving the start of your song to 2:1:000 might help.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
On 1/4/2019 at 8:26 AM, msmcleod said:

What MIDI interface are you using?

I've found the cheaper USB to MIDI cables are extremely problematic. The reason being is that their internal buffer size is extremely small, so if they're overloaded with MIDI data they drop notes... and for sysex, they are totally useless.

Bear in mind also that at 1:1:000 any program changes, CC settings (pan, volume etc) are being sent all at once.  Maybe moving the start of your song to 2:1:000 might help.

I generally start my work at 2:1:000 for that reason. That first "empty" measure gives the computer and synth time to run all the initial messages needed.

Share this post


Link to post
Share on other sites
  • 0

Good catch, bit. All track & voice settings were good but the synth's global MIDI Mode was OMNI. 🙄 Set it to MULTI and all's good now.

Thanks everyone for all the tips.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...