Jump to content
  • 0
Lee Durley

Keying latentcy

Question

I have used Cakewalk for many years until my computer crashed and when I downloaded the Bandlab version, this keying delay is a major issue. I tried the buffer suggestions with no change. Is there a definitive way to address it or do I need to try some other software? Any help would be appreciated.

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

- What keyboard, and how is it connected (USB or MIDI DIN)?

- What sound source (VSTi,  hardware module, keyboard synth or - heaven forbid - onboard GS Wavetable synth)?

- What audio interface, driver mode and buffer size?

 

Share this post


Link to post
Share on other sites
  • 0

My PC is configured as per my signature and I do not have any noticeable key delay.

We need more information (Like what David has asked for above)

Share this post


Link to post
Share on other sites
  • 0

Normally this is indicative of an ASIO buffer size that is too high, but it could also be down to a MIDI feedback loop within your virtual instruments.

Make sure that the MIDI output of any VSTi's is disabled if you're not using it:

image.png.ec42832bd55da85e76616036d169438f.png
 

Share this post


Link to post
Share on other sites
  • 0

I have the same problem all of a sudden.  MOTU M2 interface, Play VSTs as well as Dimension (same issue with both), Impact GX61 keyboard connected via USB. Everything was fine, but a number of things have crept in like this delay in responding to keyboard triggers.  I've adjusted buffers, switched to WDM and then back to ASIO so it would re-profile. What else should I try?

 

image.thumb.png.5e8ed038a1be432655f50a2da2b7b301.png

Share this post


Link to post
Share on other sites
  • 0
13 minutes ago, David Pollock said:

I have the same problem all of a sudden.  MOTU M2 interface, Play VSTs as well as Dimension (same issue with both), Impact GX61 keyboard connected via USB. Everything was fine, but a number of things have crept in like this delay in responding to keyboard triggers.

There are two sources of "MIDI" latency and neither has anything to do with MIDI

  • audio buffer size
  • plug-in delay compensation

If running the minimum usable ASIO buffer, try bypassing all FX using the FX button in the Mix Module. If the latency goes away, the problem is PDC. Either bypass, freeze (or bounce and archive) the plug-ins that need PDC or use the PDC button in the Mix Module for live input PDC override 

12 minutes ago, David Pollock said:

I've adjusted buffers, switched to WDM and then back to ASIO so it would re-profile. What else should I try?

This is meaningless if running in ASIO driver mode. Profiling is only useful for modes other than ASIO.

Share this post


Link to post
Share on other sites
  • 0

Thanks scook. Disabling FX made the latency disappear. But using the PDC button does not fix it, and since I am still creating, I don't want to bounce and archive unless I misunderstand what you mean.

As best I can tell, there are two plugins contributing to this: LP-EQ and TS-64 transient shaper. 

So even though I have a pretty able system, I cannot run these live?

Windows 10

Intel(R) Core(TM) i9-10900K CPU @ 3.70GHz   3.70 GHz

128 GB RAM

 

Share this post


Link to post
Share on other sites
  • 0

Another little detail in case this means something. Enabling the PDC button solves the latency problem when the transient shaper is enabled, but not the LP-EQ. I have to disable the EQ to stop the problem. All other effects are fine.

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, David Pollock said:

So even though I have a pretty able system, I cannot run these live?

All the power and stability in the world does not matter.

Some plug-ins must see into the future in order to react to in a timely manner.

From page 19 of the LP-EQ manual

Quote

Precision

Higher settings produce the best sound quality with less artifacts, but increase latency. The options are as follows:

  • Non Linear. Non linear phase processing. Use during recording in order to reduce latency.
  • Low. Linear phase processing with low latency and the most artifacts.
  • Medium. (Default) Linear phase processing with medium latency and artifacts.
  • High. Linear phase processing with the best sound quality, but the highest latency.

From the TS-64 documentation

Quote

Latency & automation

The TS‑64 Transient Shaper is designed primarily for mastering/post-production, and not for use as a live insert. The plug-in requires a fairly high plug-in latency (about 200ms) that needs to be compensated for by the host application. This latency/look-ahead is required by the plug-in to examine the input audio, detect transients and gather information about their nature, before applying the appropriate gain and filter curves.

TS‑64 Transient Shaper is fully automatable, with smooth, zipperless output.

 

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, David Pollock said:

Disabling FX made the latency disappear. But using the PDC button does not fix it

PDC [Override] can only work on audio/instrument tracks whose output path does not go through the PDC-inducing plugin. If the FX is on the track you're monitoring or on a bus in that track's path to Main Outs, there's no way to bypass the delay with the FX active.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...