Jump to content
  • 0
Paul Sager

Removing MIDI volume

Question

I record multiple MIDI tracks  all set to channel 8,  with various percussions sounds across the keyboard, when performed on the channel 8 track of my Montage. I then save the project as MIDI Format 0, then import it into the Montage, to which we perform live.  Thus, the result is a single MIDI track on channel 8. 

The problem is, the resulting .mid file retains the initial volume of whichever track has the highest volume set. So when I start the song on the Montage, it always sets the volume on track 8 to that initial volume, regardless of how I try to set it directly in the Montage. (I can override once the song is started, but that is unacceptable)

The Montage does not provide a way for me to directly edit the MIDI data. But there is some mechanism in Cakewalk whereby I can remove all volume data from the project. But it has been too many years, and I don't remember how to do that.

So my question is, does anyone still know how to strip all MIDI volume data from the resulting midi file?

 

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Not sure what your Montage is plays. But creating midi files for playback on most systems is normally done using the GM ( general Midi) standard and you would use a different channel for each instrument. The song will play exactly like it does in Cakewalk using the TTS-1 as example. 

If you are only trying to create a drum track then there would be no volume involved for each drum part. Volume only controls one intrument at a time.  Look in the event list to see if you inadvertently added a volume event cc 7 or ?  You use Velocity to balance those parts if all are using the same channel. The default GM drum channel is 10. 

Edited by John Vere

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Paul Sager said:

So my question is, does anyone still know how to strip all MIDI volume data from the resulting midi file?

Usually Volume is controlled by CC7 - so you can start with looking for those events  - either using the PRV or the event list view.

Sometimes CC11 is used as well.....  but CC7 would usually override that.

Share this post


Link to post
Share on other sites
  • 0

I think I can be more clear with my question.

When I open the resulting .MID file, all of the data is now in one track, Track 8, on MIDI channel 8. (no need to discuss here why I don't use GM or ch10). I remove all Controller codes from the Event List.  Let's say I set Cakewalk track 8 to volume 110 (still no controller codes in the Event List), but I set the Montage track/channel 8 to 84. Cakewalk is connect to Montage through USB. I hit Play in Cakewalk. Cakewalk immediately sends the volume control of 110 before sending my event list, thus overriding my volume of 84. So likewise when I save that .MID file, and load it into the Montage, it leads with that volume setting, even though it is not in the event list while editing in Cakewalk.

There is some way to tell Cakewalk to ignore the track volume setting at the beginning of the song. (It's just been too many years for me to remember how).

 

Share this post


Link to post
Share on other sites
  • 0

I believe what you are asking about is the GeneralMidiSMFs setting in TTSSEQ.ini.

It defaults to 0 but in this case, it should be 1 so the setup events are visible in the Event List view.

Edit "%appdata%/Cakewalk/Cakewalk Core/TTSSEQ.ini" to make the change.

Share this post


Link to post
Share on other sites
  • 0

You might also need to right-click the Volume widget in each MIDI track, and choose 'Disable' to prevent Cakewalk writing the value to the MIDI file regardless of whether anything is shown in the Event List. This also happens at playback; Cakewalk sends CC7 with the specified value from each track before starting playback. If more than one track is assigned to the same output channel, the setting of the last (i.e. highest numbered) track with an active Volume widget will pertain. The same goes for the Pan widget (CC10). Disabled controls will show parens around the value. The default if the control has never been touched is (101).

  • Great Idea 1

Share this post


Link to post
Share on other sites
  • 0

Thank you David and scook. I bet one or both of those will do it. 

I may not have a chance to try it now, the rest of this week. But I copied your responses into a more permanent document I can refer to later.

Thanks again

Share this post


Link to post
Share on other sites
  • 0

Please return when possible and post your findings

thanks

Share this post


Link to post
Share on other sites
  • 0

Yes, when I Right-Click: Disable Control, to all of the tracks, it no longer sends the initial Volume event. And likewise when I save as .MID and import into Montage, it no longer overrides the track volume.  Thank you

(FWIW, I am using Sonar 8. I installed the latest Cakewalk, but too much has changed, for doing last minute tweaks just before a gig.)

scook: Neither the Sonar nor Cakewalk Core TSSSEQ.ini had the GeneralMidiSMFs setting. I threw in GeneralMidiSMFs=1, saved and restarted Sonar, and I still did not find anything but Notes in the Event List. Did I not understand? No matter, the other works for me.  

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...