Jump to content
Sign in to follow this  
norfolkmastering

Soft Synth sound output fails during session

Recommended Posts

I have started to use soft synths for the first time in Cakewalk.  Mostly Session Drummer 3.

I have no problem inserting an instance of Session Drummer 3 and loading a drum program.  I hit a drum and I can hear the audio output.  I can record MIDI sequences and play them back.

However, I have found that at random times during the session, my Session Drummer output (whether it is being replayed from recorded MIDI or played 'live') suddenly loses its audio out.  I can see that the drum program is still loaded and if e.g. I hit the bass drum, then I see the drum bring hit ...  but no audio output!  The only solution is to reload the drum program which brings back the audio but of course I lose all my settings.

I have had the same problem with other soft synths so it is not particular to Session Drummer 3.

Does anyone know if this is a know issue and whether there is a way to avoid this happening?

Share this post


Link to post
Share on other sites

The most common cause is the synth encountering unexpected data. This can happen with any of the Cakewalk sfz engine synths. To address the problem see

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Okay I reviewed the drum track which failed using the Event List View.  100% note events.

Anything else I can check or is there a diagnostic dump I could send to Bandlab next time it fails?

Share this post


Link to post
Share on other sites

Finally I found an old thread which details the bug which is causing the problem.

Sometimes the currently selected 'soft synth' track gets into a state where it is impossible to turn off the input echo button.  Once this happens, it doesn't matter whether you select another track.  The track which gets stuck, stays stuck.  Reloading the instrument on the 'stuck' track is the only way to get the soft synth output to work again.

The solution mentioned in the old thread is to go to Preferences/MIDI/Playback and Recording and untick the 'Always Echo Current MIDI Track' box.  This fixes the issue.

So it is an old bug which has never been fixed.

The old thread is http://forum.cakewalk.com/Input-Echo-button-stays-on-m3565851.aspx

What's the best way to bring this to the development team's attention?

Share this post


Link to post
Share on other sites
5 hours ago, norfolkmastering said:

Finally I found an old thread which details the bug which is causing the problem.

Sometimes the currently selected 'soft synth' track gets into a state where it is impossible to turn off the input echo button.  Once this happens, it doesn't matter whether you select another track.  The track which gets stuck, stays stuck.  Reloading the instrument on the 'stuck' track is the only way to get the soft synth output to work again.

The solution mentioned in the old thread is to go to Preferences/MIDI/Playback and Recording and untick the 'Always Echo Current MIDI Track' box.  This fixes the issue.

So it is an old bug which has never been fixed.

The old thread is http://forum.cakewalk.com/Input-Echo-button-stays-on-m3565851.aspx

What's the best way to bring this to the development team's attention?

Make sure your using the most recent version of Cakewalk.  Create a minimial project that reproduces your issue, share it via a cloud drive (like icloud, google drive, one drive etc.) Them submit a support ticket using "support@cakewalk.com" explaining your issue and share the link to your project in the email.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...