Jump to content
Sign in to follow this  
Anders Madsen

Replace synth does not update title/name

Recommended Posts

I right click the midi/synth track and choose "Replace synth.." Pick another, and wait for new synth to load.
I does, but the former synth name is still there.

Edited by Anders Madsen

Share this post


Link to post
Share on other sites

Only if you change the synth name in Track View before replacing. However, the Synth Rack will reflect the change either way.

Would be nice if they both updated the same.

Sonar X2 exhibits the same behavior so it's been happening for awhile now.

If this is ever fixed, would be cool to have the Replace Synth option added to the Synth Rack.

Edited by sjoens

Share this post


Link to post
Share on other sites

I did a little digging on this.  If the track is a simple instrument track then the text field does not get updated by "Replace synth" if it has been edited.  However, if you are using split tracks for synths then text field for both tracks get updated regardless of whether they have been edited or not. I suspect this may be by design.

Steve

 

Share this post


Link to post
Share on other sites

Strange. I get the no-change on both simple and split synth tracks when editing the name. 

Share this post


Link to post
Share on other sites

Digging deeper ..... (I'm fairly sure that what I said originally was what I observed, however....)   what I'm seeing now is that on a split synth track whichever track text box has been edited, that text box  alone does not get updated by replace synth. This can lead to even more confusion  visually (for me, anyway) .  But the behaviour does at least seem to be consistent.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...