Jump to content

Instrument Plugins UI do not show up

Paramvir Singh

Recommended Posts


I am here in the hope I will get this sorted asap. Please help.


While working on a Cakewalk project (referred to as project A below), VST instrument (in my case TTS-1) track's keyboard icon or the one on the Synth Rack has stopped showing the instrument UI. The instrument is sounding ok from what I have already recorded on the track, but the instrument itself is not showing so I am not able to work with the instrument interface. When I click on the keyboard icon, simply nothing happens.

I have tried:

  1. Creating another project in the same Cakewalk instance. The same issue shows with the new project.
  2. Closing the current instance and creating a new instance.
    1. When I create a new project in this instance, then the problem is resolved.
    2. When I open project A first, then the problem persists, even if I create a new project.
  3. Create a copy of the project and open it in a new instance. Does not work.
  4. Creating a new project and copying my tracks from A to this new project. Does not work.

So, basically, project A has some setting that makes the cakewalk instance not show the instrument UIs. 

It is perhaps important to note that prior to experiencing this issue (I can't recall the exact event that triggered this), I was trying to load default Cakewalk instruments into the instruments window on the right panel. I ultimately succeeded in showing them there, but editing VST Settings from Preferences, by Resetting and probably tweaking some other settings (if any) there (that I do not fully recall). I have attached a pic for the Dialog Box state here.


Has someone experienced a similar issue and did you find a solution? I have already wasted several hours on solving this but can not find a way out.

Happy to provide more info.

Thanks in advance.

Edited by Paramvir Singh
Link to comment
Share on other sites

@Jack Cat It is with all instruments (not just with TTS-1). Yes, I clicked the icon from within the synth rack too. It still does not appear. Also, if I open a new instance, and then create a new project, (as I mentioned in the main post) it shows the instruments by clicking the keyboard icon or from synth rack. But as soon as I open project A in the same instance, the previous project stops showing the UIs of its instruments again.

Even adding a new TTS-1 track does not show the UI.

Link to comment
Share on other sites

Hmm, you might want to post a sample of the project. There doesn't need to be audio in it just the midi stuff. I haven't done this here yet but I think you can save it to a cloud server like one drive and share the link using the " Insert other media "?  below, 

Link to comment
Share on other sites

Yes, A CWP but without the audio, Use " save as" and uncheck the copy audio with project box. Or even if you just copy/ paste the  orange CWP icon from the projects folder to One Drive or? The project will just open complaining about missing files that's all. Either way it's the midi part that needs to be looked at. 

Here I just did that, I just dragged the CWP file to the blue thing at the bottom. 

AT the HOP.cwp

Edited by Jack Cat
  • Like 1
Link to comment
Share on other sites

[SOLVED] Thanks a lot @Steve_B. Spot on.... I am using two screens. Although I have selected my secondary screen for the display (so that the primary screen should not be used), but it turns out that CakeWalk was sending the instrument UIs to that primary screen anyway. 

Thanks @Jack Cat for all your help too. Much appreciated. I could learn a few more things in the process of chasing this issue. 

An open source DAW like Cakewalk is a great contribution to the community.




  • Like 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...