Jump to content
Nigel Jackson

Getting there...slowly!

Recommended Posts

I'm very new to MIDI/mixing/drums (only recently starting learning!) and only using CbB to play Steven Slate SSD5 drum sounds when I play...I'm not using CbB to create or record.

After quite a bit of faffing around I've finally got my Roland TD-17 triggering SSD5 in CbB , and can hear the SSD5 drum sounds through speakers or earphones which are connected to the TD-17.

But I've no idea if the method I've used is the CORRECT way to do this, and if I turn down one of the knobs in the master inspector panel I can hear the normal TD-17 sounds.

Can anyone tell me if this is the right way to do this - sorry if my terminology is wrong?...

- Select ASIO driver mode
- Start an empty project
- In the Browser select the instrument panel, select Steven Slate SSDSampler5 and drag it into the Track Pane
- The Insert Soft Synth Options dialog opens - select Simple Instrument Track, click OK
- In the track set the input to Midi Omni
- In the Inspector I can now see the ProChannel - in the TUBE section if I turn up the Output knob I hear the SSD5 drum kit when I play. If I turn down the Output knob I hear the TD-17 sounds

Am I doing this right? Am I still able to hear the TD-17 sounds because I have the speakers/earphones plugged into the TD-17, not coming off the laptop? In the TUBE section, how should I use the Input and Output knobs - should they be balanced - if not, what?

And maybe a load of other questions later!

Thanks,

Share this post


Link to post
Share on other sites

The pro channel is for inserting effects to a track. It is not for routing audio. I think you’re over boosting the signal using that effect. Don’t. 
The instrument track you inserted will need the input echo button on and have its output set to a master buss which should then go to your sound device. 
To hear the VST drums your headphones will need to be plugged into the computer or audio interface not the drum brain. Unless you have an audio connection from the computer to the auxiliary input of the brain if it has one. Then you’ll hear both. 

The midi connection over the USB cable doesn’t carry audio. Only midi data. 
Use WASAPI exclusive mode to try and reduce the latency. Otherwise you are bound to hear the VST drums later than your drum kit. This makes playing un enjoyable. 
if the VST has a stand alone mode you might be better off using that. 

Share this post


Link to post
Share on other sites

Thanks John.

So basically I’ve not done this right at all 😂.

The echo button is definitely on.

The ProChannel appeared when I added the instrument. If I shouldn’t use that, what controls should I be using in the inspector?

So the reason I’m hearing the sounds from both the brain and CbB is because I have the output directed back to the TD-17, and you can’t turn off the brain’s own output afaik. But I can turn the kit mix volume down…not sure if I can turn it off though.

There is an aux input to the brain, but if I can’t turn the kit mix volume off sounds like I need a small mixer for laptop/CbB in and speakers/headphones out?

Thanks.

Share this post


Link to post
Share on other sites

Yes the pro channel seems to show instead of the track strips but that’s easy to toggle Watch my Navigation video for that. Also the one on VST instruments And the Audio one explains signal flow. 

Yes a small mixer might be a good solution and they certainly are handy for other things   I have one so I can keep all my hardware plugged in including my Yamaha DX drum kit. What I like is it makes headphones mixing super fast. And louder too.  

Edited by John Vere
Remove videos

Share this post


Link to post
Share on other sites

Cool, thank you John.

Can I ask a question (before I watch the videos, so it might be answered, sorry!)?

I have my setup 'sort of' working but not sure if it's right...

  • The Roland brain is sending MIDI to my Focusrite interface
  • Speakers are now connected to the interface
  • My laptop with CbB and SSD5 are connected to the Focusrite by USB

I've got it so when I play the real kit, the SSD5 kit is reacting correctly onscreen, and the SSD5 sounds are coming out of the speakers :) . But, I had to add a 'simple instrument' track in CbB to make it work. I first tried adding a MIDI track, set the inputs and outputs and could see the meters in CbB moving, but there was no sound coming out. Is that correct, I should use a simple instrument track?

Thanks again.

Share this post


Link to post
Share on other sites

Any plug-in that scans as a synth must be associated with an audio track even if it is incapable of generating audio data (ex. sequencers).

Most also use a MIDI track to receive MIDI data.

An instrument track is a wrapper around an audio+MIDI track pair.

Share this post


Link to post
Share on other sites

Yes.

There are only two basic track types in CbB: audio and MIDI.

All the other track types are derived from these.

An instrument track is really just a wrapper around an audio+MIDI track pair. That is why the track inspector for an instrument track has an audio tab and a MIDI tab.

An audio+MIDI track pair pointing to the same synth may be merged into an instrument track.

An instrument track may be split into its audio+MIDI track pair.

The merge and split options are on the track header context menu.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...