Jump to content
Misha

Recent updates causing Audio dropouts / engine stopped Please help!

Recommended Posts

Hi Folks.

Before I posted this, I tried tackling with the issue for good 2+ hours. Nothing seems to help, so here it goes.

Never had such issues before on previous system or current. Current system: i7 (8th)Thinkpad  2.6ghz 6 core. 32Ram,  nmve SSD.  Since new system, I had been working with about 25 projects. Never gave me issue with audio dropouts.

I stepped out for a few days from music making.  Lenovo pushed some critical updates (Bios, Intel management and SSD firmware update)  +Windows pushed their updates...Now I get: The audio engine has been stopped unexpectedly.... with same project settings in Cakewalk as before, when I did not have dropout issues.

Before this thing happened on me, I was able to work either with native, Realtek chip with Asio4All set at 256 to 512 latency or standalone Asio card with similar settings.

 

What I tried: 

Checked power plan. Everything is on High Perfomance.

Tried native Realtek chip Wasapi Exclusive/Asio4All, pushing buffer to whooping 2048 Samples, just for the testing purposes.

Same with standalone ASIO card, keeps droping that audio even with high buffer settings.

Restarting computer, looking at BIOS (Power management is OFF, all set to High Performance)

Task Manager shows the usage of resources at about 30%  when playing project. Not spiking.

--------------------------------------------------------------

Audio is crackling.... Getting that Audio Engine stop thing.    I believe it is "update" related. But not sure what is causing this and how to fix it...

The key here is: It was working fine now it does not. So not looking to "optimize" system, but to find the cause of the problem.  Last resort scenario also looks bleak, since some hardware firmware was updated, I do not believe that re-imaging would help.

Can anybody please try to help?

Thank you!

 

 

 

 

Share this post


Link to post
Share on other sites

Try deleting your AUD.INI from %APPDATA%\Cakewalk\Cakewalk Core\

If that doesn't do it, uninstall then re-install the ASIO drivers for your standalone card, then delete AUD.INI from %APPDATA%\Cakewalk\Cakewalk Core\

 

Edited by msmcleod

Share this post


Link to post
Share on other sites

msmcleod,

Thank you for trying!

 followed that.... did not help. I even reinstalled Cakewalk too,  when suggestions failed.

I do not believe it is directly related to specific card (internal or external), because both were working before without any issues and now both of them exhibit same pattern of behavior.  Almost as computer does not have enough resources...But I know it has plenty because same projects were working absolutely fine last week.

Man, I wish that little Cakewalk "Audio Dropout"  pop up would have a specific cause of the issue.  Not sure what else to try...

 

Share this post


Link to post
Share on other sites

ok, getting some clues. I was looking at CPU monitor when dropouts occurred, and did not spot anything suspicious, but then I saw a spike on network window. I turned network "off" seems like it is helping.  Caught that right before I left home, so need to do more testing. I know it considered to be "good manners" to turn off network when working with audio...but I am not very well mannered guy, as this was never an issue that effected me. Can somebody point me to the right direction to fix Network+Cakewalk issue? Is it to: give priority to programs and not to background services setting or something else?

 

Thank you.

Share this post


Link to post
Share on other sites

Spoke too soon., it is not wireless adapter. 

LatencyMon shows this wonderful thing: Wdf01000.sys    that has issues. /creating latency. Not sure if IT is the actual problem,

but the dropouts/audio engine has been stopped  unexpectedly thing is not "occasional" .,  Cakewalk starts acting up from first few seconds.

Anybody?

Thank you.

 

 

 

Share this post


Link to post
Share on other sites

Disable the HDMI audio for your video card in device manager and make sure core parking is disabled.

 

Share this post


Link to post
Share on other sites

Misha : got to your thinkpad support page and do or re do the INF/chipset driver ..In bios turn off on board audio and anything else your not using .. win 10 updated here with no issues .. this time.. some times I have to reinstall my m-audio firewire 410 driver cause update screws it up.. you might want ti reinstall your audio driver … too

 

Edited by StarTekh

Share this post


Link to post
Share on other sites

Thank you to all who tried to help! Still, damn thing doesn't want to cooperate. 

Couple of more hours tackling the issue. 

Tried:
Parking CPU (through regedit)
Reinstalling Chipset drivers
Creating new "High Performance" power profile
Rolling back Realtek driver to previous version / reinstalling new

Rolling back USB audio driver / reinstalling freshly downloaded
Checking USB ports in device mgr for power saving...
Even tried go back to one of restore points before the issue started about 6 days back... but got BSOD, so had to come back to latest build.

I even thought that it might be Spectre and Meltdown patch related, as Microsof noted to expect decrease in performance... My machine falls into a 1 digit performance decrease (after the patch), so I doubt it is that.  

 

Do not know what else to try...

Edited by Misha

Share this post


Link to post
Share on other sites

Checking BIOS settings something like CPU power management, etc? If BIOS has these settings...

Share this post


Link to post
Share on other sites

Updates can re-enable things that were previously disabled, and the Wdf01000.sys issue is commonly linked to "Automatic Network Discovery" which basically pings for Wi-Fi devices in range every 3-4 seconds. There is no reason to have that enabled... if you want to connect something, it is safer to manually search for it and connect it. To disable, go into "Control Panel->Network and Internet->Network and Sharing Center->Advanced sharing settings" (on Win10) and select "Turn off network discovery" in both the Private and Public sections. This does not disable the network from functioning, but disables it from constantly pinging.

Edited by mettelus

Share this post


Link to post
Share on other sites

HIBI, Thanks. Double checked. Not the BIOS. All power "savings" turned off.

----------------------------------

mettelus,

Excellent  suggestion! Thank you! Got much better.

My issue is definitely resource related, but not very obvious.  Processor is i7-8850H which is fairly decent for my tasks and it was pulling everything very well (30+ tracks whole bunch of VST FX/synths) without any issues/hiccups for several month. This recent "update" was not very polite... Turning off discovery, reduced latency significantly. Last thing on the list was (is) ACPI.... And that is telling me that it is power management related item.  As soon as I switched that off in CP, Cakewalk started to behave like a good child. This is not a permanent solution as by turning ACPI off turns off battery charging, but at least now I know where the evil is coming from.

I found one other item that now, I feel worth investigating. If I turn FX off in Cakewalk, everything runs smoothly... We had a discussion here a couple of month back about plugin "load balancing". To my understanding, this feature in Cakewalk was designed to spread the load of VST's onto multiple cores. 

Looking at CPU cores in Latencymon, while playing back VST heavy project, I saw that only first core (out of six) is taking most of the load... In Cakewalk monitoring window (upper right) it shows that all cores are active pretty much equally... Not sure how to explain this. In task manager CPU usage shows around 35-40% under full load.,  maybe Cakewalk has these dropouts because it is using less cores and putting more stress on these than it could...?

 

Thank you.

 

 

 

Edited by Misha

Share this post


Link to post
Share on other sites

Windows Task Manager is looking at the system level, and CPU 0 is the "workhorse" of any Windows system, since every system has a Core 0. IIRC, Cakewalk was change a long time ago so that the CPU usage reflects only what Cakewalk is using, so that should be balanced fairly well... however, not all VST(i)s can be shifted from Core 0.

If the system loads Core 0 with that project running in Windows Task Manager, you may want to try dissecting that project by first doing a "Save As..." to a new name (be sure to do this step so you have the original project intact), then removing VST(i)s and/or archiving tracks from the copy to find the CPU-hungry ones. Unfortunately, there is no definitive list of these, and no way to monitor them from within Cakewalk, but I believe that was a feature request long ago on the old forum.

*If* you get into a situation where you need to bake-in VSTis, the "Save As..." feature works well, allowing you to bounce to track(s) and archive the original tracks so that you can work with only audio for the ones that are completed. The original project files should be small (sans unbounced Melodyne edits), which will let you back out of an archiving situation cleanly (there have been reports of un-archived tracks losing settings in the past, so play that one safe).

Since I mentioned Melodyne... also check if you have unbounced Melodyne edits (project file size being in the MB+ range).

Share this post


Link to post
Share on other sites

mettelus, Thanks!

Good wealth of information. (digesting :)) 

Actually turning off ACPI from control panel + disabling network discovery as you suggested, got me where I need to be.  Part of Lenovo update was "power management firmware", I can not unroll it. I guess that what is happening... It manages processes differently than it was prior to update and somehow encroaches on my Cakewalk. 

Wondering if it is possible to move ACPI process to another core? Will do some reading later today. 

This forum is a treasure. I want to thank everybody who helped! Big thanks to mettelus!

P.S. Now, that problem of what was chewing my Cakewalk is narrowed, I will post back when/if I find a solid  solution without disabling ACPI.

Share this post


Link to post
Share on other sites

You may also have core parking enabled, which is a Windows thing. I just tried a quick Google search for disabling core parking and am coming up with Registry changes to achieve it. I forget offhand how to access that in Windows 10 without having to drill into the registry (some are not comfortable with editing the registry).

Since you are on a laptop, that update may very well have enabled core parking on you. Core parking allows cores to drop to a 0% use state, which will be counterproductive for DAW use... BUT you also never want to run as a DAW unless plugged in (another reason it is used is to conserve power).

*If* you are comfortable editing the registry, you can Google "how to disable core parking in windows 10" and the first video that pops up shows this and the key to search for.

Share this post


Link to post
Share on other sites

mettelus,  Thanks!

yes,  one of the first 10 things I tried to fix this was "un-parked" CPU 

Turning off network discovery helped a lot.

P.S. I am not tech guru, so forgive me if I sound silly, but I think it would be a very useful feature if Bandlab develops a built diagnostic tool that would  pinpoint exact hardware / software tensions and clashes that particularly effect Cakewalk stability  and would offer suggestion to remedy these.

Edited by Misha

Share this post


Link to post
Share on other sites

You had mentioned if you turn off effects, your issues dissipate, or words to that effect (no pun intended).

Is it possible that you have any effects loaded into the project, and turned on, that are massively CPU-intensive?  Some types of plugins are designed to be used in mixing/mastering, and not for tracking/recording.  Plugins, like convoluted reverb effects, use a technique, called look-ahead processing, that results in them needing a VERY large ASIO Buffer Size to give them enough room to do their thing, and trying to either track/record or even simply playback a project that has such plugins loaded, without first making sure the buffer size has been made large enough for their needs, results in audio issues.

The general advice for setting the ASIO Buffer Size, is to set it small enough, during tracking, to keep latency low enough to where it does not become noticeable, while not setting it too low, because that too can cause audio issues.  On the other side of things, once a given project's tracking has finished, and the workflow moves into mixing, then the ASIO Buffer Size should be made large enough to accommodate the use of plugins such as convoluted reverb effects.

While, during tracking,I COULD set my ASIO Buffer Size down to 32 samples, that to me is too close to where it is too small, so I generally run with mine set to 128 samples.  It results in a low enough latency to where I don't hear it, and it is large enough to where my system easily handles it with no audio issues. 

Conversely, when I begin mixing, I change my ASIO Buffer Size to either 1024 or 2048 samples, where latency isn't an issue, because I am not trying to track/record now, I am simply playing back and mixing. and the large buffer gives the more robust effects enough room to do their thing.

So pretty much for the rest of time, I will always shift the ASIO Buffer Size between pretty low and super large, as I am either recording or mixing.

By the way - you might also consider picking up an audio interface, rather than using ASIO4ALL.  ASIO4ALL still uses the CPU to do all the heavy lifting, whereas an actual audio interface would transfer that buffer processing to the interface's circuitry, away from the CPU.  I just checked current choices and prices at Sweetwater - other music gear stores will have similar offerings - and they have USB audio interfaces running as inexpensive as around $30.  Prices go up for things like better and more features, such as the number of inputs and the quality of the mic pre-amps, but nowadays, interfaces that used to run around $150-$200 are now selling for $89-$99, and even the cheaper ones will still take the load off your CPU.

Hope the above helps - and it may indeed have nothing to do with your issues, but if it DOES, then hopefully I have explained it well enough.

Bob Bone

Share this post


Link to post
Share on other sites

Bob,

thank you for extensive post and trying to help! To clear misunderstanding. I have very powerful computer (for my needs) , that I recorded my projects with. It handled everything absolutely great before recent Windows and Lenovo updates, which came almost simultaneously. After these updates, same  projects that were flying under heavy load  begun to experience severe problems.  With help of folks  (posts above), I got it under control.  It has to do with power management mostly... I am afraid it is power management firmware that I am up against and not your average software that is possible to "unroll".  Lenovo has a tendency of issuing half baked drivers and firmware. Hopefully their gurus correct on next update.

You have some really important points written out. Especially about "look ahead" VSTs... and other items such as mixing/tracking buffers, etc.  Which I knew, but you put in a compact, easy to read/understand form, which I am sure will be picked up by current and future users.

I do have (actually 2) Asio interfaces, which I tried before posting this cry out :) 

 

 

Share this post


Link to post
Share on other sites

I'm working on a project that is close to the edge and use an rme 9643 pci card. DPI latency is waaay low, asio ibuffers are always 1024. Suddenly I experienced what you described where it will play along then start "chewing" on the audio then dropout and stop.

I chased that one too until I was at wits end and noticed the midi in indicator was full on when playing as if something was really dogging Cakewalk. I have 4 bcr2000s, a 88 key keyboard and drum set all connected via 5 pin din midi. So, I disabled all the midi ports including a tranzport and rtp midi for touchdaw. Things got better but not great until I saw a midi track record enabled. When I un-record enabled that midi track all seemed to settle down and I can fuss n' mix again without trouble. I haven't re-enabled the midi inputs to cakewalk as well, I'm not overdubbing midi anymore. I was, adding a b3 part to a "done" song when all this began to happen fwiw.

Best of blessings with your issue.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...