Jump to content
PavlovsCat

How do add parts to a soft synth/drum vst track and hear parts you've already recorded when playing additional parts?

Recommended Posts

I wasn't sure of the appropriate section to post this question in, so sorry if I got it wrong. I have been using Cakewalk and haven't figured out when I create say, a new track with a soft synth -- let's say for Addictive Drums 2 -- and I create a drum track. So let's say I lay down the basic groove and then I want to record some additional cymbal accents on the track in a second pass. How am I able to record those additional parts and hear my earlier recorded parts too? As when I record COMP, OVERWRITE or SOUND ON SOUND, I cannot hear my previously recorded part for the track I am recording on. I wouldn't think Cakewalk would require that I have to create a second track with another instance of Addictive Drums 2 for accents -- please correct me if I'm wrong. Otherwise, I'm guessing there is a simple way to do this, but I have never figured it out. 

Thanks in advance. 

Share this post


Link to post
Share on other sites

Setting the recording mode to Sound on Sound is the usual way to do this, however if you're using Auto-Punch, there's an additional "Mute Previous Takes" setting - you want this to be unchecked.

Share this post


Link to post
Share on other sites
12 hours ago, msmcleod said:

Setting the recording mode to Sound on Sound is the usual way to do this, however if you're using Auto-Punch, there's an additional "Mute Previous Takes" setting - you want this to be unchecked.

Thanks for replying. As I wrote in my original post, I use SOUND ON SOUND when I am recording and when I do an additional take on an existing track (I forget -- maybe these are called lanes? The additional midi tracks for a particular soft synth), once I press record, Cakewalk does not play what I've already recorded on that track. So, as in the example I provided earlier, if it's a drum track using AD2, and I just want to add some cymbal accents and maybe a tom fill, the earlier recorded part does not play back as soon as a hit record. In fact, I just tried it now  to ensure there isn't any setting I'm missing. So to be as clear as I can,  I have a track where the soft synth is Addictive Drums 2. I've already recorded the main drum part but want to add some cymbal accents and tom fills, but when I press record, I can no longer here the drum part I've recorded on that track so I am forced to create my cymbal accents and tom fills without the benefit of hearing them along with the existing drum part. 

I assume that others have figured this out, but I couldn't find an answer after searching. 

Share this post


Link to post
Share on other sites

@PavlovsCat - can you post a screenshot of your record settings from preferences (use ALT + PrtSc to just capture the dialog), e.g.:

image.png.fbf42d4d4a189ecc7f5afdf00a959b2c.png

FWIW, I'm getting exactly what you're wanting achieve with the settings above.

Share this post


Link to post
Share on other sites

Except for one box, "New Takes on Top" our screen shots have the identical things checked. I unchecked that box to make it identical to yours but the when I press record, the previously recorded midi part on the track I'm recording on is silent. When I press play again, the sound returns. 

image.thumb.png.e8a34c809b8bce76fd14c392b2f57aa7.png

Share this post


Link to post
Share on other sites

@PavlovsCat - I was trying to repro using your settings, and managed to do so.... but it wasn't to do with the settings, but the fact that the record button itself in the transport area was set to Comping.

So it looks like, for some reason, the recording mode in the transport is somehow de-coupled from the one in settings.

Right clicking on the record button and setting it to Sound on Sound got everything working agin.

  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, msmcleod said:

@PavlovsCat - I was trying to repro using your settings, and managed to do so.... but it wasn't to do with the settings, but the fact that the record button itself in the transport area was set to Comping.

So it looks like, for some reason, the recording mode in the transport is somehow de-coupled from the one in settings.

Right clicking on the record button and setting it to Sound on Sound got everything working agin.

The only way I've ever modified this setting from COMPING, OVERWRITE and SOUND ON SOUND is by right clicking on the record button at the top of the GUI, so that solution results in me seeing the identical, unchanged screen. I went into PREFERENCES  to access the screen that way and it is indeed the identical settings there too. I take it that PREFERENCES is what you meant when you wrote "settings"?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...