Jump to content

Recommended Posts

Hi:

I'm a long time Cakewalk user. In the past I used to have a multi port MIDI interface (now obsolete) and connect all my synths there.

Now I don't have that MIDI interface anymore and, as most modern synths have USB MIDI, I connect all my synths directly to the computer.

The problem is that not always want to use all my synth, sometimes I just turn on a single one and Cakewalk just mess all MIDI port selection on the MIDI tracks. The MIDI data (notes, etc) is sent to the wrong synths. I have to set the MIDI port for every MIDI track every time.
Even if  I turn on all my synths, sometimes Cakewalk  change the order of MIDI ports and again I have to set the MIDI port for every MIDI track.

Same happens when sending MIDI clock to my drum machine, after opening a saved project the MIDI ports are in a different order and the MIDI clock is sent to a different port so my drum machine doesn't start.

Also if I have set an instrument definition for a MIDI port, I lost that assignment...

So, please make Cakewalk remember the MIDI port settings. If I have a MIDI track and the MIDI port output is set to a MIDI port named SynthX (all my MIDI ports have the name of the synth), next time I open the project that track should be assigned to the MIDI port SynthX, and if that MIDI port is not available (not connected), should be routed to a dummy MIDI port, not to other MIDI port, if I want to route that MIDI data to another MIDI port I will do it myself manually (letting Cakewalk choose a random MIDI port doesn't help).

Thank you!

  • Great Idea 1

Share this post


Link to post
Share on other sites

There's a bit of a hack that I think works (I've run into the same with my control surface, which I rarely turn on):

- Turn everything on
- Run Cakewalk and set up the MIDI ports as you want them to be set up
- Close Cakewalk
- Open Windows Explorer and navigate to %APPDATA%\Cakewalk\Cakewalk Core
- Find ttseq.ini, and right click on it, and choose Properties
- Tick Read-Only and click OK

Of course, if you want to make changes to your MIDI setup, you'll have to un-Read-Only it, then start at the first step here again.

  • Like 3
  • Great Idea 1

Share this post


Link to post
Share on other sites

What you have discovered is the un talked about down side to USB midi. 
Din 5 pin midi always works as long as the midi interface has good drivers and is set up correctly.
You can run a room full of gear if your interface supports multi ports. And it doesn’t care what is turned on or  off, if it’s off it just becomes a dead end. 

But USB has become standard now because generally everything is ITB and few people have a room full of midi hardware. We’re on our own now. 
One solution is a power bar that fires up external hardware. You have to remember to turn this on before you load a project that uses it. 
Cakewalk midi device list is the heart of this issue. If a device is missing it will not be on the list. I guess this is due to Windows also not finding the device. 
Not only that if you open a project find a missing device, some midi driver’s allow you to turn it on and Cakewalk will see it and ask if you want to use it. Then this may work or not work and you have to close Cakewalk and re open to add the device.
Sometimes it still isn’t working so you have to re check it on the device list. 
Example is my Yamaha DTX 400 drums. It is USB but it has a stupid feature where it turns off if you are not using it. If I turn it on Cakewalk asks if I want to us it but even after saying yes it is not on the device list. 
But my Roland A49 will connect and works with out rebooting cakewalk. 
If my Yamaha kit had a real midi port I would use that for sure problem solved. 

The only solution I can see that is possible is that Cakewalk would have a way to lock the midi device list so even disconnected device show as ghosts and a reset button for these situations. 
The audio device list seems to do this. There’s always a ghosted Tascam us1641 when I’m using my Motu. I can switch interfaces with out rebooting cakewalk 

  • Like 1

Share this post


Link to post
Share on other sites

Cakewalk's handling of MIDI port changes is way better than it used to be, at least.

It used to be that if I unplugged my nanoKONTROL II, Cakewalk would automatically map the next MIDI port to control surface duty, whether it was already in use or connected to an actual control surface or not. Which in my case meant that the MIDI input in my main interface would stop paying attention to my keyboard. This caused me much wasted time and frustration trying to figure out why all of a sudden I couldn't get MIDI data into Cakewalk from the keyboard controller no matter what I tried. It was because Cakewalk had stopped listening for notes from it and started listening for control surface commands, which it was never going to get.

Now it doesn't remap, and it at least tries to correctly map reconnected USB gear. Looks like it's not always getting it right.

Share this post


Link to post
Share on other sites
On 10/2/2021 at 2:40 AM, Kevin Perry said:

There's a bit of a hack that I think works (I've run into the same with my control surface, which I rarely turn on):

- Turn everything on
- Run Cakewalk and set up the MIDI ports as you want them to be set up
- Close Cakewalk
- Open Windows Explorer and navigate to %APPDATA%\Cakewalk\Cakewalk Core
- Find ttseq.ini, and right click on it, and choose Properties
- Tick Read-Only and click OK

Of course, if you want to make changes to your MIDI setup, you'll have to un-Read-Only it, then start at the first step here again.

Thank you Kevin, I will try that.
If it works it will do my life a lot easier :)

Share this post


Link to post
Share on other sites
Posted (edited)

Hi all,

I come back to ask if this problem can be solved.

Setting ttseq.ini to read only is not very helpful. It makes Cakewalk sets the ports in the correct order, but only  helps when I turn on all the synths, because as soon as I have one turned off the MIDI routing becomes a mess... (as I explained in the first post).

I know this can be solved because I have several other MIDI software that works properly and remembers the MIDI port assignments.

I don't know if it is a more direct way to make a feature request (or should I call it bug report?) to Cakewalk/Bandlab.

Edited by Sebastián Cordovés
  • Great Idea 1

Share this post


Link to post
Share on other sites
Posted (edited)

I seriously thought that this had already been addressed (no pun). Or was it only how Cakewalk would usurp the next available port for control surface duty if you started with your USB MIDI control surface unplugged?

And yes, Windows manages USB ports, but so what? That does NOT mean that Cakewalk should lose track and shuffle them around if you unplug a device and then restart the program. I believe that each USB MIDI device gets its own GUID, but even if that's not the case, most of the ones I've seen have unique friendly names, which Cakewalk can and does read (it displays them, after all).

Just because Windows manages them doesn't mean that Cakewalk can't or shouldn't gather and maintain its own information about them.

So IMO, Cakewalk doesn't have to lose track (no pun). Even if I'm wrong about the GUID's, at worst it might be lose track in the case of two USB MIDI devices with the same friendly name, which is a thing that I've yet to see.

If you want to see the information that Cakewalk can get from the OS regarding USB ports and devices, there's a freeware utility called USBDeview (scroll alll the way down to download it) that will show you. Each USB device has a manufacturer number and a product ID, which you can also read right from Device Manager: https://www.the-sz.com/products/usbid/ There's plenty of information supplied by the OS to distinguish one USB MIDI port from another.

A program should be able to look at that list, notice which devices are still there from the last time it started, which of them are not, and retain its configuration for the ones that are still there.

As the OP points out, there are other Windows programs that don't have the same issue, which suggests that it's possible to address.

I thought that it had been addressed. It no longer causes trouble for me, anyway, but that might just be for the control surface issue.

Edited by Starship Krupa
  • Like 2

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...