Jump to content
dantarbill

No Copy Track Import

Recommended Posts

I'm dealing with weekly live multi-track recordings captured direct to an external drive from a QSC TouchMix board.

When you import a .wav file into a track in Cakewalk, you have the option "Copy audio to project folder" marked by default.   When you do that, the file is copied to <projectName>/Audio and is then referred to internally by a relative path...so...when you move the project "projectName" somewhere else, it still knows where that file is.  (At least, I think that's how it works.)

Let's say then, that I want to avoid costly file copies.  I'm dealing with 2 hour, 44.1 kHz, 32 bit tracks that take about 4 1/2 minutes per track to copy on import...one at a time...with about 20 tracks.  This is time and labor intensive.

What happens if I bulk copy those files directly to  the <projectName>/Audio folder and don't select "Copy audio..." on import?  In the short term, I imagine that should work, but internally, are those files now referred to by a fully specified path that will lose track of the track files if the project is moved?

 

Share this post


Link to post
Share on other sites

Sure copying files into the project audio folder works but the files are not known to the project until they are actually referenced in the project either by using the import dialog or dropping the files into the project from the OS or media browser.

Copying a project folder at the OS level will copy everything in the folder but  the "Save As" in the DAW only knows about the files referenced in the project.

Share this post


Link to post
Share on other sites
8 minutes ago, scook said:

Sure copying files into the project audio folder works but the files are not known to the project until they are actually referenced in the project either by using the import dialog or dropping the files into the project from the OS or media browser.

Copying a project folder at the OS level will copy everything in the folder but  the "Save As" in the DAW only knows about the files referenced in the project.

Perhaps I wasn't entirely clear...

The idea is to copy the files to <projectName>/Audio first.  Next import each of the files into Cakewalk tracks, but without selecting "Copy audio to project folder" on the import (and the 4 minute penalty).  So now, wav files are assigned to (and referenced by) Cakewalk tracks.

My fear is that Cakewalk will then refer to those tracks with an absolute rather than a relative path and get confused when the project is moved.

Follow?

Share this post


Link to post
Share on other sites

It should work fine.

Pretty easy to test too.

Rather then use the import dialog for clips already in the project audio folder I use the media browser and drag them into the project.

Share this post


Link to post
Share on other sites
43 minutes ago, scook said:

It should work fine.

Pretty easy to test too.

Rather then use the import dialog for clips already in the project audio folder I use the media browser and drag them into the project.

With the drag import it still creates a copy (<filename> (n).wav).

Moreover...even if I unselect "Copy audio..." on import...it still copies.

Edited by dantarbill

Share this post


Link to post
Share on other sites

I don't see that.

When I

  • create a new project,
  • copy an audio file into the per-project audio folder and
  • drag the audio file into the project from the CbB media browser

the clip is in the project and the audio folder only has one clip in the project audio folder. 

 

Share this post


Link to post
Share on other sites
20 hours ago, scook said:

One thing to check is the Import Bit Depth setting.

I use the default value Original.

Hmm...I tried that, with the same results I was getting before.  The difference might be that I'm importing into a project with the audio driver recording at 24 bits, but I'm pulling in 32 bit files (with matching sample rates of 44.1 kHz).

The sizes of the original and copied files are slightly different (3,380 bytes).  That could be because Cakewalk isn't just doing a OS level file copy.  It likely that it's also rewriting the .wav file header with some data that wasn't there before.

Share this post


Link to post
Share on other sites

I've found the "secret sauce".  The problem was importing 32 bit files into a 24 bit project.

However, QSC has a TouchMix Utility to help with track import.  One of the options I hadn't noticed before was the option to quantize the tracks down from 32 bits to 24 bits while it's doing the transfer.  With 24 bit tracks in had, Cakewalk is happy enough to accept the files without another copy.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...